summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2008-03-01 20:33:21 +0000
committerIlya Volynets <iluxa@gentoo.org>2008-03-01 20:33:21 +0000
commitc638b960466cc878a7a6506c5ac188e72de1f521 (patch)
tree8abba3e0feaf8287ab32e66795a6d762a7c2f7b7 /dev-cpp/cppserv/cppserv-0.1.102.ebuild
parentversion bump from upstream (diff)
downloadhistorical-c638b960466cc878a7a6506c5ac188e72de1f521.tar.gz
historical-c638b960466cc878a7a6506c5ac188e72de1f521.tar.bz2
historical-c638b960466cc878a7a6506c5ac188e72de1f521.zip
-Add "debug" use flag
-Depend on apache-2 and up Install apache config fragment into correct place Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-cpp/cppserv/cppserv-0.1.102.ebuild')
-rw-r--r--dev-cpp/cppserv/cppserv-0.1.102.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-cpp/cppserv/cppserv-0.1.102.ebuild b/dev-cpp/cppserv/cppserv-0.1.102.ebuild
deleted file mode 100644
index c1bfbad2c148..000000000000
--- a/dev-cpp/cppserv/cppserv-0.1.102.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cppserv/cppserv-0.1.102.ebuild,v 1.2 2008/01/13 09:50:55 iluxa Exp $
-
-inherit eutils apache-module
-
-DESCRIPTION="CPPSERV is an application server providing Servlet-like API in C++, as well as CSP (C++ Server Pages) parser."
-HOMEPAGE="http://www.total-knowledge.com/progs/cppserv"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~x86 ~mips ~amd64"
-IUSE=""
-
-APACHE2_MOD_CONF="75_mod_cserv"
-
-DEPEND="net-libs/socket++
- >=dev-cpp/sptk-3.5.6
- =www-servers/apache-2.0*
- dev-libs/boost
-"
-
-need_apache2
-
-src_compile() {
- emake PREFIX=/usr ADON_VERBOSE=1 ADON_BUILD=release || die "emake failed"
-}
-
-src_install() {
- emake PREFIX=/usr ADON_BUILD=release DESTDIR="${D}" install || die "emake install failed"
- insinto "${APACHE2_MODULES_CONFDIR}"
- doins "${FILESDIR}/${APACHE2_MOD_CONF}.conf" || die "internal ebuild error: \"${FILESDIR}/${APACHE2_MOD_CONF}.conf\" not found"
-}