summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Buisse <nattfodd@gentoo.org>2006-01-19 17:50:03 +0000
committerAlexandre Buisse <nattfodd@gentoo.org>2006-01-19 17:50:03 +0000
commit0da7ca265959c208c1f99b7d4e9837a370aac3fa (patch)
treefb1f03df1e683d8800a6ea34dfff1343f4ec45af /dev-cpp
parentUpdated for new style virtual/pcmcia. (diff)
downloadhistorical-0da7ca265959c208c1f99b7d4e9837a370aac3fa.tar.gz
historical-0da7ca265959c208c1f99b7d4e9837a370aac3fa.tar.bz2
historical-0da7ca265959c208c1f99b7d4e9837a370aac3fa.zip
Minor changes, mainly in USE flags
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/ice/ChangeLog7
-rw-r--r--dev-cpp/ice/Manifest6
-rw-r--r--dev-cpp/ice/files/ice-3.0.0-makefile.patch59
-rw-r--r--dev-cpp/ice/ice-3.0.0-r1.ebuild17
4 files changed, 51 insertions, 38 deletions
diff --git a/dev-cpp/ice/ChangeLog b/dev-cpp/ice/ChangeLog
index 50a0f9d35b0a..fac29e953bae 100644
--- a/dev-cpp/ice/ChangeLog
+++ b/dev-cpp/ice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/ice
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ChangeLog,v 1.1 2006/01/19 15:35:47 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ChangeLog,v 1.2 2006/01/19 17:50:03 nattfodd Exp $
+
+ 19 Jan 2006; Alexandre Buisse <nattfodd@gentoo.org>
+ files/ice-3.0.0-makefile.patch, ice-3.0.0-r1.ebuild:
+ Changed readline USE in ncurses and added debug, moved the
+ -I/usr/include/db4.3 in the makefile patch.
*ice-3.0.0-r1 (19 Jan 2006)
diff --git a/dev-cpp/ice/Manifest b/dev-cpp/ice/Manifest
index 24b9cef58b5b..4424cf823981 100644
--- a/dev-cpp/ice/Manifest
+++ b/dev-cpp/ice/Manifest
@@ -1,5 +1,5 @@
-MD5 814515bb5530350346e79f10f3b45c33 ChangeLog 620
+MD5 5017f9ac8e975640f2af08e7abb7122e ChangeLog 840
MD5 5643b69002aaa0bd00051022b1b087aa files/digest-ice-3.0.0-r1 62
-MD5 c8d682f5487fe005ed4a2bd2efcbe79b files/ice-3.0.0-makefile.patch 1412
-MD5 fcbf362bfee7b92a5c09e51ee48f0088 ice-3.0.0-r1.ebuild 1485
+MD5 32a346f9cd5aaec1b8e44ef52543fc4d files/ice-3.0.0-makefile.patch 1656
+MD5 18b348af0e09c47b9b615a0c4e376d80 ice-3.0.0-r1.ebuild 1469
MD5 fa56365fdfb0c6f7e71fe6bbae6e26b2 metadata.xml 1168
diff --git a/dev-cpp/ice/files/ice-3.0.0-makefile.patch b/dev-cpp/ice/files/ice-3.0.0-makefile.patch
index bcf2487656c2..5a52ae116966 100644
--- a/dev-cpp/ice/files/ice-3.0.0-makefile.patch
+++ b/dev-cpp/ice/files/ice-3.0.0-makefile.patch
@@ -1,28 +1,5 @@
---- config/Make.rules.old 2006-01-19 21:47:21.000000000 +0900
-+++ config/Make.rules 2006-01-19 14:13:37.000000000 +0900
-@@ -12,7 +12,7 @@
- # if it does not exist.
- #
-
--prefix = /opt/Ice-$(VERSION)
-+prefix = $(DESTDIR)/usr
-
- #
- # Define OPTIMIZE as yes if you want to build with
-@@ -154,9 +154,9 @@
- endif
-
- install_includedir = $(prefix)/include
--install_slicedir = $(prefix)/slice
-+install_slicedir = $(prefix)/share/ice-$(VERSION)/slice
- install_schemadir = $(prefix)/schema
--install_docdir = $(prefix)/doc
-+install_docdir = $(prefix)/share/doc/ice-$(VERSION)
-
- INSTALL = cp -fp
- INSTALL_PROGRAM = ${INSTALL}
---- Makefile.old 2006-01-19 05:24:42.000000000 +0900
-+++ Makefile 2006-01-19 13:37:03.000000000 +0900
+--- Ice-3.0.0/Makefile.old 2006-01-19 05:24:42.000000000 +0900
++++ Ice-3.0.0/Makefile 2006-01-19 13:37:03.000000000 +0900
@@ -19,7 +19,7 @@
@if test ! -d $(prefix) ; \
then \
@@ -52,3 +29,35 @@
clean::
@if test -d doc ; \
+--- Ice-3.0.0/config/Make.rules.old 2006-01-19 19:27:15.000000000 +0100
++++ Ice-3.0.0/config/Make.rules 2006-01-19 19:27:28.000000000 +0100
+@@ -12,7 +12,7 @@
+ # if it does not exist.
+ #
+
+-prefix = /opt/Ice-$(VERSION)
++prefix = $(DESTDIR)/usr
+
+ #
+ # Define OPTIMIZE as yes if you want to build with
+@@ -154,9 +154,9 @@
+ endif
+
+ install_includedir = $(prefix)/include
+-install_slicedir = $(prefix)/slice
++install_slicedir = $(prefix)/share/ice-$(VERSION)/slice
+ install_schemadir = $(prefix)/schema
+-install_docdir = $(prefix)/doc
++install_docdir = $(prefix)/share/doc/ice-$(VERSION)
+
+ INSTALL = cp -fp
+ INSTALL_PROGRAM = ${INSTALL}
+@@ -212,7 +212,7 @@
+ DB_FLAGS = -I$(DB_HOME)/include
+ DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
+ else
+- DB_FLAGS =
++ DB_FLAGS = -I/usr/include/db4.3
+ DB_LIBS = -ldb_cxx
+ endif
+
diff --git a/dev-cpp/ice/ice-3.0.0-r1.ebuild b/dev-cpp/ice/ice-3.0.0-r1.ebuild
index 679da52dae5e..8e16fdb2fc99 100644
--- a/dev-cpp/ice/ice-3.0.0-r1.ebuild
+++ b/dev-cpp/ice/ice-3.0.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ice-3.0.0-r1.ebuild,v 1.1 2006/01/19 15:35:47 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ice/ice-3.0.0-r1.ebuild,v 1.2 2006/01/19 17:50:03 nattfodd Exp $
inherit eutils
@@ -13,9 +13,9 @@ SRC_URI="http://www.zeroc.com/download/Ice/3.0/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
-IUSE="readline test"
+IUSE="readline test debug"
-DEPEND="readline? ( sys-libs/ncurses
+DEPEND="ncurses? ( sys-libs/ncurses
sys-libs/readline )
test? ( >=dev-lang/python-2.2 )
>=sys-libs/db-4.3.29
@@ -45,15 +45,14 @@ src_unpack() {
${S}/config/Make.rules || die "Failed to set no readline"
fi
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ ${S}/config/Make.rules || die "Failed to remove debug"
+ fi
+
sed -i -e \
"s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
-
- for files in ${S}/src/Freeze*/*.{h,cpp}
- do
- sed -i -e "s:db_cxx\.h:db4.3/db_cxx\.h:g" \
- ${files} || die "Failed to patch db headers."
- done
}
src_install() {