summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2006-01-10 01:36:38 +0000
committerIlya Volynets <iluxa@gentoo.org>2006-01-10 01:36:38 +0000
commit3c446103491807e6c04190e9a1ad6f8c92e24d1c (patch)
treeea5dfa4b60a1e5cb1c3f2bd0e8e8472f74d1fe0d /dev-cpp
parentadded dev-cpp/sptk:sqlite3 (diff)
downloadhistorical-3c446103491807e6c04190e9a1ad6f8c92e24d1c.tar.gz
historical-3c446103491807e6c04190e9a1ad6f8c92e24d1c.tar.bz2
historical-3c446103491807e6c04190e9a1ad6f8c92e24d1c.zip
- Add sqlite3 use flag
- Use use_enable Package-Manager: portage-2.0.53
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sptk/ChangeLog7
-rw-r--r--dev-cpp/sptk/Manifest4
-rw-r--r--dev-cpp/sptk/sptk-3.0.11.ebuild11
3 files changed, 14 insertions, 8 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 5398b625d665..f8e791dc37a4 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.12 2006/01/10 00:36:06 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.13 2006/01/10 01:36:38 iluxa Exp $
+
+ 10 Jan 2006; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ sptk-3.0.11.ebuild:
+ - Add sqlite3 use flag
+ - Use use_enable
*sptk-3.0.11 (10 Jan 2006)
diff --git a/dev-cpp/sptk/Manifest b/dev-cpp/sptk/Manifest
index a537dd8f1600..a6e8327809ed 100644
--- a/dev-cpp/sptk/Manifest
+++ b/dev-cpp/sptk/Manifest
@@ -1,8 +1,8 @@
-MD5 699412028790fc875c8fe1bc0efb3a6c ChangeLog 2069
+MD5 46a6b65ff658cfbd049ee912b7160adc ChangeLog 2196
MD5 c1961e9d1e8c7ce2861b6a9f9da08038 files/digest-sptk-2.3.28 62
MD5 e9256a4a57897f70722574b5a45366fc files/digest-sptk-3.0.11 62
MD5 9d6f57f2f01a7c0acbaba21baffa4982 files/digest-sptk-3.0.6 61
MD5 623669b964009bb2a2adfc367f12d072 metadata.xml 334
MD5 b5cd9d1217f0d957c3926185dd0fe4b2 sptk-2.3.28.ebuild 1092
-MD5 66999c45064dea83be667794795e6c93 sptk-3.0.11.ebuild 1401
+MD5 3aecb7c69a1bf39e992572bde4871665 sptk-3.0.11.ebuild 1398
MD5 954ae150ba200ce2de4d986855b49667 sptk-3.0.6.ebuild 1409
diff --git a/dev-cpp/sptk/sptk-3.0.11.ebuild b/dev-cpp/sptk/sptk-3.0.11.ebuild
index 6ce9ab5b6b5a..cf9ab74c9c63 100644
--- a/dev-cpp/sptk/sptk-3.0.11.ebuild
+++ b/dev-cpp/sptk/sptk-3.0.11.ebuild
@@ -1,10 +1,10 @@
# Copyright 2006-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.0.11.ebuild,v 1.1 2006/01/10 00:36:06 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.0.11.ebuild,v 1.2 2006/01/10 01:36:38 iluxa Exp $
inherit autotools
-IUSE="fltk odbc doc"
+IUSE="fltk odbc doc sqlite3"
DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
@@ -16,6 +16,7 @@ KEYWORDS="~x86 ~sparc ~mips ~amd64 ~ppc"
DEPEND="fltk? ( x11-libs/fltk )
odbc? ( >=dev-db/unixODBC-2.2.6 )
+ sqlite3? ( >=dev-db/sqlite-3 )
doc? ( app-doc/doxygen )"
src_unpack() {
@@ -30,11 +31,11 @@ src_compile() {
local myconf
myconf="--enable-shared"
- use odbc || myconf="${myconf} --disable-odbc" #default enabled
- use fltk || myconf="${myconf} --disable-fltk"
-
econf \
--prefix=/usr \
+ `use_enable odbc` \
+ `use_enable fltk` \
+ `use_enable sqlite3` \
${myconf} || die "Configuration Failed"
emake || die "Parallel Make Failed"