summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-05-21 19:29:13 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-05-21 19:29:13 +0000
commit2d255db8d73eb637fc585845d84a2a4262d57ebb (patch)
treef42d8f51dec863320831401593e3c0233c8f122c /dev-db/phpmyadmin
parentRemove ice, as db has also been unmasked (diff)
downloadhistorical-2d255db8d73eb637fc585845d84a2a4262d57ebb.tar.gz
historical-2d255db8d73eb637fc585845d84a2a4262d57ebb.tar.bz2
historical-2d255db8d73eb637fc585845d84a2a4262d57ebb.zip
Version bump
Package-Manager: portage-2.1_pre10-r5
Diffstat (limited to 'dev-db/phpmyadmin')
-rw-r--r--dev-db/phpmyadmin/ChangeLog7
-rw-r--r--dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.13
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.8.1.ebuild87
3 files changed, 96 insertions, 1 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index d43e2689359f..daea16613fea 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.184 2006/05/16 19:04:28 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.185 2006/05/21 19:29:13 rl03 Exp $
+
+*phpmyadmin-2.8.1 (21 May 2006)
+
+ 21 May 2006; Renat Lumpau <rl03@gentoo.org> +phpmyadmin-2.8.1.ebuild:
+ Version bump
16 May 2006; Renat Lumpau <rl03@gentoo.org> -phpmyadmin-2.8.0.3.ebuild:
Removed old version
diff --git a/dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.1 b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.1
new file mode 100644
index 000000000000..529a27927a56
--- /dev/null
+++ b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.1
@@ -0,0 +1,3 @@
+MD5 82d7ed4a71608fd7eeef5510c4a49056 phpMyAdmin-2.8.1.tar.bz2 2013450
+RMD160 d51570e8bacabae619fbf0553e1aead7519c915e phpMyAdmin-2.8.1.tar.bz2 2013450
+SHA256 1fb9ac93d5df33679f796287818cfa579d94e6f073132ce8dea4be3730f3c30e phpMyAdmin-2.8.1.tar.bz2 2013450
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.8.1.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.8.1.ebuild
new file mode 100644
index 000000000000..3f08908d9ff8
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-2.8.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.8.1.ebuild,v 1.1 2006/05/21 19:29:13 rl03 Exp $
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P=phpMyAdmin-${MY_PV}
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND=">=dev-db/mysql-3.23.32 <dev-db/mysql-5.1
+ sys-apps/findutils"
+S=${WORKDIR}/${MY_P}
+
+need_php
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use pcre session unicode \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following"
+ eerror "USE flags enabled:"
+ eerror
+ eerror "pcre session unicode"
+ eerror
+ eerror "as well as any of the following USE flags enabled:"
+ eerror
+ eerror "mysql or mysqli if using dev-lang/php-5"
+ eerror "mysql if using dev-lang/php-4"
+ eerror
+ die "Re-install ${PHP_PKG}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/config.default.php-2.8.0.patch
+
+ # Remove .cvs* files and CVS directories
+ find ${S} -name .cvs\* -or \( -type d -name CVS -prune \) | xargs rm -rf
+}
+
+src_compile() {
+ einfo "Setting random user/password details for the controluser"
+
+ local pmapass="${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
+ sed -e "s/@pmapass@/${pmapass}/g" -i libraries/config.default.php
+ sed -e "s/@pmapass@/${pmapass}/g" \
+ ${FILESDIR}/mysql-setup.sql.in-2.5.6 > ${T}/mysql-setup.sql
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="CREDITS Documentation.txt INSTALL README RELEASE-DATE-${MY_PV} TODO ChangeLog"
+
+ # install the SQL scripts available to us
+ #
+ # unfortunately, we do not have scripts to upgrade from older versions
+ # these are things we need to add at a later date
+
+ webapp_sqlscript mysql ${T}/mysql-setup.sql
+
+ dodoc ${docs}
+ dohtml Documentation.html
+
+ # Copy the app's main files
+
+ einfo "Installing main files"
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/libraries/config.default.php
+ webapp_serverowned ${MY_HTDOCSDIR}/libraries/config.default.php
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-2.8.0.txt
+ webapp_hook_script ${FILESDIR}/reconfig-2.8
+ webapp_src_install
+ # bug #88831, make sure the create script is world-readable.
+ fperms 0600 ${MY_SQLSCRIPTSDIR}/mysql/${PVR}_create.sql
+}