summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-20 02:23:21 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-20 02:23:21 +0000
commitaab9c4298708861eb460dbdeffd35479263d7f60 (patch)
tree3a343f08371be3f48ad234673499e8acdf88f67b /dev-db/postgresql
parentNEVER use exit in an ebuild (diff)
downloadhistorical-aab9c4298708861eb460dbdeffd35479263d7f60.tar.gz
historical-aab9c4298708861eb460dbdeffd35479263d7f60.tar.bz2
historical-aab9c4298708861eb460dbdeffd35479263d7f60.zip
NEVER use exit in an ebuild
Diffstat (limited to 'dev-db/postgresql')
-rw-r--r--dev-db/postgresql/postgresql-7.3.2.ebuild14
-rw-r--r--dev-db/postgresql/postgresql-7.3.3.ebuild14
-rw-r--r--dev-db/postgresql/postgresql-7.3.4-r1.ebuild16
-rw-r--r--dev-db/postgresql/postgresql-7.3.4.ebuild14
-rw-r--r--dev-db/postgresql/postgresql-7.3.ebuild14
5 files changed, 40 insertions, 32 deletions
diff --git a/dev-db/postgresql/postgresql-7.3.2.ebuild b/dev-db/postgresql/postgresql-7.3.2.ebuild
index f4f4dfcbed09..90edc3d0cf1f 100644
--- a/dev-db/postgresql/postgresql-7.3.2.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.2.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.2.ebuild,v 1.10 2003/09/10 01:45:05 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.2.ebuild,v 1.11 2003/11/20 02:23:20 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="sophisticated Object-Relational DBMS"
-SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz"
HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
IUSE="ssl nls java python tcltk perl libg++ pam readline zlib"
-filter-flags -ffast-math
-
DEPEND="virtual/glibc
sys-devel/autoconf
app-admin/sudo
@@ -47,7 +47,7 @@ pkg_setup() {
eerror "pg_restore to import them when you have upgraded completely."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
fi
fi
}
@@ -62,6 +62,8 @@ check_java_config() {
}
src_compile() {
+ filter-flags -ffast-math
+
use java && check_java_config
local myconf
@@ -165,7 +167,7 @@ pkg_config() {
eerror "Postgres ${PV} cannot upgrade your existing databases."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
else
einfo -n "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
einfo "Read the documentation to check how to upgrade to version ${PV}."
diff --git a/dev-db/postgresql/postgresql-7.3.3.ebuild b/dev-db/postgresql/postgresql-7.3.3.ebuild
index cb170394c1ef..4b8f7fc28247 100644
--- a/dev-db/postgresql/postgresql-7.3.3.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.3.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.3.ebuild,v 1.5 2003/09/10 01:45:05 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.3.ebuild,v 1.6 2003/11/20 02:23:21 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="sophisticated Object-Relational DBMS"
-SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz"
HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64"
IUSE="ssl nls java python tcltk perl libg++ pam readline zlib"
-filter-flags -ffast-math
-
DEPEND="virtual/glibc
sys-devel/autoconf
app-admin/sudo
@@ -47,7 +47,7 @@ pkg_setup() {
eerror "pg_restore to import them when you have upgraded completely."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
fi
fi
}
@@ -62,6 +62,8 @@ check_java_config() {
}
src_compile() {
+ filter-flags -ffast-math
+
use java && check_java_config
local myconf
@@ -165,7 +167,7 @@ pkg_config() {
eerror "Postgres ${PV} cannot upgrade your existing databases."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
else
einfon "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
einfo "Read the documentation to check how to upgrade to version ${PV}."
diff --git a/dev-db/postgresql/postgresql-7.3.4-r1.ebuild b/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
index 435ba25382ed..05ada6499454 100644
--- a/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
@@ -1,21 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4-r1.ebuild,v 1.2 2003/11/17 19:19:16 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4-r1.ebuild,v 1.3 2003/11/20 02:23:21 vapier Exp $
-DESCRIPTION="sophisticated Object-Relational DBMS."
+inherit flag-o-matic
+DESCRIPTION="sophisticated Object-Relational DBMS"
+HOMEPAGE="http://www.postgresql.org/ http://gppl.terminal.ru/index.eng.html"
SRC_URI="mirror://postgresql/v${PV}/${P}.tar.gz
pg-hier? ( http://gppl.terminal.ru/hier-Pg7.3-0.3.tar.gz )"
-HOMEPAGE="http://www.postgresql.org/
-http://gppl.terminal.ru/index.eng.html"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64 hppa"
IUSE="ssl nls java python tcltk perl libg++ pam readline zlib pg-hier"
-filter-flags -ffast-math
-
DEPEND="virtual/glibc
sys-devel/autoconf
app-admin/sudo
@@ -50,7 +48,7 @@ pkg_setup() {
eerror "pg_restore to import them when you have upgraded completely."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
fi
fi
}
@@ -76,6 +74,8 @@ src_unpack() {
}
src_compile() {
+ filter-flags -ffast-math
+
use java && check_java_config
local myconf
@@ -182,7 +182,7 @@ pkg_config() {
eerror "Postgres ${PV} cannot upgrade your existing databases."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
else
einfon "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
einfo "Read the documentation to check how to upgrade to version ${PV}."
diff --git a/dev-db/postgresql/postgresql-7.3.4.ebuild b/dev-db/postgresql/postgresql-7.3.4.ebuild
index 0d09f3b6ae47..7b04722a8929 100644
--- a/dev-db/postgresql/postgresql-7.3.4.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.4.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4.ebuild,v 1.7 2003/10/07 20:54:00 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4.ebuild,v 1.8 2003/11/20 02:23:21 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="sophisticated Object-Relational DBMS"
+HOMEPAGE="http://www.postgresql.org/"
SRC_URI="ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.gz
ftp://ftp8.us.postgresql.org/pub/pgsql/v${PV}/${P}.tar.gz"
-HOMEPAGE="http://www.postgresql.org/"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64 hppa"
IUSE="ssl nls java python tcltk perl libg++ pam readline zlib"
-filter-flags -ffast-math
-
DEPEND="virtual/glibc
sys-devel/autoconf
app-admin/sudo
@@ -48,7 +48,7 @@ pkg_setup() {
eerror "pg_restore to import them when you have upgraded completely."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
fi
fi
}
@@ -63,6 +63,8 @@ check_java_config() {
}
src_compile() {
+ filter-flags -ffast-math
+
use java && check_java_config
local myconf
@@ -166,7 +168,7 @@ pkg_config() {
eerror "Postgres ${PV} cannot upgrade your existing databases."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
else
einfon "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
einfo "Read the documentation to check how to upgrade to version ${PV}."
diff --git a/dev-db/postgresql/postgresql-7.3.ebuild b/dev-db/postgresql/postgresql-7.3.ebuild
index a01e28998420..bd26c751ac83 100644
--- a/dev-db/postgresql/postgresql-7.3.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.ebuild,v 1.11 2003/09/10 01:45:05 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.ebuild,v 1.12 2003/11/20 02:23:21 vapier Exp $
+
+inherit flag-o-matic
DESCRIPTION="sophisticated Object-Relational DBMS"
-SRC_URI="ftp://ftp.us.postgresql.org/source/v${PV}/${P}.tar.gz"
HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="ftp://ftp.us.postgresql.org/source/v${PV}/${P}.tar.gz"
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc"
IUSE="ssl nls java python tcltk perl"
-filter-flags -ffast-math
-
DEPEND="virtual/glibc
sys-devel/autoconf
app-admin/sudo
@@ -47,12 +47,14 @@ pkg_setup() {
eerror "pg_restore to import them when you have upgraded completely."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
fi
fi
}
src_compile() {
+ filter-flags -ffast-math
+
local myconf
use tcltk && myconf="--with-tcl"
use python && myconf="$myconf --with-python"
@@ -154,7 +156,7 @@ pkg_config() {
eerror "Postgres ${PV} cannot upgrade your existing databases."
eerror "You must remove your entire database directory to continue."
eerror "(database directory = ${PG_DIR})."
- exit 1
+ die
else
einfo -n "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
einfo "Read the documentation to check how to upgrade to version ${PV}."