summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2005-03-19 11:32:37 +0000
committerAnders Rune Jensen <arj@gentoo.org>2005-03-19 11:32:37 +0000
commit61667440bdb8a825eb0bb637632216c7252af0c2 (patch)
tree6ae89237c1cbb83049c10bfadd1858c58e374afb /dev-db/sqlite
parentVersion bumped. Added ipv6 and threads to IUSE. Added ~amd64. (diff)
downloadhistorical-61667440bdb8a825eb0bb637632216c7252af0c2.tar.gz
historical-61667440bdb8a825eb0bb637632216c7252af0c2.tar.bz2
historical-61667440bdb8a825eb0bb637632216c7252af0c2.zip
new version
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/ChangeLog8
-rw-r--r--dev-db/sqlite/Manifest4
-rw-r--r--dev-db/sqlite/files/digest-sqlite-3.1.61
-rw-r--r--dev-db/sqlite/sqlite-3.1.6.ebuild62
4 files changed, 73 insertions, 2 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 85c0d6d6ffe8..7f1154c22251 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.68 2005/03/12 21:21:59 arj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.69 2005/03/19 11:32:37 arj Exp $
+
+*sqlite-3.1.6 (19 Mar 2005)
+
+ 19 Mar 2005; Anders Rune Jensen <arj@gentoo.org> +sqlite-3.1.6.ebuild:
+ New version which fixes another corruption bug. I don't think 3.x
+ will be going stable anytime soon.
*sqlite-3.1.5 (12 Mar 2005)
diff --git a/dev-db/sqlite/Manifest b/dev-db/sqlite/Manifest
index ad61d018cf81..c7a5562451e7 100644
--- a/dev-db/sqlite/Manifest
+++ b/dev-db/sqlite/Manifest
@@ -6,10 +6,11 @@ MD5 529fd03eceab183a8c3dea72741c7266 sqlite-3.0.6.ebuild 1046
MD5 5cbea2bc70699b7a68bf442f4d6a2622 sqlite-3.1.3.ebuild 1890
MD5 c2c8c2607bf7e784464bf8b6c17f5972 sqlite-3.1.5.ebuild 1889
MD5 8cda692208b4f43344d30e5bfa2ee396 sqlite-2.8.16.ebuild 1402
-MD5 7dcfc67bc77069a4b9683d50a9a4e54a ChangeLog 9271
+MD5 31477f374092248d79a50c31dc495306 ChangeLog 9479
MD5 c0c61638e3f6d70263748a5db601414d sqlite-3.1.2.ebuild 1882
MD5 99bf2a671c91f7499255003439d5eac0 sqlite-2.8.14.ebuild 862
MD5 f29cd1d06dca071985256cb325d2b380 sqlite-3.0.7.ebuild 995
+MD5 8c6d9f1b14b238affe69ab822d635cd8 sqlite-3.1.6.ebuild 1889
MD5 006d5e8c0eb41234ac90294b6fd93f2d sqlite-3.0.8-r1.ebuild 1817
MD5 c9c200833c7c14eb4d750bb00455199e files/digest-sqlite-2.8.14 65
MD5 2a35fca391c8617c26b2934d02b8fcb5 files/digest-sqlite-3.1.3 65
@@ -23,4 +24,5 @@ MD5 b4031f19b8a32fa2b9dd4dfaf4b57ad0 files/digest-sqlite-2.8.15 65
MD5 572dbaa55a4dd1cec17ee827911ee243 files/digest-sqlite-3.0.8 65
MD5 3f0417272ef2e01ef38d27021a93aeaf files/digest-sqlite-2.8.16 65
MD5 5aeb0a32e55ac5562756134561b39dae files/digest-sqlite-3.0.6 65
+MD5 4943d36d9f7038f8ea32136b3a7d5f1e files/digest-sqlite-3.1.6 65
MD5 572dbaa55a4dd1cec17ee827911ee243 files/digest-sqlite-3.0.8-r1 65
diff --git a/dev-db/sqlite/files/digest-sqlite-3.1.6 b/dev-db/sqlite/files/digest-sqlite-3.1.6
new file mode 100644
index 000000000000..e86113623f4d
--- /dev/null
+++ b/dev-db/sqlite/files/digest-sqlite-3.1.6
@@ -0,0 +1 @@
+MD5 34e77a82ca7c1a7f5ff00a1939075fa8 sqlite-3.1.6.tar.gz 1337475
diff --git a/dev-db/sqlite/sqlite-3.1.6.ebuild b/dev-db/sqlite/sqlite-3.1.6.ebuild
new file mode 100644
index 000000000000..6a856ff77349
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.1.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.1.6.ebuild,v 1.1 2005/03/19 11:32:37 arj Exp $
+
+inherit eutils
+
+IUSE="nls nothreadsafe"
+
+DESCRIPTION="SQLite: An SQL Database Engine in a C Library."
+SRC_URI="http://www.sqlite.org/${P}.tar.gz"
+HOMEPAGE="http://www.sqlite.org"
+
+# Adding glibc as dependency for USE !nothreadsafe until someone can tell me
+# if all virtual/libc's provide POSIX threads (pthread.h)
+# - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
+DEPEND="virtual/libc
+ !nothreadsafe? ( !ppc-macos? ( sys-libs/glibc ) )
+ dev-lang/tcl"
+SLOT="3"
+LICENSE="as-is"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
+
+src_compile() {
+ # sqlite includes a doc directory making it impossible to generate docs,
+ # which are very important to people adding support for sqlite3 to their
+ # programs.
+ rm -rf doc/
+
+ local myconf
+ myconf="--enable-incore-db --enable-tempdb-in-ram"
+ # Yes, this is ridiculous, but I'm not the maintainer for this ebuild,
+ # and yet it's broken w/o thread support, so this has to do for now
+ # - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
+ if ! use nothreadsafe; then
+ myconf="${myconf} --enable-threadsafe"
+ else
+ myconf="${myconf} --disable-threadsafe"
+ fi
+ myconf="${myconf} `use_with nls utf8`"
+ myconf="--with-tcl=/usr/$(get_libdir)/"
+ econf ${myconf} || die
+ emake all || die # doc is not working yet in 3.1.2
+}
+
+# In case we ever want testing support; note: this needs more work, as
+# as it causes some sandbox issues.
+# - 20041203, Armando Di Cianno <fafhrd@gentoo.org>
+#src_test() {
+# cd ${S}
+# emake fulltest || die "some test failed"
+#}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+
+ dobin lemon
+ dodoc README VERSION
+ doman sqlite.1
+ docinto html
+ dohtml doc/*.html doc/*.txt doc/*.png
+}