summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-03-11 18:44:20 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-03-11 18:44:20 +0000
commitfda6d520c80f294dc59f6091b02e451f2b037281 (patch)
treebb8201a1ad4788bd41403d31560f62e2d08bcfa6 /dev-dotnet/google-gdata-sharp
parentStable on amd64 wrt bug #302479 (diff)
downloadhistorical-fda6d520c80f294dc59f6091b02e451f2b037281.tar.gz
historical-fda6d520c80f294dc59f6091b02e451f2b037281.tar.bz2
historical-fda6d520c80f294dc59f6091b02e451f2b037281.zip
Initial commit C# bindings for the GData API.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-dotnet/google-gdata-sharp')
-rw-r--r--dev-dotnet/google-gdata-sharp/ChangeLog11
-rw-r--r--dev-dotnet/google-gdata-sharp/Manifest5
-rw-r--r--dev-dotnet/google-gdata-sharp/files/pkgconfig-typo-fix.patch8
-rw-r--r--dev-dotnet/google-gdata-sharp/google-gdata-sharp-1.4.0.2.ebuild29
-rw-r--r--dev-dotnet/google-gdata-sharp/metadata.xml8
5 files changed, 61 insertions, 0 deletions
diff --git a/dev-dotnet/google-gdata-sharp/ChangeLog b/dev-dotnet/google-gdata-sharp/ChangeLog
new file mode 100644
index 000000000000..45d79191423f
--- /dev/null
+++ b/dev-dotnet/google-gdata-sharp/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-dotnet/google-gdata-sharp
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/google-gdata-sharp/ChangeLog,v 1.1 2010/03/11 18:44:20 ford_prefect Exp $
+
+*google-gdata-sharp-1.4.0.2 (11 Mar 2010)
+
+ 11 Mar 2010; Arun Raghavan <ford_prefect@gentoo.org>
+ +google-gdata-sharp-1.4.0.2.ebuild, +files/pkgconfig-typo-fix.patch,
+ +metadata.xml:
+ Initial commit of C# bindings for the GData API.
+
diff --git a/dev-dotnet/google-gdata-sharp/Manifest b/dev-dotnet/google-gdata-sharp/Manifest
new file mode 100644
index 000000000000..a8bf53e45fce
--- /dev/null
+++ b/dev-dotnet/google-gdata-sharp/Manifest
@@ -0,0 +1,5 @@
+AUX pkgconfig-typo-fix.patch 569 RMD160 abf5624e1012e9b223a8161276deeabc4cd5947a SHA1 47c4d851448eb828aec4e60ead9177136b9e7872 SHA256 e46319e4e9fc625f24069314e9172f1564e74d098f48c0daadedd3c82d2cceb7
+DIST libgoogle-data-mono-1.4.0.2.tar.gz 2090937 RMD160 a2b6f67728b5d3b18bab9b71a9186d5f3ca787b8 SHA1 8e24b7ad03899b31499716c668e38f6af3189480 SHA256 761124feb67ad972e61a10a09bbde68536a2fa8cc67f9f17fcda907bbdb2fbe4
+EBUILD google-gdata-sharp-1.4.0.2.ebuild 777 RMD160 2cfd3c9ba4e0566b6621a10e7b27843f9c574b75 SHA1 924295a404ecf07705c1fa4ccad4b9bb3cfff0e2 SHA256 370dca45900e58b5a8f236900ccf9b9ef5006454b9b94573fe8a3dea3c6958fd
+MISC ChangeLog 475 RMD160 d8c26917161817de4cc53148af6182bbe110af44 SHA1 15e643224a9258dcd34205c24f9917f8783a2afb SHA256 673feadd7318c3dda60cb3d654d5aecbb605321ec63e2d0221ef8e6cd3a6cfd1
+MISC metadata.xml 236 RMD160 c84a0606d7ae97b7d6fed9ce39b948e8be50881f SHA1 957159f40a4301977e5670d76532561fefa2e1b2 SHA256 1bcac32d6020396c8892a0c72c69f9a2947d2b515bcf0dc79e443e84b6527bcf
diff --git a/dev-dotnet/google-gdata-sharp/files/pkgconfig-typo-fix.patch b/dev-dotnet/google-gdata-sharp/files/pkgconfig-typo-fix.patch
new file mode 100644
index 000000000000..854e6dd085ff
--- /dev/null
+++ b/dev-dotnet/google-gdata-sharp/files/pkgconfig-typo-fix.patch
@@ -0,0 +1,8 @@
+--- libgoogle-data-mono-1.4.0.2/misc/gdata-sharp-core.pc.in 2010-03-09 13:07:29.000000000 +0100
++++ libgoogle-data-mono-1.4.0.2.new/misc/gdata-sharp-core.pc.in 2010-03-10 13:11:29.000000000 +0100
+@@ -5,4 +5,4 @@ Name: GData Sharp Core
+ Description: CLI bindings to Google's online services (Core libraries)
+ Version: 1.4.0.2
+
+-Libs: -r:${libdir}/mono/GData-Sharp/Google.GData.Client.dll -r${libdir}/mono/GData-Sharp/Google.GData.Extensions.dll
++Libs: -r:${libdir}/mono/GData-Sharp/Google.GData.Client.dll -r:${libdir}/mono/GData-Sharp/Google.GData.Extensions.dll
diff --git a/dev-dotnet/google-gdata-sharp/google-gdata-sharp-1.4.0.2.ebuild b/dev-dotnet/google-gdata-sharp/google-gdata-sharp-1.4.0.2.ebuild
new file mode 100644
index 000000000000..01f348c22316
--- /dev/null
+++ b/dev-dotnet/google-gdata-sharp/google-gdata-sharp-1.4.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/google-gdata-sharp/google-gdata-sharp-1.4.0.2.ebuild,v 1.1 2010/03/11 18:44:20 ford_prefect Exp $
+
+EAPI=3
+
+inherit base mono
+
+MY_PN="libgoogle-data-mono"
+
+DESCRIPTION="C# bindings for the Google GData API"
+HOMEPAGE="http://code.google.com/p/google-gdata/"
+SRC_URI="http://google-gdata.googlecode.com/files/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-2.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+# The Makefile has prefix=/usr/local by default :|
+MAKEOPTS="PREFIX=/usr ${MAKEOPTS}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/pkgconfig-typo-fix.patch
+}
diff --git a/dev-dotnet/google-gdata-sharp/metadata.xml b/dev-dotnet/google-gdata-sharp/metadata.xml
new file mode 100644
index 000000000000..3127c57cc2a8
--- /dev/null
+++ b/dev-dotnet/google-gdata-sharp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ford_prefect@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>