summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2006-11-25 00:13:59 +0000
committerJurek Bartuszek <jurek@gentoo.org>2006-11-25 00:13:59 +0000
commit0aaec4ae53074f6603e3d7d8c4198fb3c9cb7678 (patch)
tree23ef09a33798c32938922e3178537fbb835f77fa /dev-dotnet
parentFixes bug #156044. (diff)
downloadhistorical-0aaec4ae53074f6603e3d7d8c4198fb3c9cb7678.tar.gz
historical-0aaec4ae53074f6603e3d7d8c4198fb3c9cb7678.tar.bz2
historical-0aaec4ae53074f6603e3d7d8c4198fb3c9cb7678.zip
Added dev-dotnet/xsp-1.2.1
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/xsp/ChangeLog10
-rw-r--r--dev-dotnet/xsp/files/1.2.1/mod-mono-server.confd34
-rw-r--r--dev-dotnet/xsp/files/1.2.1/mod-mono-server.initd81
-rw-r--r--dev-dotnet/xsp/files/1.2.1/xsp.confd12
-rw-r--r--dev-dotnet/xsp/files/1.2.1/xsp.initd38
-rw-r--r--dev-dotnet/xsp/files/digest-xsp-1.2.13
-rw-r--r--dev-dotnet/xsp/xsp-1.2.1.ebuild58
7 files changed, 235 insertions, 1 deletions
diff --git a/dev-dotnet/xsp/ChangeLog b/dev-dotnet/xsp/ChangeLog
index da33a77199d3..f2e772696a0f 100644
--- a/dev-dotnet/xsp/ChangeLog
+++ b/dev-dotnet/xsp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-dotnet/xsp
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.33 2006/11/12 22:12:56 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/ChangeLog,v 1.34 2006/11/25 00:13:58 jurek Exp $
+
+*xsp-1.2.1 (25 Nov 2006)
+
+ 25 Nov 2006; Jurek Bartuszek <jurek@gentoo.org>
+ +files/1.2.1/mod-mono-server.confd, +files/1.2.1/mod-mono-server.initd,
+ +files/1.2.1/xsp.confd, +files/1.2.1/xsp.initd,
+ -files/xsp-monoworkerrequest-fix.patch, +xsp-1.2.1.ebuild:
+ Version bump
12 Nov 2006; Jurek Bartuszek <jurek@gentoo.org>
-files/1.1.10/mod-mono-server.confd, -files/1.1.10/mod-mono-server.initd,
diff --git a/dev-dotnet/xsp/files/1.2.1/mod-mono-server.confd b/dev-dotnet/xsp/files/1.2.1/mod-mono-server.confd
new file mode 100644
index 000000000000..222b6e7221de
--- /dev/null
+++ b/dev-dotnet/xsp/files/1.2.1/mod-mono-server.confd
@@ -0,0 +1,34 @@
+# Config file for /etc/init.d/mod-mono-server
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/files/1.2.1/mod-mono-server.confd,v 1.1 2006/11/25 00:13:59 jurek Exp $
+
+# Configuration directives for mod-mono-server.exe. For more information on
+# these variables, see the man page for xsp(1).
+
+# This is the document root; trailing slash is not necessary
+#MonoServerRootDir="/usr/lib/xsp/test"
+
+# Directory to search for files with an `.webapp' extension.
+#MonoApplicationsConfigDir="/usr/lib/xsp/test"
+
+# Comma separated list of directories (in the form virtual:real) for all
+# applications managed by the server. For example:
+# /app1:/var/www/localhost/htdocs/app1,/app2:/var/www/localhost/htdocs/app2
+MonoApplications="/mono:/usr/lib/xsp/test"
+
+# The communication channel used between mod-mono-server and mod_mono.
+# unix - A unix socket
+# tcp - A TCP connection
+MonoServerChannel="unix"
+
+# When the comm. channel is "unix", the local filename used by the socket.
+UnixSocketFileName="/tmp/mod_mono_server"
+
+# When the comm. channel is "tcp", IP address for the server to listen on.
+#MonoServerAddress=127.0.0.1
+
+# When the comm. channel is "tcp", port for the server to listen on.
+#MonoServerPort=8080
+
+# If you want to host .NET 2.0 applications you have to set this to 2.
+# Otherwise, leave it unchaged
+MonoServerVersion=1
diff --git a/dev-dotnet/xsp/files/1.2.1/mod-mono-server.initd b/dev-dotnet/xsp/files/1.2.1/mod-mono-server.initd
new file mode 100644
index 000000000000..65d1595fdaab
--- /dev/null
+++ b/dev-dotnet/xsp/files/1.2.1/mod-mono-server.initd
@@ -0,0 +1,81 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/files/1.2.1/mod-mono-server.initd,v 1.1 2006/11/25 00:13:59 jurek Exp $
+
+depend() {
+ use net
+ after dotnet
+}
+
+start() {
+ [ -z "$MonoServerRootDir" ] && \
+ MonoServerRootDir="/usr/lib/xsp/test"
+ [ -z "$MonoApplications" ] && \
+ MonoApplications="/mono:/usr/lib/xsp/test,/:."
+ [ -z "$UnixSocketFileName" ] && \
+ UnixSocketFileName="/tmp/mod_mono_server"
+ [ -z "$MonoServerAddress" ] && \
+ MonoServerAddress=127.0.0.1
+ [ -z "$MonoServerPort" ] && \
+ MonoServerPort=8080
+ [ -z "$MonoServerVersion" ] && \
+ MonoServerVersion=1
+
+ MONO_SERVER_OPTS="--root ${MonoServerRootDir} \
+--applications ${MonoApplications} --nonstop"
+
+ [ -n "$MonoApplicationsConfigDir" ] && \
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--appconfigdir ${MonoApplicationsConfigDir}"
+
+ case "$MonoServerChannel" in
+ "tcp" )
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--address ${MonoServerAddress} --port ${MonoServerPort}"
+ ;;
+
+ "unix" )
+ [ -f "$UnixSocketFileName" ] && rm -f $UnixSocketFileName
+ MONO_SERVER_OPTS="${MONO_SERVER_OPTS} \
+--filename ${UnixSocketFileName}"
+ ;;
+
+ * )
+ eerror "Please set a valid value for MonoServerChannel"
+ return 1
+ ;;
+ esac
+
+ if [ ${MonoServerVersion} -eq 1 ]; then
+ modmonoserverpath=1.0/mod-mono-server.exe
+ elif [ ${MonoServerVersion} -eq 2 ]; then
+ modmonoserverpath=2.0/mod-mono-server2.exe
+ else
+ eerror "MonoServerVersion was not properly set. Check your /etc/conf.d/xsp"
+ return 1
+ fi
+
+ export MONO_SHARED_DIR=/tmp
+
+ ebegin "Starting mod-mono-server"
+
+ start-stop-daemon --quiet --start \
+ --background \
+ --make-pidfile \
+ --pidfile /var/run/aspnet/mod-mono-server.pid \
+ --chuid aspnet \
+ --exec /usr/bin/mono /usr/lib/mono/${modmonoserverpath} \
+ -- $MONO_SERVER_OPTS
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping mod-mono-server"
+
+ start-stop-daemon -o --quiet --stop \
+ --pidfile /var/run/aspnet/mod-mono-server.pid
+
+ eend $?
+}
diff --git a/dev-dotnet/xsp/files/1.2.1/xsp.confd b/dev-dotnet/xsp/files/1.2.1/xsp.confd
new file mode 100644
index 000000000000..e49177bcde59
--- /dev/null
+++ b/dev-dotnet/xsp/files/1.2.1/xsp.confd
@@ -0,0 +1,12 @@
+# Config file for /etc/init.d/xsp
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/files/1.2.1/xsp.confd,v 1.1 2006/11/25 00:13:59 jurek Exp $
+
+# This is the document root; trailing slash is not necessary
+MonoServerRoot=/usr/lib/xsp/test
+
+# Port for the server to run on
+MonoServerPort=8000
+
+# If you want to host .NET 2.0 applications you have to set this to 2.
+# Otherwise, leave it unchanged
+MonoServerVersion=1
diff --git a/dev-dotnet/xsp/files/1.2.1/xsp.initd b/dev-dotnet/xsp/files/1.2.1/xsp.initd
new file mode 100644
index 000000000000..94f48a1ea46f
--- /dev/null
+++ b/dev-dotnet/xsp/files/1.2.1/xsp.initd
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/files/1.2.1/xsp.initd,v 1.1 2006/11/25 00:13:59 jurek Exp $
+
+depend() {
+ need net
+ after dotnet
+}
+
+start() {
+ ebegin "Starting xsp"
+
+ if [ ${MonoServerVersion} -eq 1 ]; then
+ xsppath=1.0/xsp.exe
+ elif [ ${MonoServerVersion} -eq 2 ]; then
+ xsppath=2.0/xsp2.exe
+ else
+ eerror "MonoServerVersion was not properly set. Check your config file"
+ return 1
+ fi
+
+ start-stop-daemon --quiet --start \
+ --background \
+ --make-pidfile \
+ --pidfile /var/run/aspnet/xsp.pid \
+ --chuid aspnet \
+ --exec /usr/bin/mono /usr/lib/mono/${xsppath} -- --root ${MonoServerRoot} --port ${MonoServerPort} --nonstop
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping xsp"
+ start-stop-daemon -o --quiet --stop \
+ --pidfile /var/run/aspnet/xsp.pid
+ eend $?
+}
+
diff --git a/dev-dotnet/xsp/files/digest-xsp-1.2.1 b/dev-dotnet/xsp/files/digest-xsp-1.2.1
new file mode 100644
index 000000000000..e40811e99c77
--- /dev/null
+++ b/dev-dotnet/xsp/files/digest-xsp-1.2.1
@@ -0,0 +1,3 @@
+MD5 37333caaf4c4570ec76cf0ef9218b402 xsp-1.2.1.tar.gz 230521
+RMD160 51a72584a024071ea28a1691ffaa495c0a91e995 xsp-1.2.1.tar.gz 230521
+SHA256 76c7c03d2cf411c52e90f1b6262214865efe7d3b89d51d5277537ba6bfee2d20 xsp-1.2.1.tar.gz 230521
diff --git a/dev-dotnet/xsp/xsp-1.2.1.ebuild b/dev-dotnet/xsp/xsp-1.2.1.ebuild
new file mode 100644
index 000000000000..db02988d7bfc
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-1.2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-1.2.1.ebuild,v 1.1 2006/11/25 00:13:58 jurek Exp $
+
+inherit mono autotools eutils
+
+DESCRIPTION="XSP ASP.NET host"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/sources/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+IUSE=""
+
+DEPEND=">=dev-lang/mono-${PV}"
+
+pkg_preinst() {
+ enewgroup aspnet
+
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e "s:mkinstalldirs) \$(data:mkinstalldirs) \$(DESTDIR)\$(data:" \
+ -e "s:gif \$(data:gif \$(DESTDIR)\$(data:" \
+ ${S}/test/2.0/treeview/Makefile.am
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "./configure failed!"
+ emake || {
+ echo
+ eerror "If xsp fails to build, try unmerging and re-emerging it."
+ die "make failed"
+ }
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ exeinto /etc/init.d ; newexe ${FILESDIR}/${PV}/xsp.initd xsp
+ newexe ${FILESDIR}/${PV}/mod-mono-server.initd mod-mono-server
+ insinto /etc/conf.d ; newins ${FILESDIR}/${PV}/xsp.confd xsp
+ newins ${FILESDIR}/${PV}/mod-mono-server.confd mod-mono-server
+
+ keepdir /var/run/aspnet
+
+ dodoc README ChangeLog AUTHORS INSTALL NEWS
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}