summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-09-19 16:46:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-09-19 16:46:26 +0000
commit381f055ee9817f2cd29d2714b40b5c184ab26a70 (patch)
tree804a27373d88fcd97e8d531130be559a47419293 /dev-games
parentold (diff)
downloadhistorical-381f055ee9817f2cd29d2714b40b5c184ab26a70.tar.gz
historical-381f055ee9817f2cd29d2714b40b5c184ab26a70.tar.bz2
historical-381f055ee9817f2cd29d2714b40b5c184ab26a70.zip
old
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/guichan/guichan-0.5.0.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-games/guichan/guichan-0.5.0.ebuild b/dev-games/guichan/guichan-0.5.0.ebuild
index 5329ce14b806..8093fd57973b 100644
--- a/dev-games/guichan/guichan-0.5.0.ebuild
+++ b/dev-games/guichan/guichan-0.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.5.0.ebuild,v 1.1 2006/08/20 05:11:05 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.5.0.ebuild,v 1.2 2006/09/19 16:46:26 mr_bones_ Exp $
inherit eutils autotools
@@ -19,24 +19,17 @@ DEPEND="opengl? ( virtual/opengl )
S=${WORKDIR}/${P}-src
-src_unpack() {
- unpack ${A}
- cd "${S}"
- #epatch "${FILESDIR}/${P}"-gentoo.patch
- #eautoreconf
-}
-
src_compile() {
econf \
$(use_enable allegro) \
$(use_enable sdl) \
$(use_enable sdl sdlimage) \
$(use_enable opengl) \
- || die "Configuration failed"
- emake || die "Build failed"
+ || die
+ emake || die "emake failed"
}
src_install() {
- make install DESTDIR="${D}" || die "Installation failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README TODO
}