summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-30 21:17:22 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-30 21:17:22 +0000
commitefd7a1f5db68b619a492a9da38128272c88ebed6 (patch)
tree523e3d0016e72f7e1a50c6fa8811ace7b88a5523 /dev-games
parentold (diff)
downloadhistorical-efd7a1f5db68b619a492a9da38128272c88ebed6.tar.gz
historical-efd7a1f5db68b619a492a9da38128272c88ebed6.tar.bz2
historical-efd7a1f5db68b619a492a9da38128272c88ebed6.zip
rename
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ode/Manifest18
-rw-r--r--dev-games/ode/files/0.5-PIC.patch20
-rw-r--r--dev-games/ode/files/ode-0.5-PIC.patch19
3 files changed, 23 insertions, 34 deletions
diff --git a/dev-games/ode/Manifest b/dev-games/ode/Manifest
index 589e3325593a..68314cb6e71f 100644
--- a/dev-games/ode/Manifest
+++ b/dev-games/ode/Manifest
@@ -1,15 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 160bb996ab652e9251d736c40f693786 ChangeLog 2763
-MD5 05d1eafa8377f72052f3e5c7eb6fe88c files/0.5-PIC.patch 516
-MD5 24a10f16623003a6f4c8df5d8a0c11f5 files/digest-ode-0.5-r2 57
+MD5 9789c4db84563d4e55c3a223541b1bbd ChangeLog 2941
+MD5 24a10f16623003a6f4c8df5d8a0c11f5 files/digest-ode-0.5-r3 57
+MD5 396acb81503d05b97e7dffe8d6c0003e files/ode-0.5-PIC.patch 446
MD5 897a7d200c1e7b0159d465d3220c9eff metadata.xml 509
-MD5 8de4a3a45586bb8c3e802c38598c582a ode-0.5-r2.ebuild 1939
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDWdREgIKl8Uu19MoRAmavAJ9Yqex5fIc1G90c0FRpsZApXUHQUQCggw+1
-V4tSNUsxHi5v7LiU0T8m+rs=
-=VK7e
------END PGP SIGNATURE-----
+MD5 b0e29e30d96a49d8cdb202bda680909c ode-0.5-r3.ebuild 1933
diff --git a/dev-games/ode/files/0.5-PIC.patch b/dev-games/ode/files/0.5-PIC.patch
deleted file mode 100644
index 8255d34f2cc1..000000000000
--- a/dev-games/ode/files/0.5-PIC.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Make sure we don't clobber %ebx (important with PIC).
-
-http://bugs.gentoo.org/show_bug.cgi?id=77079
-
---- ode-0.5/ode/src/timer.cpp.orig 2005-01-08 00:42:12.799324632 -0500
-+++ ode-0.5/ode/src/timer.cpp 2005-01-08 00:42:38.347440728 -0500
-@@ -118,6 +118,13 @@
- {
- asm volatile (
-+#if defined(__i386__) && defined(__PIC__)
-+ "pushl %%ebx\n"
-+ "cpuid\n"
-+ "popl %%ebx\n"
-+ : : : "%eax","%ecx","%edx","cc","memory");
-+#else
- "mov $0,%%eax\n"
- "cpuid\n"
- : : : "%eax","%ebx","%ecx","%edx","cc","memory");
-+#endif
- }
diff --git a/dev-games/ode/files/ode-0.5-PIC.patch b/dev-games/ode/files/ode-0.5-PIC.patch
new file mode 100644
index 000000000000..b3c1dcf9605c
--- /dev/null
+++ b/dev-games/ode/files/ode-0.5-PIC.patch
@@ -0,0 +1,19 @@
+Make sure we don't clobber %ebx (important with PIC).
+
+http://bugs.gentoo.org/77079
+
+--- ode-0.5/ode/src/timer.cpp
++++ ode-0.5/ode/src/timer.cpp
+@@ -117,9 +117,11 @@ static inline void getClockCount (unsign
+ static inline void serialize()
+ {
+ asm volatile (
++ "mov %%ebx,%%edi\n"
+ "mov $0,%%eax\n"
+ "cpuid\n"
+- : : : "%eax","%ebx","%ecx","%edx","cc","memory");
++ "mov %%edi,%%ebx\n"
++ : : : "%eax","%edi","%ecx","%edx","cc","memory");
+ }
+
+