summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-01-16 04:11:53 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-01-16 04:11:53 +0000
commitf057af3e6dc7292b5361b4e95a56ac6fb4e30393 (patch)
tree1606876fb6bcee53b9a5ea5092817d8f99b6d90d /dev-games
parentadd static-libs support (diff)
downloadhistorical-f057af3e6dc7292b5361b4e95a56ac6fb4e30393.tar.gz
historical-f057af3e6dc7292b5361b4e95a56ac6fb4e30393.tar.bz2
historical-f057af3e6dc7292b5361b4e95a56ac6fb4e30393.zip
add static-libs support
Package-Manager: portage-2.1.9.25/cvs/Linux i686
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/guichan/ChangeLog7
-rw-r--r--dev-games/guichan/guichan-0.8.2.ebuild13
-rw-r--r--dev-games/wfmath/ChangeLog7
-rw-r--r--dev-games/wfmath/wfmath-0.3.10.ebuild16
4 files changed, 32 insertions, 11 deletions
diff --git a/dev-games/guichan/ChangeLog b/dev-games/guichan/ChangeLog
index b9e6395d5d79..cf6cfc640d52 100644
--- a/dev-games/guichan/ChangeLog
+++ b/dev-games/guichan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-games/guichan
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.23 2010/10/15 12:48:31 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.24 2011/01/16 04:06:56 mr_bones_ Exp $
+
+ 16 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org> guichan-0.8.2.ebuild:
+ add static-libs support
15 Oct 2010; Brent Baude <ranger@gentoo.org> guichan-0.8.2.ebuild:
stable ppc, bug 318909
diff --git a/dev-games/guichan/guichan-0.8.2.ebuild b/dev-games/guichan/guichan-0.8.2.ebuild
index 5f66b71cf4eb..29a3b5ef0ee2 100644
--- a/dev-games/guichan/guichan-0.8.2.ebuild
+++ b/dev-games/guichan/guichan-0.8.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.2.ebuild,v 1.4 2010/10/15 12:48:31 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.2.ebuild,v 1.5 2011/01/16 04:06:56 mr_bones_ Exp $
EAPI=2
inherit eutils autotools
@@ -12,7 +12,7 @@ SRC_URI="http://guichan.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="allegro opengl sdl"
+IUSE="allegro opengl sdl static-libs"
DEPEND="allegro? ( media-libs/allegro )
opengl? ( virtual/opengl )
@@ -32,10 +32,15 @@ src_configure() {
$(use_enable allegro) \
$(use_enable opengl) \
$(use_enable sdl) \
- $(use_enable sdl sdlimage)
+ $(use_enable sdl sdlimage) \
+ $(use_enable static-libs static)
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README TODO
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + \
+ || die "la removal failed"
+ fi
}
diff --git a/dev-games/wfmath/ChangeLog b/dev-games/wfmath/ChangeLog
index bd92087c9244..108224e48719 100644
--- a/dev-games/wfmath/ChangeLog
+++ b/dev-games/wfmath/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-games/wfmath
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/ChangeLog,v 1.15 2010/12/06 09:28:08 tupone Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/ChangeLog,v 1.16 2011/01/16 04:11:53 mr_bones_ Exp $
+
+ 16 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org> wfmath-0.3.10.ebuild:
+ add static-libs support
06 Dec 2010; Alfredo Tupone <tupone@gentoo.org> wfmath-0.3.10.ebuild:
Remove not strictly needed dependency on media-libs/atlas-c++
diff --git a/dev-games/wfmath/wfmath-0.3.10.ebuild b/dev-games/wfmath/wfmath-0.3.10.ebuild
index 63e7e8ce7ce0..052040812c9a 100644
--- a/dev-games/wfmath/wfmath-0.3.10.ebuild
+++ b/dev-games/wfmath/wfmath-0.3.10.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/wfmath-0.3.10.ebuild,v 1.4 2010/12/06 09:28:08 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/wfmath/wfmath-0.3.10.ebuild,v 1.5 2011/01/16 04:11:53 mr_bones_ Exp $
EAPI=2
DESCRIPTION="Worldforge math library"
@@ -10,11 +10,17 @@ SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="doc"
+IUSE="doc static-libs"
RDEPEND=""
DEPEND="doc? ( app-doc/doxygen )"
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static)
+}
+
src_compile() {
emake || die "emake failed"
if use doc; then
@@ -28,4 +34,8 @@ src_install() {
if use doc; then
dohtml doc/html/*
fi
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + \
+ || die "la removal failed"
+ fi
}