summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2005-03-23 07:37:48 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2005-03-23 07:37:48 +0000
commita2d6f5bba713694e4969a7514c2c26a0f8f401f6 (patch)
tree58f20f4cfa5595f71a15168360004711f1114d42 /dev-haskell/hmake
parentRenaming stackgrowth patch (diff)
downloadhistorical-a2d6f5bba713694e4969a7514c2c26a0f8f401f6.tar.gz
historical-a2d6f5bba713694e4969a7514c2c26a0f8f401f6.tar.bz2
historical-a2d6f5bba713694e4969a7514c2c26a0f8f401f6.zip
New hmake release. It works with ghc6.4
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-haskell/hmake')
-rw-r--r--dev-haskell/hmake/ChangeLog7
-rw-r--r--dev-haskell/hmake/Manifest10
-rw-r--r--dev-haskell/hmake/files/digest-hmake-3.101
-rw-r--r--dev-haskell/hmake/hmake-3.10.ebuild54
4 files changed, 67 insertions, 5 deletions
diff --git a/dev-haskell/hmake/ChangeLog b/dev-haskell/hmake/ChangeLog
index c9d0aeab7340..e6dc9a9fe928 100644
--- a/dev-haskell/hmake/ChangeLog
+++ b/dev-haskell/hmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hmake
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/ChangeLog,v 1.12 2005/03/08 23:03:12 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/ChangeLog,v 1.13 2005/03/23 07:37:48 araujo Exp $
+
+*hmake-3.10 (23 Mar 2005)
+
+ 23 Mar 2005; Luis F. Araujo <araujo@gentoo.org> +hmake-3.10.ebuild:
+ New hmake release.
*hmake-3.09 (08 Mar 2005)
diff --git a/dev-haskell/hmake/Manifest b/dev-haskell/hmake/Manifest
index e5fb040f1d31..0e678415ed5c 100644
--- a/dev-haskell/hmake/Manifest
+++ b/dev-haskell/hmake/Manifest
@@ -1,16 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 8b3a9921059333cd23a6edebf31e24c9 ChangeLog 1741
+MD5 681f9ada5ec6c3413b3f3995cd6a903b ChangeLog 1860
MD5 dd301d3b0c4370817c888f5ef010a402 hmake-3.08.ebuild 1387
MD5 e0ce59fd27b9382896cdb87d5fa48f89 metadata.xml 286
MD5 cebcfca46a06fcb12daa8329c708b854 hmake-3.09.ebuild 1363
+MD5 2be0585b3db5731cb7ba2836d33faa37 hmake-3.10.ebuild 1370
MD5 77342bba93c32304e51d32b4894dddf2 files/digest-hmake-3.08 61
MD5 50a20e8dc3ef16030908acbe85b97f1b files/digest-hmake-3.09 62
+MD5 fdfe8526461bed837798b8d287cc82bb files/digest-hmake-3.10 62
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCLi9LBQBy/eDH5uERAuGJAJ9vkjBqhu0OmmEp8pNJabCxipcSKQCgiukW
-O3Qt7bvZZZyI6drdqUTwGhQ=
-=PivF
+iD8DBQFCQRzzBQBy/eDH5uERAhuYAJ4xLPsQ/xDetZuzck+J4pEo7nlX/QCgiwfy
+wA9ao5f9TPgXeAlZoVNKkL8=
+=uTAf
-----END PGP SIGNATURE-----
diff --git a/dev-haskell/hmake/files/digest-hmake-3.10 b/dev-haskell/hmake/files/digest-hmake-3.10
new file mode 100644
index 000000000000..fbb65aab0594
--- /dev/null
+++ b/dev-haskell/hmake/files/digest-hmake-3.10
@@ -0,0 +1 @@
+MD5 32c8fea53feaa9b2ead1622609ec052a hmake-3.10.tar.gz 104656
diff --git a/dev-haskell/hmake/hmake-3.10.ebuild b/dev-haskell/hmake/hmake-3.10.ebuild
new file mode 100644
index 000000000000..71cf19c30c12
--- /dev/null
+++ b/dev-haskell/hmake/hmake-3.10.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.10.ebuild,v 1.1 2005/03/23 07:37:48 araujo Exp $
+
+inherit base fixheadtails
+
+DESCRIPTION="a make tool for Haskell programs"
+HOMEPAGE="http://www.haskell.org/hmake/"
+SRC_URI="http://www.haskell.org/hmake/${P}.tar.gz"
+
+LICENSE="nhc98"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/ghc
+ sys-libs/readline"
+RDEPEND="sys-libs/readline
+ virtual/libc
+ dev-libs/gmp"
+
+# if using readline, hmake depends also on ncurses; but
+# readline already has this dependency
+
+src_compile() {
+ local buildwith
+ local arch
+
+ buildwith="--buildwith=ghc"
+
+ # fix all head/tail declarations
+ sed -i 's/tail -1/tail -n 1/' src/hmake/MkConfig.hs
+ # the line above prevents current fixheadtails.eclass from doing nonsense;
+ # double space before -n is significant
+ ht_fix_all
+
+ # fix string gaps
+ sed -i -e 's/\\ $/" ++/' -e 's/^\\/ "/' src/interpreter/HInteractive.hs
+
+ # package uses non-standard configure, therefore econf does
+ # not work ...
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man/man1 \
+ ${buildwith} || die "./configure failed"
+
+ # emake tested; does not work
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dohtml docs/hmake/*
+}