summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 17:33:10 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 17:33:10 +0000
commit25a3c087ab579f6d43727d24688b2dddd833c135 (patch)
treef95397b3dbba567f372152f040d9dd847c18a7b3 /dev-haskell/hxt
parentNew version. (diff)
downloadhistorical-25a3c087ab579f6d43727d24688b2dddd833c135.tar.gz
historical-25a3c087ab579f6d43727d24688b2dddd833c135.tar.bz2
historical-25a3c087ab579f6d43727d24688b2dddd833c135.zip
New version. Fix quoting issues in older ebuilds.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-haskell/hxt')
-rw-r--r--dev-haskell/hxt/ChangeLog9
-rw-r--r--dev-haskell/hxt/files/digest-hxt-7.33
-rw-r--r--dev-haskell/hxt/hxt-4.02-r1.ebuild13
-rw-r--r--dev-haskell/hxt/hxt-4.02.ebuild13
-rw-r--r--dev-haskell/hxt/hxt-5.00.ebuild15
-rw-r--r--dev-haskell/hxt/hxt-6.0.ebuild6
-rw-r--r--dev-haskell/hxt/hxt-7.2.ebuild6
-rw-r--r--dev-haskell/hxt/hxt-7.3.ebuild44
8 files changed, 83 insertions, 26 deletions
diff --git a/dev-haskell/hxt/ChangeLog b/dev-haskell/hxt/ChangeLog
index 564164d9e0ca..5af4dbeb1433 100644
--- a/dev-haskell/hxt/ChangeLog
+++ b/dev-haskell/hxt/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/hxt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/ChangeLog,v 1.9 2007/10/31 13:07:44 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/ChangeLog,v 1.10 2007/12/13 17:31:46 dcoutts Exp $
+
+*hxt-7.3 (13 Dec 2007)
+
+ 13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> hxt-4.02.ebuild,
+ hxt-4.02-r1.ebuild, hxt-5.00.ebuild, hxt-6.0.ebuild, hxt-7.2.ebuild,
+ +hxt-7.3.ebuild:
+ New version. Fix quoting issues in older ebuilds.
31 Oct 2007; Duncan Coutts <dcoutts@gentoo.org> hxt-4.02.ebuild,
hxt-4.02-r1.ebuild, hxt-5.00.ebuild, hxt-6.0.ebuild:
diff --git a/dev-haskell/hxt/files/digest-hxt-7.3 b/dev-haskell/hxt/files/digest-hxt-7.3
new file mode 100644
index 000000000000..b1489514e16d
--- /dev/null
+++ b/dev-haskell/hxt/files/digest-hxt-7.3
@@ -0,0 +1,3 @@
+MD5 1005c522e8fb039d7e0c7c275fd4f8d0 hxt-7.3.tar.gz 3629101
+RMD160 3cb62dfed6ccbf726d2ed864129fe845fa35242d hxt-7.3.tar.gz 3629101
+SHA256 998a1004a80a9353612ac0b9595855eb089e3c30ef26a0bf749aff163b3e329c hxt-7.3.tar.gz 3629101
diff --git a/dev-haskell/hxt/hxt-4.02-r1.ebuild b/dev-haskell/hxt/hxt-4.02-r1.ebuild
index 5bb45696d291..9053e83a51b0 100644
--- a/dev-haskell/hxt/hxt-4.02-r1.ebuild
+++ b/dev-haskell/hxt/hxt-4.02-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-4.02-r1.ebuild,v 1.2 2007/10/31 13:07:44 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-4.02-r1.ebuild,v 1.3 2007/12/13 17:31:46 dcoutts Exp $
inherit fixheadtails base eutils ghc-package
@@ -40,17 +40,18 @@ src_test() {
}
src_install() {
- sed -i "s:/usr/local/lib/hxt:$(ghc-libdir)/${PF}:" ${S}/src/{netextra,hxt}-package.conf
- sed -i "/ghc-pkg --update-package *$/d" ${S}/src/Makefile
+ sed -i "s:/usr/local/lib/hxt:$(ghc-libdir)/${PF}:" \
+ "${S}/src/{netextra,hxt}-package.conf"
+ sed -i "/ghc-pkg --update-package *$/d" "${S}/src/Makefile"
- ghc-setup-pkg ${S}/src/netextra-package.conf ${S}/src/hxt-package.conf
+ ghc-setup-pkg "${S}/src/netextra-package.conf" "${S}/src/hxt-package.conf"
make install \
GHC_INSTALL_DIR="${D}$(ghc-libdir)/${PF}" \
|| die "make install failed"
- dodoc LICENSE README
+ dodoc README
if use doc; then
- cd ${S}/doc
+ cd "${S}/doc"
dodoc thesis.ps
dohtml -r *
fi
diff --git a/dev-haskell/hxt/hxt-4.02.ebuild b/dev-haskell/hxt/hxt-4.02.ebuild
index 3e80af231656..73a08ef0ddcf 100644
--- a/dev-haskell/hxt/hxt-4.02.ebuild
+++ b/dev-haskell/hxt/hxt-4.02.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-4.02.ebuild,v 1.3 2007/10/31 13:07:44 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-4.02.ebuild,v 1.4 2007/12/13 17:31:46 dcoutts Exp $
inherit fixheadtails base eutils ghc-package
@@ -40,17 +40,18 @@ src_test() {
}
src_install() {
- sed -i "s:/usr/local/lib/hxt:$(ghc-libdir):" ${S}/src/{netextra,hxt}-package.conf
- sed -i "/ghc-pkg --update-package *$/d" ${S}/src/Makefile
+ sed -i "s:/usr/local/lib/hxt:$(ghc-libdir):" \
+ "${S}/src/{netextra,hxt}-package.conf"
+ sed -i "/ghc-pkg --update-package *$/d" "${S}/src/Makefile"
- ghc-setup-pkg ${S}/src/netextra-package.conf ${S}/src/hxt-package.conf
+ ghc-setup-pkg "${S}/src/netextra-package.conf" "${S}/src/hxt-package.conf"
make install \
GHC_INSTALL_DIR="${D}$(ghc-libdir)" \
|| die "make install failed"
- dodoc LICENSE README
+ dodoc README
if use doc; then
- cd ${S}/doc
+ cd "${S}/doc"
dodoc thesis.ps
dohtml -r *
fi
diff --git a/dev-haskell/hxt/hxt-5.00.ebuild b/dev-haskell/hxt/hxt-5.00.ebuild
index 9d8a6a1a83e7..8ece5bb73ba2 100644
--- a/dev-haskell/hxt/hxt-5.00.ebuild
+++ b/dev-haskell/hxt/hxt-5.00.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-5.00.ebuild,v 1.2 2007/10/31 13:07:44 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-5.00.ebuild,v 1.3 2007/12/13 17:31:46 dcoutts Exp $
inherit fixheadtails base eutils ghc-package
@@ -41,18 +41,19 @@ src_test() {
}
src_install() {
- sed -i "s:/usr/local/lib/hxt:$(ghc-libdir)/${PF}:" ${S}/src/hxt-package.conf
- sed -i "/ghc-pkg --update-package *$/d" ${S}/src/Makefile
- sed -i "/ghc-pkg --remove-package/d" ${S}/src/Makefile
+ sed -i "s:/usr/local/lib/hxt:$(ghc-libdir)/${PF}:" \
+ "${S}/src/hxt-package.conf"
+ sed -i "/ghc-pkg --update-package *$/d" "${S}/src/Makefile"
+ sed -i "/ghc-pkg --remove-package/d" "${S}/src/Makefile"
- ghc-setup-pkg ${S}/src/hxt-package.conf
+ ghc-setup-pkg "${S}/src/hxt-package.conf"
emake install \
GHC_INSTALL_DIR="${D}$(ghc-libdir)/${PF}" \
|| die "make install failed"
- dodoc LICENSE README
+ dodoc README
if use doc; then
- cd ${S}/doc
+ cd "${S}/doc"
dodoc thesis.ps
dohtml -r *
fi
diff --git a/dev-haskell/hxt/hxt-6.0.ebuild b/dev-haskell/hxt/hxt-6.0.ebuild
index c2d36bb01b8e..e929f9b8dba9 100644
--- a/dev-haskell/hxt/hxt-6.0.ebuild
+++ b/dev-haskell/hxt/hxt-6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-6.0.ebuild,v 1.2 2007/10/31 13:07:44 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-6.0.ebuild,v 1.3 2007/12/13 17:31:46 dcoutts Exp $
CABAL_FEATURES="lib profile haddock"
inherit base haskell-cabal
@@ -34,9 +34,9 @@ src_unpack() {
src_install() {
cabal_src_install
- dodoc LICENSE README
+ dodoc README
if use doc; then
- cd ${S}/doc
+ cd "${S}/doc"
dodoc thesis.ps
dohtml -r *
fi
diff --git a/dev-haskell/hxt/hxt-7.2.ebuild b/dev-haskell/hxt/hxt-7.2.ebuild
index 4682290f4b4e..c1d1fe5ac4c0 100644
--- a/dev-haskell/hxt/hxt-7.2.ebuild
+++ b/dev-haskell/hxt/hxt-7.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-7.2.ebuild,v 1.1 2007/07/28 17:58:47 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-7.2.ebuild,v 1.2 2007/12/13 17:31:46 dcoutts Exp $
CABAL_FEATURES="lib profile haddock"
inherit base haskell-cabal
@@ -35,9 +35,9 @@ src_unpack() {
src_install() {
cabal_src_install
- dodoc LICENSE README
+ dodoc README
if use doc; then
- cd ${S}/doc
+ cd "${S}/doc"
dodoc thesis.pdf
fi
}
diff --git a/dev-haskell/hxt/hxt-7.3.ebuild b/dev-haskell/hxt/hxt-7.3.ebuild
new file mode 100644
index 000000000000..5a1b7b336b90
--- /dev/null
+++ b/dev-haskell/hxt/hxt-7.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hxt/hxt-7.3.ebuild,v 1.1 2007/12/13 17:31:46 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal versionator
+
+DESCRIPTION="A collection of tools for processing XML with Haskell"
+HOMEPAGE="http://www.fh-wedel.de/~si/HXmlToolbox/"
+SRC_URI="http://www.fh-wedel.de/~si/HXmlToolbox/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ghc-6.6
+ >=dev-haskell/http-2006.7.7
+ >=dev-haskell/hunit-1.1
+ >=dev-haskell/network-1.0"
+
+src_unpack() {
+ unpack "${A}"
+
+ # Oh ffs! The name of the licence file in the cabal file does not match
+ # the name of the file in the tarball so it fails at the install step.
+ sed -i -e 's/LICENCE/LICENSE/' "${S}/hxt.cabal"
+
+ if version_is_at_least "6.8" "$(ghc-version)"; then
+ sed -i -e '/build-depends:/a \
+ , process, containers, directory' \
+ "${S}/hxt.cabal"
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc README
+ if use doc; then
+ cd "${S}/doc"
+ dodoc thesis.pdf
+ fi
+}