summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-12-27 02:58:17 +0000
committerMark Wright <gienah@gentoo.org>2012-12-27 02:58:17 +0000
commitac47d01baebcb79bf470e36a0bda87375a076e03 (patch)
tree0a69bbf4c54c126e1bea6262f26e51fabd967ca6 /dev-haskell/wxcore/wxcore-0.90.0.3.ebuild
parentBump wxhaskell to 0.13.2.1 and 0.90 (diff)
downloadhistorical-ac47d01baebcb79bf470e36a0bda87375a076e03.tar.gz
historical-ac47d01baebcb79bf470e36a0bda87375a076e03.tar.bz2
historical-ac47d01baebcb79bf470e36a0bda87375a076e03.zip
Bump wxcore to 0.13.2.1 and 0.90.0.3
Package-Manager: portage-2.1.11.38/cvs/Linux x86_64 Manifest-Sign-Key: 0x618E971F
Diffstat (limited to 'dev-haskell/wxcore/wxcore-0.90.0.3.ebuild')
-rw-r--r--dev-haskell/wxcore/wxcore-0.90.0.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild b/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild
new file mode 100644
index 000000000000..1160e775da6d
--- /dev/null
+++ b/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxcore/wxcore-0.90.0.3.ebuild,v 1.1 2012/12/27 02:58:09 gienah Exp $
+
+EAPI=5
+
+WX_GTK_VER="2.9"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit base haskell-cabal
+
+DESCRIPTION="wxHaskell core"
+HOMEPAGE="http://haskell.org/haskellwiki/WxHaskell"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="wxWinLL-3.1"
+SLOT="${WX_GTK_VER}/${PV}"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="opengl"
+
+RDEPEND="dev-haskell/parsec:=[profile?]
+ dev-haskell/stm:=[profile?]
+ >=dev-haskell/wxc-0.90.0.4:${WX_GTK_VER}=[opengl,profile?]
+ >=dev-haskell/wxdirect-0.90:${WX_GTK_VER}=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+PATCHES=("${FILESDIR}/${PN}-0.90.0.1-ghc-7.5.patch")
+
+src_prepare() {
+ base_src_prepare
+ sed -e "s@wxdirect@wxdirect-${WX_GTK_VER}@g" \
+ -i "${S}/Setup.hs" \
+ || die "Could not change Setup.hs for wxdirect slot ${WX_GTK_VER}"
+}