summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-03-03 22:21:39 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-03-03 22:21:39 +0000
commite87d5e25c779f51c338062eaf71696ac9efbff8b (patch)
tree60da17870fa9d99789dce6fdd6271b97cda97c4c /dev-haskell/wxhaskell
parentAdded to ~ppc (diff)
downloadhistorical-e87d5e25c779f51c338062eaf71696ac9efbff8b.tar.gz
historical-e87d5e25c779f51c338062eaf71696ac9efbff8b.tar.bz2
historical-e87d5e25c779f51c338062eaf71696ac9efbff8b.zip
library had been installed in wrong directory
Diffstat (limited to 'dev-haskell/wxhaskell')
-rw-r--r--dev-haskell/wxhaskell/ChangeLog7
-rw-r--r--dev-haskell/wxhaskell/Manifest4
-rw-r--r--dev-haskell/wxhaskell/files/digest-wxhaskell-0.6-r11
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.6-r1.ebuild83
4 files changed, 93 insertions, 2 deletions
diff --git a/dev-haskell/wxhaskell/ChangeLog b/dev-haskell/wxhaskell/ChangeLog
index 4fb72954bf63..f68fb92ef6f3 100644
--- a/dev-haskell/wxhaskell/ChangeLog
+++ b/dev-haskell/wxhaskell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/wxhaskell
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.1 2004/03/03 17:12:17 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.2 2004/03/03 22:21:39 kosmikus Exp $
+
+*wxhaskell-0.6-r1 (03 Mar 2004)
+
+ 03 Mar 2004; Andres Loeh <kosmikus@gentoo.org> wxhaskell-0.6-r1.ebuild:
+ Fixed library placement bug.
*wxhaskell-0.6 (03 Mar 2004)
diff --git a/dev-haskell/wxhaskell/Manifest b/dev-haskell/wxhaskell/Manifest
index 60d886d35a4f..1ff5f52d7b63 100644
--- a/dev-haskell/wxhaskell/Manifest
+++ b/dev-haskell/wxhaskell/Manifest
@@ -1,4 +1,6 @@
+MD5 551c0176efd249a23dd105c11b9c11a3 wxhaskell-0.6-r1.ebuild 2408
MD5 389242ce3dad1f078960f26d85d69445 wxhaskell-0.6.ebuild 2278
-MD5 b72ffa62a9517941a605012c24a66d65 ChangeLog 433
+MD5 a6b734840e74073a7d160c668985fe86 ChangeLog 572
MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
MD5 3370d9be457b4e8fa9b80ec89b49f30b files/digest-wxhaskell-0.6 132
+MD5 2b3cf83262913705b98fae84eb4e5757 files/digest-wxhaskell-0.6-r1 66
diff --git a/dev-haskell/wxhaskell/files/digest-wxhaskell-0.6-r1 b/dev-haskell/wxhaskell/files/digest-wxhaskell-0.6-r1
new file mode 100644
index 000000000000..ba89df4821ee
--- /dev/null
+++ b/dev-haskell/wxhaskell/files/digest-wxhaskell-0.6-r1
@@ -0,0 +1 @@
+MD5 ff5889eb6893da83092938541fbe9b61 wxhaskell-src-0.6.zip 506746
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.6-r1.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.6-r1.ebuild
new file mode 100644
index 000000000000..cefcebff2e30
--- /dev/null
+++ b/dev-haskell/wxhaskell/wxhaskell-0.6-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.6-r1.ebuild,v 1.1 2004/03/03 22:21:39 kosmikus Exp $
+
+DESCRIPTION="a portable and native GUI library for Haskell"
+HOMEPAGE="http://wxhaskell.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wxhaskell/${PN}-src-${PV}.zip"
+LICENSE="wxWinLL-3"
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="doc"
+
+DEPEND="${DEPEND}
+ >=virtual/ghc-6.2
+ >=x11-libs/wxGTK-2.4.1
+ doc? ( >=dev-haskell/haddock-0.6-r2 )"
+
+S=${WORKDIR}/${P}
+
+# the variable ghc_version is used to store the ghc version we are building against
+
+src_compile() {
+ # non-standard configure, so econf is not an option
+ mv configure configure.orig
+ # adapt to Gentoo path convention
+ sed -e 's:/doc/html:/share/doc/html:' \
+ -e 's:wxwinlibs="`$.*$:wxwinlibs="`$wxconfig --libs` `$wxconfig --gl-libs`":' \
+ configure.orig > configure
+ # sed -e 's:test "$wxwinlib\":test "":' configure.orig > configure
+ chmod u+x ./configure
+ # determine ghc library directory
+ # (so that it's possible to install the library for
+ # multiple versions of ghc)
+ local myopts
+ ghc_version=`best_version virtual/ghc | sed "s:.*/::"`
+ test -n ${ghc_version} && ghclibdir="/usr/lib/${ghc_version}"
+ test -n ${ghclibdir} || ghclibdir="/usr/lib"
+ test -n ${ghclibdir} && myopts="${myopts} --libdir=${D}/${ghclibdir}"
+ ./configure \
+ --prefix=${D}/usr \
+ --hcpkg=/bin/true \
+ ${myopts} \
+ || die "./configure failed"
+ # emake doesn't work
+ make || die "make failed"
+ # create documentation
+ if [ `use doc` ]; then
+ make doc || die "make doc failed"
+ fi
+}
+
+src_install() {
+ make install || die "make install failed"
+ mv ${D}/usr/lib/${ghc_version}/libwxc-${PV}.so ${D}/usr/lib
+ if [ `use doc` ]; then
+ dohtml -A haddock -r out/doc/*
+ cp -r samples ${D}/usr/share/doc/${PF}
+ fi
+}
+
+pkg_postinst() {
+ einfo "Registering wxcore package"
+ wxhlibdir=${ghclibdir} ghc-pkg -u -i ${S}/config/wxcore.pkg
+ einfo "Registering wx package"
+ wxhlibdir=${ghclibdir} ghc-pkg -u -i ${S}/config/wx.pkg
+}
+
+pkg_postrm() {
+ # check if another version is still there
+ has_version "<${CATEGORY}/${PF}" \
+ || has_version ">${CATEGORY}/${PF}" \
+ || unregister_ghc_packages
+}
+
+unregister_ghc_packages() {
+ einfo "Unregistering wx package"
+ /usr/bin/ghc-pkg -r wx
+ einfo "Unregistering wxcore package"
+ /usr/bin/ghc-pkg -r wxcore
+}
+