summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-11-01 18:19:07 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-11-01 18:19:07 +0000
commit2b17d33c1afb53319d8a5e9134e36a4b9a986619 (patch)
treeb3bdc3c2ad76e07fd95ee3dc0852660a0ec3eb85 /dev-java/commons-collections
parentMasked dev-java/commons-collections-2.1 (diff)
downloadhistorical-2b17d33c1afb53319d8a5e9134e36a4b9a986619.tar.gz
historical-2b17d33c1afb53319d8a5e9134e36a4b9a986619.tar.bz2
historical-2b17d33c1afb53319d8a5e9134e36a4b9a986619.zip
Fixes #10043.
Diffstat (limited to 'dev-java/commons-collections')
-rw-r--r--dev-java/commons-collections/ChangeLog8
-rw-r--r--dev-java/commons-collections/commons-collections-2.1.ebuild41
-rw-r--r--dev-java/commons-collections/files/digest-commons-collections-2.11
3 files changed, 49 insertions, 1 deletions
diff --git a/dev-java/commons-collections/ChangeLog b/dev-java/commons-collections/ChangeLog
index a5044985c2b1..88cef45d82be 100644
--- a/dev-java/commons-collections/ChangeLog
+++ b/dev-java/commons-collections/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-collections
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.1 2002/10/31 20:38:08 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.2 2002/11/01 18:19:07 karltk Exp $
+
+*commons-collections-2.1 (01 Nov 2002)
+
+ 01 Oct 2002; Karl Trygve Kalleberg <karltk@gentoo.org> commons-collections-2.1.ebuild files/digest-commons-collections-2.1 :
+ New upstream version. Ebuild submitted by Adrian Almenar
+ <aalmenar@conectium.com>. Masked until the "junit" useflag is sanctioned.
*commons-collections-2.0 (31 Oct 2002)
diff --git a/dev-java/commons-collections/commons-collections-2.1.ebuild b/dev-java/commons-collections/commons-collections-2.1.ebuild
new file mode 100644
index 000000000000..6f4a00f53631
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-2.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-2.1.ebuild,v 1.1 2002/11/01 18:19:07 karltk Exp $
+
+S=${WORKDIR}/commons-collections-${PV}-src
+DESCRIPTION="Jakarta-Commons Collections Component"
+HOMEPAGE="http://jakarta.apache.org/commons/collections.html"
+SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/commons-collections/v${PV}/commons-collections-${PV}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=ant-1.4
+ junit? ( >=junit-3.7 )"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+IUSE=""
+
+src_compile() {
+
+ if [ -n "`use junit`" ] ; then
+ echo "junit.jar=`java-config --classpath=junit`" > build.properties
+ ant || die "Testing Classes Failed"
+ fi
+
+ ant dist-jar || die "Compilation Failed"
+ ant doc || die "Unable to create documents"
+}
+
+src_install () {
+ dojar dist/commons-collections*.jar || die "Unable to Install"
+ dodir /usr/share/doc/${P}
+ dohtml dist/*.html
+ dohtml -r dist/docs/*
+}
+
+pkg_postinst() {
+ einfo "************ Documentation can be found at *************\n
+ WEB: http://jakarta.apache.org/commons/collections.html\n
+ LOCAL: /usr/share/doc/commons-collections-${PV}\n
+ ********************************************************"
+}
diff --git a/dev-java/commons-collections/files/digest-commons-collections-2.1 b/dev-java/commons-collections/files/digest-commons-collections-2.1
new file mode 100644
index 000000000000..f2de34acfce0
--- /dev/null
+++ b/dev-java/commons-collections/files/digest-commons-collections-2.1
@@ -0,0 +1 @@
+MD5 ee30c02b1b57693f72cd86c899b925d9 commons-collections-2.1-src.tar.gz 229173