summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-07-16 20:14:11 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-07-16 20:14:11 +0000
commit82b454d2db360090191e14318f1b274169c7da3c (patch)
tree81501244c631433320798eab4e61f9b7fb0ecde6 /dev-java/commons-collections
parentStable on sparc and hppa (diff)
downloadhistorical-82b454d2db360090191e14318f1b274169c7da3c.tar.gz
historical-82b454d2db360090191e14318f1b274169c7da3c.tar.bz2
historical-82b454d2db360090191e14318f1b274169c7da3c.zip
Version bump
Diffstat (limited to 'dev-java/commons-collections')
-rw-r--r--dev-java/commons-collections/ChangeLog8
-rw-r--r--dev-java/commons-collections/Manifest4
-rw-r--r--dev-java/commons-collections/commons-collections-3.1.ebuild35
-rw-r--r--dev-java/commons-collections/files/digest-commons-collections-3.11
4 files changed, 46 insertions, 2 deletions
diff --git a/dev-java/commons-collections/ChangeLog b/dev-java/commons-collections/ChangeLog
index 9781d97bdb42..a81c3aec2aee 100644
--- a/dev-java/commons-collections/ChangeLog
+++ b/dev-java/commons-collections/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-collections
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.20 2004/06/24 22:20:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/ChangeLog,v 1.21 2004/07/16 20:14:11 axxo Exp $
+
+*commons-collections-3.1 (16 Jul 2004)
+
+ 16 Jul 2004; Thomas Matthijs <axxo@gentoo.org>
+ +commons-collections-3.1.ebuild:
+ Version Bump
16 May 2004; Chris Aniszczyk <zx@gentoo.org>
-commons-collections-2.1-r3.ebuild, -commons-collections-3.0.ebuild:
diff --git a/dev-java/commons-collections/Manifest b/dev-java/commons-collections/Manifest
index bbcaccde3c04..7d546f7aabbf 100644
--- a/dev-java/commons-collections/Manifest
+++ b/dev-java/commons-collections/Manifest
@@ -1,4 +1,6 @@
+MD5 e36342fe21bb670f251a02c57f080737 commons-collections-3.1.ebuild 1100
MD5 35138ed29a4dc0c781bca03fc9e5307b commons-collections-3.0-r1.ebuild 985
-MD5 4f077c47b526f140ed7d41ee98ef3fa9 ChangeLog 3089
+MD5 d8850e758d7d236078422f17961144ab ChangeLog 3225
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 384d7c4e44a87df342f5270dcaccd3f1 files/digest-commons-collections-3.0-r1 80
+MD5 d6999c3ed2ac2f04284b7b49641afcc9 files/digest-commons-collections-3.1 80
diff --git a/dev-java/commons-collections/commons-collections-3.1.ebuild b/dev-java/commons-collections/commons-collections-3.1.ebuild
new file mode 100644
index 000000000000..05361bddf486
--- /dev/null
+++ b/dev-java/commons-collections/commons-collections-3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-3.1.ebuild,v 1.1 2004/07/16 20:14:11 axxo Exp $
+
+inherit java-pkg eutils
+
+DESCRIPTION="Jakarta-Commons Collections Component"
+HOMEPAGE="http://jakarta.apache.org/commons/collections.html"
+SRC_URI="mirror://apache/jakarta/commons/collections/source/${PN}-${PV}-src.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4"
+RDEPEND=">=virtual/jdk-1.3"
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ #when this is installed as a dep on ant
+ #junit ant task is not installed yet. so it cannot run
+ #use junit && antflags="${antflags} test"
+ ant ${antflags} || die "compile failed"
+}
+
+src_install() {
+ mv build/${P}.jar build/${PN}.jar
+ java-pkg_dojar build/${PN}.jar
+ dodoc LICENSE.txt README.txt
+ use doc && dohtml -r build/docs/apidocs
+ dohtml *.html
+}
diff --git a/dev-java/commons-collections/files/digest-commons-collections-3.1 b/dev-java/commons-collections/files/digest-commons-collections-3.1
new file mode 100644
index 000000000000..c078c7d46c7d
--- /dev/null
+++ b/dev-java/commons-collections/files/digest-commons-collections-3.1
@@ -0,0 +1 @@
+MD5 2da710d9c81ae85ee3a386e7ed1b1fe8 commons-collections-3.1-src.tar.gz 1137330