summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-09-23 05:41:27 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-09-23 05:41:27 +0000
commitd8d44588f9e03a675c123d2c6f5d1ea2ad6e6bdf (patch)
treec41e6600fa69573d7f9561c9a842aa87e8374514 /dev-java/kaffe
parentFix silly segfault when using --log-prefix="" #148169 by tla. (diff)
downloadhistorical-d8d44588f9e03a675c123d2c6f5d1ea2ad6e6bdf.tar.gz
historical-d8d44588f9e03a675c123d2c6f5d1ea2ad6e6bdf.tar.bz2
historical-d8d44588f9e03a675c123d2c6f5d1ea2ad6e6bdf.zip
Pruned old revisions. Added a fix for bug #148004.
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'dev-java/kaffe')
-rw-r--r--dev-java/kaffe/ChangeLog14
-rw-r--r--dev-java/kaffe/files/digest-kaffe-1.1.7-r33
-rw-r--r--dev-java/kaffe/kaffe-1.1.7-r3.ebuild134
3 files changed, 150 insertions, 1 deletions
diff --git a/dev-java/kaffe/ChangeLog b/dev-java/kaffe/ChangeLog
index a76f59f0c0da..a9bc23e54f53 100644
--- a/dev-java/kaffe/ChangeLog
+++ b/dev-java/kaffe/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-java/kaffe
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/kaffe/ChangeLog,v 1.56 2006/09/01 01:46:45 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/kaffe/ChangeLog,v 1.57 2006/09/23 05:41:27 nichoj Exp $
+
+*kaffe-1.1.7-r3 (23 Sep 2006)
+
+ 23 Sep 2006; Joshua Nichols <nichoj@gentoo.org> -kaffe-1.1.4.ebuild,
+ -kaffe-1.1.4-r1.ebuild, -kaffe-1.1.7_rc1.ebuild, -kaffe-1.1.7.ebuild,
+ -kaffe-1.1.7-r1.ebuild, +kaffe-1.1.7-r3.ebuild:
+ Pruned old revisions. Added a fix for bug #148004.
+
+*kaffe-1.1.7-r2 (19 Sep 2006)
+
+ 19 Sep 2006; <> kaffe-1.1.7-r2.ebuild files/digest-kaffe-1.1.7-r2
+ # INSERT ENTRY HERE
01 Sep 2006; Joshua Nichols <nichoj@gentoo.org> kaffe-1.1.7-r1.ebuild:
Added metadata to indicate packages support generation-1.
diff --git a/dev-java/kaffe/files/digest-kaffe-1.1.7-r3 b/dev-java/kaffe/files/digest-kaffe-1.1.7-r3
new file mode 100644
index 000000000000..2db7c00c6d29
--- /dev/null
+++ b/dev-java/kaffe/files/digest-kaffe-1.1.7-r3
@@ -0,0 +1,3 @@
+MD5 375c3dc44656f3f253455ea219f768b1 kaffe-1.1.7.tar.gz 14494274
+RMD160 7523a3470cd06cf60dbade8ea2f464dc9d85277b kaffe-1.1.7.tar.gz 14494274
+SHA256 7e46e8659e2b7f8b44e53438553df15f1d90c7f498be465391513157a03ff919 kaffe-1.1.7.tar.gz 14494274
diff --git a/dev-java/kaffe/kaffe-1.1.7-r3.ebuild b/dev-java/kaffe/kaffe-1.1.7-r3.ebuild
new file mode 100644
index 000000000000..40ee53e7459c
--- /dev/null
+++ b/dev-java/kaffe/kaffe-1.1.7-r3.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/kaffe/kaffe-1.1.7-r3.ebuild,v 1.1 2006/09/23 05:41:27 nichoj Exp $
+
+JAVA_SUPPORTS_GENERATION_1="true"
+inherit base eutils java-vm-2 flag-o-matic
+
+DESCRIPTION="A cleanroom, open source Java VM and class libraries"
+SRC_URI="ftp://ftp.kaffe.org/pub/${PN}/v1.1.x-development/${P}.tar.gz"
+HOMEPAGE="http://www.kaffe.org/"
+
+#robilad recommended in bug 103978 that we leave the X and QT
+#awt backends disabled for now. Please check the status of these
+#backends with new upstream versions.
+# X?( virtual/x11 )
+# qt?( =x11-libs/qt-3.3* )
+
+DEPEND="
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2.1
+ app-arch/zip
+ dev-java/jikes
+ dev-libs/libxml2
+ sys-libs/zlib
+ gtk? (
+ >=dev-libs/glib-2.0
+ >=x11-libs/gtk+-2.0
+ >=media-libs/libart_lgpl-2.0 )
+ esd? ( >=media-sound/esound-0.2.1 )
+ alsa? ( >=media-libs/alsa-lib-1.0.1 )
+ gmp? ( >=dev-libs/gmp-3.1 )"
+RDEPEND=${DEPEND}
+
+# We need to build this after kaffe because it is implemented in java
+PDEPEND="dev-java/gjdoc"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+#X qt
+IUSE="alsa esd gmp gtk nls"
+
+# kaffe-1.1.6-alsa.patch is needed to prevent compile errors with newer alsas
+# (see bug #119272)
+#PATCHES="${FILESDIR}/${PN}-1.1.6-alsa.patch"
+
+# ignore execstack for now. needs to be fixed upstream
+# http://kaffe.org/cgi-bin/bugzilla/show_bug.cgi?id=59
+QA_EXECSTACK_x86="opt/${P}/jre/lib/i386/libkaffevm-1.1.7.so"
+
+pkg_setup() {
+ if ! use gmp; then
+ ewarn "You have don't have the gmp use flag set."
+ ewarn "Using gmp is the default upstream setting."
+ epause 3
+ fi
+
+ if ! use gtk; then
+ ewarn ""
+ ewarn "The gtk use flag is needed for a awt implementation."
+ ewarn "Don't file bugs for awt not working when you have"
+ ewarn "gtk use flag turned off."
+ epause 3
+ fi
+}
+
+src_compile() {
+ local confargs=""
+
+ # see #88330
+ filter-flags "-fomit-frame-pointer"
+ append-flags "-fno-strict-aliasing"
+
+ if ! use alsa && ! use esd; then
+ confargs="${confargs} --disable-sound"
+ fi
+
+ ! use gmp && confargs="${confargs} --enable-pure-java-math"
+
+# $(use_with X x) \
+# $(use_with X kaffe-x-awt) \
+# $(use_with qt kaffe-qt-awt ) \
+
+ # according to dalibor, this is needed on ppc because jit is
+ # not complete
+ # TODO needs testing!
+ use ppc && confargs="${confargs} --with-engine=intrp"
+
+ # Use bundled fastjar until we have a separate fastjar package
+ # bug #141477
+ FASTJAR="$S/external/gcc/fastjar/fastjar"
+ # --with-rt-jar in 1.1.7 to use the system installed classpath
+ econf \
+ --disable-dependency-tracking \
+ --prefix=/opt/${P} \
+ --host=${CHOST} \
+ $(use_with alsa)\
+ $(use_with esd) \
+ $(use_with gmp) \
+ $(use_enable nls) \
+ $(use_enable gtk gtk-peer) \
+ ${confargs} \
+ --with-jikes \
+ --disable-gjdoc || die "Failed to configure."
+
+ # --with-bcel
+ # --with-profiling
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Failed to install"
+ set_java_env
+
+ # use doexe to ensure executable bit (bug #144635)
+ echo '#!/bin/bash' > javadoc
+ echo 'exec /usr/bin/gjdoc "${@}"' >> javadoc
+ exeinto "/opt/${P}/bin/"
+ doexe javadoc
+
+ # Remove some files that collide with classpath
+ rm ${D}/usr/share/info/vmintegration.info \
+ ${D}/usr/share/info/hacking.info
+
+ # Add symlink to glibj.zip, for bug #148607
+ cd ${D}/opt/${P}/jre/lib
+ ln -s glibj.zip rt.jar
+}
+
+pkg_postinst() {
+ ewarn "Please, do not use Kaffe as your default JDK/JRE!"
+ ewarn "Kaffe is currently meant for testing... it should be"
+ ewarn "only be used by developers or bug-hunters willing to deal"
+ ewarn "with oddities that are bound to come up while using Kaffe!"
+}