summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-05-21 11:53:43 +0000
committerMichael Imhof <tantive@gentoo.org>2003-05-21 11:53:43 +0000
commitaf4f225355d8ae108da7635a95da277029b7d5b0 (patch)
tree9a0723d8c8124b1c33b563bcdd6dbfb90f7f3e29 /dev-lang/squeak
parentVersion bump. Should close #21396 (diff)
downloadhistorical-af4f225355d8ae108da7635a95da277029b7d5b0.tar.gz
historical-af4f225355d8ae108da7635a95da277029b7d5b0.tar.bz2
historical-af4f225355d8ae108da7635a95da277029b7d5b0.zip
Version bump. Should close #21393
Diffstat (limited to 'dev-lang/squeak')
-rw-r--r--dev-lang/squeak/ChangeLog8
-rw-r--r--dev-lang/squeak/files/digest-squeak-3.4.11
-rw-r--r--dev-lang/squeak/squeak-3.4.1.ebuild112
3 files changed, 120 insertions, 1 deletions
diff --git a/dev-lang/squeak/ChangeLog b/dev-lang/squeak/ChangeLog
index 20b6900b43c4..1e9f40edddfd 100644
--- a/dev-lang/squeak/ChangeLog
+++ b/dev-lang/squeak/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/squeak
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/ChangeLog,v 1.2 2003/02/12 05:58:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/ChangeLog,v 1.3 2003/05/21 11:53:43 tantive Exp $
+
+*squeak-3.4.1-1 (21 May 2003)
+
+ 21 May 2003; Michael Imhof <tantive@gentoo.org> :
+ Version bump. Ebuild submitted by Christopher Verges
+ <squirrel@headnut.org>.
*squeak-3.2.5 (29 Dec 2002)
diff --git a/dev-lang/squeak/files/digest-squeak-3.4.1 b/dev-lang/squeak/files/digest-squeak-3.4.1
new file mode 100644
index 000000000000..bfbee3e7c2ec
--- /dev/null
+++ b/dev-lang/squeak/files/digest-squeak-3.4.1
@@ -0,0 +1 @@
+MD5 780af1cf1cdc8d44c1ce30a527bdd508 Squeak-3.4-1.src.tar.gz 1890889
diff --git a/dev-lang/squeak/squeak-3.4.1.ebuild b/dev-lang/squeak/squeak-3.4.1.ebuild
new file mode 100644
index 000000000000..6349264c3afe
--- /dev/null
+++ b/dev-lang/squeak/squeak-3.4.1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.4.1.ebuild,v 1.1 2003/05/21 11:53:43 tantive Exp $
+
+#Simply change these numbers for different versions
+MV=3.4
+NV=${MV}-1
+FV=${MV}.1
+
+DESCRIPTION="Highly-portable Smalltalk-80 implementation"
+HOMEPAGE="http://www.squeak.org/"
+SRC_URI="ftp://st.cs.uiuc.edu/Smalltalk/Squeak/${MV}/unix-linux/Squeak-${NV}.src.tar.gz"
+LICENSE="Apple"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X oss mmx mozilla"
+# a ffi flag would be nice
+
+DEPEND="virtual/glibc
+ X? ( x11-base/xfree )"
+RDEPEND="dev-lang/squeak-vm
+ virtual/glibc
+ X? ( x11-base/xfree )"
+
+S="${WORKDIR}/Squeak-${NV}"
+
+src_compile() {
+ local myconf=""
+
+ use X || myconf="--without-x"
+ use oss && myconf="${myconf} --with-audio=oss"
+ use mmx && myconf="${myconf} --enable-mpg-mmx"
+
+ cd ${S}
+ mkdir build
+ cd build
+ ../platforms/unix/config/configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "configure failed"
+ mv Makefile Makefile.tmp.$$
+ cat Makefile.tmp.$$|sed \
+ 's/$(prefix)\/doc\/squeak/$(prefix)\/share\/doc\/squeak-${FV}/g'\
+ > Makefile
+ rm -f Makefile.tmp.$$
+ emake || die
+ make npsqueak
+ # this is a bit paranoid, but we want to be sure it gets compiled now
+ cd nps
+ emake || die
+}
+
+src_install() {
+ cd ${S}/build
+
+ make DESTDIR=${D} ROOT=${D} install || die
+
+ exeinto /usr/bin
+ doexe inisqueak
+
+ ### the rest is all for the plugin
+
+ cd nps
+
+ # plugin sample, must be served to work, file:// doesnt work.
+
+ insinto /usr/share/doc/squeak-${FV}
+ doins test/plugintest.html
+ doins test/plugintest.sts
+
+ # fix the paths
+
+ SQ_DIR=/usr/lib/squeak
+ VM_VERSION=${NV}
+ NPSQUEAK_SO=${SQ_DIR}/${VM_VERSION}/npsqueak.so
+ sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
+ npsqueakrun.in > npsqueakrun.in.2
+ sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
+ npsqueakregister.in > npsqueakregister
+ sed 's|^ensurefile|ensurefile "${HOME}/.npsqueak/SqueakPlugin.changes" "${SQ_DIR}/npsqueak.changes"\nensurefile|' npsqueakrun.in.2 > npsqueakrun
+
+ exeinto /usr/lib/squeak
+ doexe npsqueakregister
+ exeinto /usr/lib/squeak/${NV}
+ doexe npsqueakrun
+
+
+ # install in browsers (no opera use flags?)
+
+ dodir /opt/netscape/plugins
+ dosym /usr/lib/squeak/${NV}/npsqueak.so /opt/netscape/plugins
+
+ if [ "`use mozilla`" ] ; then
+ dodir /usr/lib/mozilla/plugins
+ dosym /opt/netscape/plugins/npsqueak.so \
+ /usr/lib/mozilla/plugins/npsqueak.so
+ fi
+
+ # maybe we should install the image here..
+
+ # dosym /usr/lib/squeak/SqueakV3.sources /usr/lib/squeak/${NV}/SqueakV3.sources
+ # doins npsqueak.image
+ # doins npsqueak.changes
+}
+
+pkg_postinst() {
+ einfo 'Run "inisqueak" to get a private copy of the VM image.'
+ einfo ''
+ einfo 'To setup the browser plugin, create a working set named npsqueak.* in /usr/lib/squeak/<version>/'
+}