summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-12-07 14:34:09 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-12-07 14:34:09 +0000
commit37015e60e6249d5eac612caea47ebc08ead0fbe9 (patch)
tree3ebd70fd73b251b4105d00c6dfa8cd90c4ac1fa0 /dev-lang/tcl
parentVersion bumped. (diff)
downloadhistorical-37015e60e6249d5eac612caea47ebc08ead0fbe9.tar.gz
historical-37015e60e6249d5eac612caea47ebc08ead0fbe9.tar.bz2
historical-37015e60e6249d5eac612caea47ebc08ead0fbe9.zip
Version bumped.
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/Manifest2
-rw-r--r--dev-lang/tcl/files/digest-tcl-8.4.51
-rw-r--r--dev-lang/tcl/tcl-8.4.5.ebuild82
3 files changed, 84 insertions, 1 deletions
diff --git a/dev-lang/tcl/Manifest b/dev-lang/tcl/Manifest
index 07866ecf2599..dbfb85ad44db 100644
--- a/dev-lang/tcl/Manifest
+++ b/dev-lang/tcl/Manifest
@@ -1,5 +1,5 @@
MD5 efce7f63c18f3658617fda1b3f7d5838 tcl-8.3.3-r1.ebuild 2065
-MD5 46b516f94bc74d0d88d9242cf2aa5b13 tcl-8.4.5.ebuild 2623
+MD5 a601490dc762a9394a37a16e4fd64b36 tcl-8.4.5.ebuild 2623
MD5 13074b32eac31e630c13fedfca62cba6 ChangeLog 3098
MD5 056b9e2cb6cdb3310174a9a2d3a90b62 tcl-8.4.3.ebuild 2668
MD5 46b516f94bc74d0d88d9242cf2aa5b13 tcl-8.4.4.ebuild 2623
diff --git a/dev-lang/tcl/files/digest-tcl-8.4.5 b/dev-lang/tcl/files/digest-tcl-8.4.5
new file mode 100644
index 000000000000..f0ee055c52f4
--- /dev/null
+++ b/dev-lang/tcl/files/digest-tcl-8.4.5
@@ -0,0 +1 @@
+MD5 3fb354dba28166a1004f9103553a3974 tcl8.4.5-src.tar.gz 3444510
diff --git a/dev-lang/tcl/tcl-8.4.5.ebuild b/dev-lang/tcl/tcl-8.4.5.ebuild
new file mode 100644
index 000000000000..476820bc6e88
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.4.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.5.ebuild,v 1.1 2003/12/07 14:33:30 mholzer Exp $
+
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tool Command Language"
+
+DEPEND="virtual/glibc
+ >=app-portage/gentoolkit-0.1.22"
+RDEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc ~mips amd64"
+IUSE=""
+
+# hyper-optimizations untested...
+#
+
+src_compile() {
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die
+ # threading is not recommended as it breaks some packages
+ # --enable-threads \
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ S= make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ -e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tcl${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
+ dodir /usr/lib/tcl${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
+ dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
+
+ ln -sf tclsh${v1} ${D}/usr/bin/tclsh
+
+ cd ${S}
+ dodoc README changes license.terms
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you're upgrading from tcl-8.3, you must recompile the other"
+ ewarn "packages on your system that link with tcl after the upgrade"
+ ewarn "completes. To perform this action, please run revdep-rebuild."
+ ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
+ ewarn "upgrade them before this recompilation, too,"
+ ewarn
+ sleep 5
+}