summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-08-08 01:58:28 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-08-08 01:58:28 +0000
commit10cb990aa4dc06344e476bb96280b7395a78db4c (patch)
tree642e729f00db2b59be63756b9b34cc97df252267 /dev-lang
parentFixes #6135. (diff)
downloadhistorical-10cb990aa4dc06344e476bb96280b7395a78db4c.tar.gz
historical-10cb990aa4dc06344e476bb96280b7395a78db4c.tar.bz2
historical-10cb990aa4dc06344e476bb96280b7395a78db4c.zip
new version of tcc (tiny C compiler)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcc/files/digest-tcc-0.9.81
-rw-r--r--dev-lang/tcc/tcc-0.9.8.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-lang/tcc/files/digest-tcc-0.9.8 b/dev-lang/tcc/files/digest-tcc-0.9.8
new file mode 100644
index 000000000000..2f0796e37be0
--- /dev/null
+++ b/dev-lang/tcc/files/digest-tcc-0.9.8
@@ -0,0 +1 @@
+MD5 fa15a9f7d7ada821048f1896d590826e tcc-0.9.8.tar.gz 133061
diff --git a/dev-lang/tcc/tcc-0.9.8.ebuild b/dev-lang/tcc/tcc-0.9.8.ebuild
new file mode 100644
index 000000000000..2a5f5e06d36e
--- /dev/null
+++ b/dev-lang/tcc/tcc-0.9.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcc/tcc-0.9.8.ebuild,v 1.1 2002/08/08 01:58:28 george Exp $
+
+DESCRIPTION="A very small C compiler for ix86"
+HOMEPAGE="http://www.tinycc.org/"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+SRC_URI="http://fabrice.bellard.free.fr/tcc/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+SLOT="0"
+KEYWORDS="x86"
+
+src_compile() {
+ mv Makefile Makefile.orig || die
+ sed -e 's:prefix=/usr/local:prefix=/usr:g' \
+ -e 's:$(INSTALL) tcc.1 $(prefix)/man/man1:# Gentoo \: Manpage handled by doman:' \
+ Makefile.orig > Makefile || die
+ emake || die
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/lib
+ make prefix=${D}/usr install || die
+ doman tcc.1
+ dodoc Changelog README TODO ex*.c
+ dohtml tcc-doc.html
+}