summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-08-04 00:11:39 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-08-04 00:11:39 +0000
commit64e461c17bf7769e16d32a14a86b05e29bf3b190 (patch)
treede926c73cfe5c5315f78f6927a7af97688d1f078 /dev-lang
parentVersion bump and security fix. (diff)
downloadhistorical-64e461c17bf7769e16d32a14a86b05e29bf3b190.tar.gz
historical-64e461c17bf7769e16d32a14a86b05e29bf3b190.tar.bz2
historical-64e461c17bf7769e16d32a14a86b05e29bf3b190.zip
made tk dependency optional
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog15
-rw-r--r--dev-lang/ocaml/ocaml-3.04-r2.ebuild61
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index c0be1e62856f..ab7898a2e07e 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.3 2002/06/24 20:54:02 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.4 2002/08/04 00:11:39 george Exp $
+
+*ocaml-3.04-r2 (01 Aug 2002)
+
+ 02 Aug 2002; George Shapovalov <george@gentoo.org> ocaml-3.04-r2.ebuild :
+
+ tk dependence is reported (by Tim Hobbs <rectrix@rectrix.cx>) to be optional,
+ made it depend on tcltk use flag.
+ Created and masked new revision to give this some testing without interuption
+ to the working package.
+ Core devs (cvs access people): please do not unmask it on server! Instead please
+ let me know that it tested Ok. I will do necessary modifications to the -r1
+ and delete -r2. This way we will not force everybody to rebuild perfectly
+ working package.
*ocaml-3.04-r1 (24 Jun 2002)
diff --git a/dev-lang/ocaml/ocaml-3.04-r2.ebuild b/dev-lang/ocaml/ocaml-3.04-r2.ebuild
new file mode 100644
index 000000000000..d77be74182d6
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.04-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 20022 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.04-r2.ebuild,v 1.1 2002/08/04 00:11:39 george Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Objective Caml is a fast modern type-inferring functional programming language descended from the ML (Meta Language) family."
+SRC_URI="ftp://ftp.inria.fr/lang/caml-light/${P}.tar.gz"
+HOMEPAGE="http://www.ocaml.org/"
+
+DEPEND="virtual/glibc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="QPL-1.0 LGPL-2"
+KEYWORDS="x86"
+
+# The unpack function is needed only so that we can apply a ppc patch from cvs.
+# This should be fixed in v.>3.04, so the function can be removed then.
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+ if [ ${ARCH} == "ppc" ]
+ then
+ tar -zxf ${FILESDIR}/${P}-ppc.diff.tgz
+ patch -l -p1 < ${P}-ppc.diff
+ fi
+}
+
+src_compile()
+{
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/man/man1 \
+ -with-pthread \
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install ()
+{
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/man/man1 \
+ install || die
+
+ dodir /etc/env.d
+ echo LDPATH=/usr/lib/ocaml:/usr/lib/ocaml/labltk \
+ > ${D}/etc/env.d/30ocaml
+ dodoc Changes INSTALL LICENSE README Upgrading
+
+}
+
+
+
+