summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-11-11 23:53:11 +0000
committerAron Griffis <agriffis@gentoo.org>2003-11-11 23:53:11 +0000
commita21bb2db0046b276b8263c8cd58b4df4893c31e9 (patch)
treedce1d9e871e9e0b25909b590d449708ab99bbfdd /dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
parentuse /usr/lib on alpha (diff)
downloadhistorical-a21bb2db0046b276b8263c8cd58b4df4893c31e9.tar.gz
historical-a21bb2db0046b276b8263c8cd58b4df4893c31e9.tar.bz2
historical-a21bb2db0046b276b8263c8cd58b4df4893c31e9.zip
use /usr/lib on alpha
Diffstat (limited to 'dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild')
-rw-r--r--dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild b/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..59c7b429ce2f
--- /dev/null
+++ b/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild,v 1.1 2003/11/11 23:53:08 agriffis Exp $
+
+DESCRIPTION="Beecrypt is a general-purpose cryptography library."
+HOMEPAGE="http://sourceforge.net/projects/beecrypt"
+SRC_URI="mirror://sourceforge/beecrypt/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+SLOT="0"
+
+DEPEND="python? ( =dev-lang/python-2.2* )
+ !<app-arch/rpm-4.2.1"
+
+IUSE="python"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Prevent usage of lib64 on alpha where it isn't appropriate. We
+ # only have one execution model, so all libraries install in
+ # /usr/lib. This patch can apply regardless of architecture
+ # (11 Nov 2003 agriffis)
+ epatch ${FILESDIR}/beecrypt-3.1.0-alpha.patch
+}
+
+src_compile() {
+ econf \
+ `use_with python` \
+ --enable-shared \
+ --enable-static || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ # Not needed
+ rm -f ${D}/usr/lib/python*/site-packages/_bc.*a
+ dodoc BUGS README BENCHMARKS NEWS || die "dodoc failed"
+}