summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-03 16:16:41 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-03 16:16:41 +0000
commita6f25b92a36009d2420f61e2575d865c9220fc4c (patch)
tree27b79291cf3fc9fd760cb7d6def01061af82e08c /dev-libs/boost
parentVersion bump, closes #52878. (diff)
downloadhistorical-a6f25b92a36009d2420f61e2575d865c9220fc4c.tar.gz
historical-a6f25b92a36009d2420f61e2575d865c9220fc4c.tar.bz2
historical-a6f25b92a36009d2420f61e2575d865c9220fc4c.zip
Fix use invocation
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog6
-rw-r--r--dev-libs/boost/boost-1.30.0.ebuild6
-rw-r--r--dev-libs/boost/boost-1.30.2.ebuild6
-rw-r--r--dev-libs/boost/boost-1.31.0.ebuild6
4 files changed, 14 insertions, 10 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 51d6e57e95b1..fd5eaf4cd014 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.16 2004/04/17 03:57:00 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.17 2004/06/03 16:13:18 agriffis Exp $
+
+ 03 Jun 2004; Aron Griffis <agriffis@gentoo.org> boost-1.30.0.ebuild,
+ boost-1.30.2.ebuild, boost-1.31.0.ebuild:
+ Fix use invocation
16 Apr 2004; Jason Wever <weeve@gentoo.org> boost-1.31.0.ebuild:
Stable on sparc.
diff --git a/dev-libs/boost/boost-1.30.0.ebuild b/dev-libs/boost/boost-1.30.0.ebuild
index 147b412415d5..ea1d8da14f6d 100644
--- a/dev-libs/boost/boost-1.30.0.ebuild
+++ b/dev-libs/boost/boost-1.30.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.30.0.ebuild,v 1.3 2004/03/14 12:28:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.30.0.ebuild,v 1.4 2004/06/03 16:13:18 agriffis Exp $
MY_V="${PV//\./_}"
@@ -28,7 +28,7 @@ src_compile() {
local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | /usr/bin/cut -d . -f 2,3)
local BOOST_TOOLSET
- if [ "`use icc`" ] ; then
+ if use icc ; then
BOOST_TOOLSET="intel-linux"
else
BOOST_TOOLSET="gcc"
@@ -39,7 +39,7 @@ src_compile() {
./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
cd ${S}
- if [ "`use icc`" ] ; then
+ if use icc ; then
./tools/build/jam_src/bin.linux${ARCH}/bjam -j2 \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
diff --git a/dev-libs/boost/boost-1.30.2.ebuild b/dev-libs/boost/boost-1.30.2.ebuild
index c7693f399415..2532a8ec5bd3 100644
--- a/dev-libs/boost/boost-1.30.2.ebuild
+++ b/dev-libs/boost/boost-1.30.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.30.2.ebuild,v 1.3 2004/02/24 00:10:28 bazik Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.30.2.ebuild,v 1.4 2004/06/03 16:13:18 agriffis Exp $
DESCRIPTION="Boost provides free peer-reviewed portable C++ source libraries."
HOMEPAGE="http://www.boost.org"
@@ -24,7 +24,7 @@ src_compile() {
local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
local BOOST_TOOLSET
- if [ "`use icc`" ] ; then
+ if use icc ; then
BOOST_TOOLSET="intel-linux"
else
BOOST_TOOLSET="gcc"
@@ -35,7 +35,7 @@ src_compile() {
./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
cd ${S}
- if [ "`use icc`" ] ; then
+ if use icc ; then
./tools/build/jam_src/bin.linux${ARCH}/bjam -j2 \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
diff --git a/dev-libs/boost/boost-1.31.0.ebuild b/dev-libs/boost/boost-1.31.0.ebuild
index 9ae9bd151e58..049010045fc8 100644
--- a/dev-libs/boost/boost-1.31.0.ebuild
+++ b/dev-libs/boost/boost-1.31.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.31.0.ebuild,v 1.4 2004/04/17 03:57:00 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.31.0.ebuild,v 1.5 2004/06/03 16:13:18 agriffis Exp $
MyPV=${PV//./_}
@@ -29,7 +29,7 @@ src_compile() {
local BOOST_TOOLSET
local arch
- if [ "`use icc`" ] ; then
+ if use icc ; then
BOOST_TOOLSET="intel-linux"
else
BOOST_TOOLSET="gcc"
@@ -46,7 +46,7 @@ src_compile() {
arch=${ARCH}
fi
- if [ "`use icc`" ] ; then
+ if use icc ; then
./tools/build/jam_src/bin.linux${arch}/bjam -j2 \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \