summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2002-08-15 06:05:45 +0000
committerMatthew Turk <satai@gentoo.org>2002-08-15 06:05:45 +0000
commit09ffc14b3a89c9c8c694432fe8c314220457a651 (patch)
treea9b51b9d3dad1af49df4edcba02d4277f07928a3 /dev-libs/coldsync/coldsync-2.2.5-r1.ebuild
parentadded ppc to keywords (diff)
downloadhistorical-09ffc14b3a89c9c8c694432fe8c314220457a651.tar.gz
historical-09ffc14b3a89c9c8c694432fe8c314220457a651.tar.bz2
historical-09ffc14b3a89c9c8c694432fe8c314220457a651.zip
Bumped revision after fixing compile on GCC 3.1. Closing bug 5750.
Diffstat (limited to 'dev-libs/coldsync/coldsync-2.2.5-r1.ebuild')
-rw-r--r--dev-libs/coldsync/coldsync-2.2.5-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/coldsync/coldsync-2.2.5-r1.ebuild b/dev-libs/coldsync/coldsync-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..c541c7f8fb78
--- /dev/null
+++ b/dev-libs/coldsync/coldsync-2.2.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/coldsync/coldsync-2.2.5-r1.ebuild,v 1.1 2002/08/15 06:05:45 satai Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A command-line tool to synchronize PalmOS PDAs with Unix workstations"
+SRC_URI="http://www.coldsync.org/download/${P}.tar.gz"
+HOMEPAGE="http://www.coldsync.org/"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="x86 sparc sparc64"
+
+src_compile() {
+ cd ${S}
+ local myconf
+ use nls || myconf="${myconf} --without-i18n"
+ use perl || myconf="${myconf} --without-perl"
+
+ patch -p1 < ${FILESDIR}/coldsync-2.2.5-gcc3.diff
+
+ econf ${myconf} || die "configuring coldsync failed"
+ make || die "couldn't make coldsync"
+}
+
+src_install() {
+ make \
+ PREFIX=${D}/usr \
+ MANDIR=${D}/usr/share/man \
+ SYSCONFDIR=${D}/etc \
+ DATADIR=${D}/usr/share \
+ INFODIR=${D}/usr/share/info \
+ install || die "couldn't install coldsync"
+
+ dodoc AUTHORS Artistic ChangeLog HACKING INSTALL NEWS README TODO
+}