summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-01-21 15:57:55 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-01-21 15:57:55 +0000
commit394d598a4b709001bfa825dca4205c53500ec8b9 (patch)
tree0cc4770861a2f1c48531cd371a8f3aabe15f0467 /dev-libs/confuse/confuse-2.6.ebuild
parentStable for HPPA (bug #206717). (diff)
downloadhistorical-394d598a4b709001bfa825dca4205c53500ec8b9.tar.gz
historical-394d598a4b709001bfa825dca4205c53500ec8b9.tar.bz2
historical-394d598a4b709001bfa825dca4205c53500ec8b9.zip
Version bumped. maintainership takeover. bug #203832.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-libs/confuse/confuse-2.6.ebuild')
-rw-r--r--dev-libs/confuse/confuse-2.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/confuse/confuse-2.6.ebuild b/dev-libs/confuse/confuse-2.6.ebuild
new file mode 100644
index 000000000000..b2f9c03fa49a
--- /dev/null
+++ b/dev-libs/confuse/confuse-2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/confuse/confuse-2.6.ebuild,v 1.1 2008/01/21 15:57:55 matsuu Exp $
+
+DESCRIPTION="a configuration file parser library"
+HOMEPAGE="http://www.nongnu.org/confuse/"
+SRC_URI="http://bzero.se/confuse/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls"
+
+DEPEND="sys-devel/libtool
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_compile() {
+ econf \
+ --enable-shared \
+ $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ doman doc/man/man3/*.3
+ dodoc AUTHORS NEWS README
+ dohtml doc/html/* || die
+}