summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-04-25 15:18:47 +0000
committerMike Frysinger <vapier@gentoo.org>2003-04-25 15:18:47 +0000
commit780b81feeb414ca968915f06eb3bbb1d32dd9357 (patch)
tree492538457b10bad19ff0a3a20e3aa706877fd5bc /dev-libs/dvthread
parenttouchups (diff)
downloadhistorical-780b81feeb414ca968915f06eb3bbb1d32dd9357.tar.gz
historical-780b81feeb414ca968915f06eb3bbb1d32dd9357.tar.bz2
historical-780b81feeb414ca968915f06eb3bbb1d32dd9357.zip
touchups
Diffstat (limited to 'dev-libs/dvthread')
-rw-r--r--dev-libs/dvthread/dvthread-0.4.4.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/dev-libs/dvthread/dvthread-0.4.4.ebuild b/dev-libs/dvthread/dvthread-0.4.4.ebuild
index e8863169a4b0..b79ac82bc911 100644
--- a/dev-libs/dvthread/dvthread-0.4.4.ebuild
+++ b/dev-libs/dvthread/dvthread-0.4.4.ebuild
@@ -1,27 +1,24 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvthread/dvthread-0.4.4.ebuild,v 1.3 2003/03/13 23:18:51 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dvthread/dvthread-0.4.4.ebuild,v 1.4 2003/04/25 15:16:44 vapier Exp $
-A=dvthread-${PV}.tar.gz
-S=${WORKDIR}/dvthread-${PV}
-DESCRIPTION="dvthread provides classes for threads and monitors, wrapped around the posix thread library"
-SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvthread/download/${A}"
+inherit eutils
+
+DESCRIPTION="classes for threads and monitors, wrapped around the posix thread library"
+SRC_URI="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvthread/download/${P}.tar.gz"
HOMEPAGE="http://tinf2.vub.ac.be/~dvermeir/software/dv/dvthread/html/"
+
KEYWORDS="x86 ppc"
LICENSE="GPL-2"
SLOT="0"
-inherit eutils
-
-IUSE=""
DEPEND="virtual/glibc"
-RDEPEND=${DEPEND}
src_unpack() {
unpack ${A}
- epatch ${FILESDIR}/gentoo-0.4.4.patch
+ epatch ${FILESDIR}/gentoo-${PV}.patch
}
src_install() {
- make prefix=${D}/usr install
+ make prefix=${D}/usr install || die
}