summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-01-08 14:13:45 +0000
committerMike Frysinger <vapier@gentoo.org>2010-01-08 14:13:45 +0000
commit89c1050087c32bb397634b67f2fddc452ed2994f (patch)
treeb6c711ac8aa8b80fd53867eff2bd68c2fac606e2 /dev-libs/gmp
parentVersion bump. (diff)
downloadhistorical-89c1050087c32bb397634b67f2fddc452ed2994f.tar.gz
historical-89c1050087c32bb397634b67f2fddc452ed2994f.tar.bz2
historical-89c1050087c32bb397634b67f2fddc452ed2994f.zip
Version bump.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/gmp')
-rw-r--r--dev-libs/gmp/ChangeLog8
-rw-r--r--dev-libs/gmp/files/gmp-5.0.0-s390.diff68
-rw-r--r--dev-libs/gmp/gmp-5.0.0.ebuild80
3 files changed, 155 insertions, 1 deletions
diff --git a/dev-libs/gmp/ChangeLog b/dev-libs/gmp/ChangeLog
index 1ce04250daea..7c9b287d5b91 100644
--- a/dev-libs/gmp/ChangeLog
+++ b/dev-libs/gmp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/gmp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/ChangeLog,v 1.124 2010/01/08 14:11:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/ChangeLog,v 1.125 2010/01/08 14:13:44 vapier Exp $
+
+*gmp-5.0.0 (08 Jan 2010)
+
+ 08 Jan 2010; Mike Frysinger <vapier@gentoo.org> +gmp-5.0.0.ebuild,
+ +files/gmp-5.0.0-s390.diff:
+ Version bump.
*gmp-4.3.2 (08 Jan 2010)
diff --git a/dev-libs/gmp/files/gmp-5.0.0-s390.diff b/dev-libs/gmp/files/gmp-5.0.0-s390.diff
new file mode 100644
index 000000000000..14771a438ede
--- /dev/null
+++ b/dev-libs/gmp/files/gmp-5.0.0-s390.diff
@@ -0,0 +1,68 @@
+stolen from SuSE
+
+--- configure.in
++++ configure.in
+@@ -1050,6 +1050,9 @@
+ ;;
+
+
++ s390x-*-*)
++ path="s390x" ;;
++
+ # IBM s/370 and similar
+ [s3[6-9]0*-*-*])
+ gcc_cflags="-O2 $fomit_frame_pointer"
+--- configure
++++ configure
+@@ -1050,6 +1050,9 @@
+ ;;
+
+
++ s390x-*-*)
++ path="s390x" ;;
++
+ # IBM s/370 and similar
+ s3[6-9]0*-*-*)
+ gcc_cflags="-O2 $fomit_frame_pointer"
+--- mpn/s390/gmp-mparam.h
++++ mpn/s390/gmp-mparam.h
+@@ -20,7 +20,8 @@
+ MA 02110-1301, USA. */
+
+
+-/* GMP_LIMB_BITS etc generated by configure */
++#define GMP_LIMB_BITS 32
++#define BYTES_PER_MP_LIMB 4
+
+
+ /* Generated by tuneup.c, 2001-12-03, gcc 2.95 */
+--- mpn/s390x/gmp-mparam.h
++++ mpn/s390x/gmp-mparam.h
+@@ -0,0 +1,27 @@
++/* gmp-mparam.h -- Compiler/machine parameter header file.
++
++Copyright (C) 1991, 1993, 1994, 1995 Free Software Foundation, Inc.
++
++This file is part of the GNU MP Library.
++
++The GNU MP Library is free software; you can redistribute it and/or modify
++it under the terms of the GNU Library General Public License as published by
++the Free Software Foundation; either version 2 of the License, or (at your
++option) any later version.
++
++The GNU MP Library is distributed in the hope that it will be useful, but
++WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
++or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Library General Public
++License for more details.
++
++You should have received a copy of the GNU Library General Public License
++along with the GNU MP Library; see the file COPYING.LIB. If not, write to
++the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
++MA 02111-1307, USA. */
++
++#define GMP_LIMB_BITS 64
++#define BYTES_PER_MP_LIMB 8
++#define BITS_PER_LONGINT 64
++#define BITS_PER_INT 32
++#define BITS_PER_SHORTINT 16
++#define BITS_PER_CHAR 8
diff --git a/dev-libs/gmp/gmp-5.0.0.ebuild b/dev-libs/gmp/gmp-5.0.0.ebuild
new file mode 100644
index 000000000000..5b75bc8fd7ee
--- /dev/null
+++ b/dev-libs/gmp/gmp-5.0.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-5.0.0.ebuild,v 1.1 2010/01/08 14:13:44 vapier Exp $
+
+inherit flag-o-matic eutils libtool flag-o-matic
+
+DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
+HOMEPAGE="http://gmplib.org/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+# doc? ( http://www.nada.kth.se/~tege/${PN}-man-${PV}.pdf )"
+
+LICENSE="LGPL-3"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nocxx" #doc
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ [[ -d ${FILESDIR}/${PV} ]] && EPATCH_SUFFIX="diff" EPATCH_FORCE="yes" epatch "${FILESDIR}"/${PV}
+ epatch "${FILESDIR}"/${PN}-4.1.4-noexecstack.patch
+ epatch "${FILESDIR}"/${PN}-5.0.0-s390.diff
+
+ # GMP uses the "ABI" env var during configure as does Gentoo (econf)
+ mv configure configure.wrapped || die
+ cat <<-\EOF > configure
+ #!/bin/sh
+ export ABI=$GMPABI
+ exec "${0}.wrapped" "$@"
+ EOF
+ chmod a+rx configure
+
+ # note: we cannot run autotools here as gcc depends on this package
+ elibtoolize
+}
+
+src_compile() {
+ # GMP believes hppa2.0 is 64bit
+ local is_hppa_2_0
+ if [[ ${CHOST} == hppa2.0-* ]] ; then
+ is_hppa_2_0=1
+ export CHOST=${CHOST/2.0/1.1}
+ fi
+
+ # ABI mappings (needs all architectures supported)
+ case ${ABI} in
+ 32|x86) GMPABI=32;;
+ 64|amd64|n64) GMPABI=64;;
+ o32|n32) GMPABI=${ABI};;
+ esac
+ export GMPABI
+
+ tc-export CC
+ econf \
+ --localstatedir=/var/state/gmp \
+ --disable-mpfr \
+ --disable-mpbsd \
+ $(use_enable !nocxx cxx) \
+ || die "configure failed"
+
+ # Fix the ABI for hppa2.0
+ if [[ -n ${is_hppa_2_0} ]] ; then
+ sed -i \
+ -e 's:pa32/hppa1_1:pa32/hppa2_0:' \
+ "${S}"/config.h || die
+ export CHOST=${CHOST/1.1/2.0}
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+ dodoc doc/configuration doc/isa_abi_headache
+ dohtml -r doc
+
+ #use doc && cp "${DISTDIR}"/gmp-man-${PV}.pdf "${D}"/usr/share/doc/${PF}/
+}