summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-25 13:24:06 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-25 13:24:06 +0000
commit16eaadef987f166147da9f8d2c2fcde6a0eb5fe1 (patch)
tree7ea4e53fb123c637412adf6cfe099b8d9b2c7f2b /dev-libs/iniparser/iniparser-3.1.ebuild
parentVersion bump (diff)
downloadhistorical-16eaadef987f166147da9f8d2c2fcde6a0eb5fe1.tar.gz
historical-16eaadef987f166147da9f8d2c2fcde6a0eb5fe1.tar.bz2
historical-16eaadef987f166147da9f8d2c2fcde6a0eb5fe1.zip
Version bump to 3.1 wrt bug#417467.
Package-Manager: portage-2.2.0_alpha108/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/iniparser/iniparser-3.1.ebuild')
-rw-r--r--dev-libs/iniparser/iniparser-3.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/iniparser/iniparser-3.1.ebuild b/dev-libs/iniparser/iniparser-3.1.ebuild
new file mode 100644
index 000000000000..1855ef337f38
--- /dev/null
+++ b/dev-libs/iniparser/iniparser-3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/iniparser/iniparser-3.1.ebuild,v 1.1 2012/05/25 13:24:06 scarabeus Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="A free stand-alone ini file parsing library."
+HOMEPAGE="http://ndevilla.free.fr/iniparser/"
+
+SRC_URI="http://ndevilla.free.fr/iniparser/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-macos"
+IUSE="doc examples static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )
+ sys-devel/libtool"
+RDEPEND=""
+
+# the tests are rather examples than tests, no point in running them
+RESTRICT="test"
+
+S="${WORKDIR}/${PN}"
+
+DOCS=( AUTHORS README )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0b-cpp.patch"
+ "${FILESDIR}/${PN}-3.0-autotools.patch"
+)
+
+src_install() {
+ autotools-utils_src_install
+
+ if use doc; then
+ emake -C doc
+ dohtml -r html/*
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*.{c,ini,py}
+ fi
+}