summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-27 03:25:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-27 03:25:44 +0000
commit3c659a2af37a6526c0cb505c8c3eb8d6cc41952f (patch)
treecd0c5d0e4cf0fb87a07e1d6f028b79e22a3d8441 /dev-libs/libtommath
parentver bump (diff)
downloadhistorical-3c659a2af37a6526c0cb505c8c3eb8d6cc41952f.tar.gz
historical-3c659a2af37a6526c0cb505c8c3eb8d6cc41952f.tar.bz2
historical-3c659a2af37a6526c0cb505c8c3eb8d6cc41952f.zip
metadata
Diffstat (limited to 'dev-libs/libtommath')
-rw-r--r--dev-libs/libtommath/libtommath-0.29.ebuild4
-rw-r--r--dev-libs/libtommath/metadata.xml61
2 files changed, 63 insertions, 2 deletions
diff --git a/dev-libs/libtommath/libtommath-0.29.ebuild b/dev-libs/libtommath/libtommath-0.29.ebuild
index f719d369fc46..19faeea1cf32 100644
--- a/dev-libs/libtommath/libtommath-0.29.ebuild
+++ b/dev-libs/libtommath/libtommath-0.29.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.29.ebuild,v 1.1 2004/01/27 03:18:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtommath/libtommath-0.29.ebuild,v 1.2 2004/01/27 03:25:44 vapier Exp $
DESCRIPTION="highly optimized and portable routines for integer based number theoretic applications"
HOMEPAGE="http://math.libtomcrypt.org/"
diff --git a/dev-libs/libtommath/metadata.xml b/dev-libs/libtommath/metadata.xml
new file mode 100644
index 000000000000..04efd207507d
--- /dev/null
+++ b/dev-libs/libtommath/metadata.xml
@@ -0,0 +1,61 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+</maintainer>
+<longdescription>
+LibTomMath is a free open source portable number theoretic multiple-precision
+integer library written entirely in C. (phew!). The library is designed to
+provide a simple to work with API that provides fairly efficient routines that
+build out of the box without configuration.
+
+The library builds out of the box with GCC 2.95 [and up] as well as Visual C++
+v6.00 [with SP5] without configuration. The source code is arranged to make it
+easy to dive into a particular area very quickly. The code is also littered with
+comments [This is one of the on going goals] that help explain the algorithms and
+their implementations. Ideally the code will serve as an educational tool in the
+future for CS students studying number theory.
+
+The library provides a vast array of highly optimized routines from various
+branches of number theory.
+
+ * Simple Algebraic
+ o Addition
+ o Subtraction
+ o Multiplication
+ o Squaring
+ o Division
+ * Digit Manipulation
+ o Shift left/right whole digits (mult by 2b by moving digits)
+ o Fast multiplication/division by 2 and 2k for k>1
+ o Binary AND, OR and XOR gates
+ * Modular Reductions
+ o Barrett Reduction (fast for any p)
+ o Montgomery Reduction (faster for any odd p)
+ o DR Reduction (faster for any restricted p see manual)
+ o 2k Reduction (fast reduction modulo 2p - k)
+ o The exptmod logic can use any of the four reduction algorithms when
+appropriate with a single function call.
+ * Number Theoretic
+ o Greatest Common Divisor
+ o Least Common Multiple
+ o Jacobi Symbol Computation (falls back to Legendre for prime moduli)
+ o Multiplicative Inverse
+ o Extended Euclidean Algorithm
+ o Modular Exponentiation
+ o Fermat and Miller-Rabin Primality Tests, utility function such as
+is_prime and next_prime
+ * Miscellaneous
+ o Root finding over Z
+ o Pseudo-random integers
+ o Signed and Unsigned comparisons
+ * Optimizations
+ o Fast Comba based Multiplier, Squaring and Montgomery routines.
+ o Montgomery, Diminished Radix and Barrett based modular
+exponentiation.
+ o Karatsuba and Toom-Cook multiplication algorithms.
+ o Many pointer aliasing optimiztions throughout the entire library.
+</longdescription>
+</pkgmetadata>