summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-12-15 07:30:28 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-12-15 07:30:28 +0000
commitd7bce0e9eb740030151645d887a59ce94f6c2bd8 (patch)
tree35223c39e9ff90d551ac13ce2ae1c141d166c401 /dev-libs/newt
parent- local kernel DoS CAN-2004-1016 (diff)
downloadhistorical-d7bce0e9eb740030151645d887a59ce94f6c2bd8.tar.gz
historical-d7bce0e9eb740030151645d887a59ce94f6c2bd8.tar.bz2
historical-d7bce0e9eb740030151645d887a59ce94f6c2bd8.zip
Bug #73850, and clean up the build process as well.
Diffstat (limited to 'dev-libs/newt')
-rw-r--r--dev-libs/newt/ChangeLog8
-rw-r--r--dev-libs/newt/Manifest15
-rw-r--r--dev-libs/newt/files/digest-newt-0.50.35-r41
-rw-r--r--dev-libs/newt/newt-0.50.35-r4.ebuild48
4 files changed, 70 insertions, 2 deletions
diff --git a/dev-libs/newt/ChangeLog b/dev-libs/newt/ChangeLog
index 6f09cc6b4407..7cb924668df6 100644
--- a/dev-libs/newt/ChangeLog
+++ b/dev-libs/newt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/newt
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.13 2004/06/24 23:29:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.14 2004/12/15 07:30:28 robbat2 Exp $
+
+*newt-0.50.35-r4 (14 Dec 2004)
+
+ 14 Dec 2004; Robin H. Johnson <robbat2@gentoo.org>
+ +newt-0.50.35-r4.ebuild:
+ Bug #73850, and clean up the build process as well.
*newt-0.50.35-r3 (12 May 2004)
diff --git a/dev-libs/newt/Manifest b/dev-libs/newt/Manifest
index 3e4681fbf864..c2579cf7ad48 100644
--- a/dev-libs/newt/Manifest
+++ b/dev-libs/newt/Manifest
@@ -1,5 +1,18 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 40e01ec956d720880d36aa6f1cc0a9ec newt-0.50.35-r3.ebuild 899
MD5 cc19d21de0e9ae41c1c65a428c75557d newt-0.50.35-r2.ebuild 860
-MD5 9240c74cf5ddeb8b976edee670083216 ChangeLog 1610
+MD5 4eb96288aa305600158e7ad0eae0652e newt-0.50.35-r4.ebuild 1508
+MD5 90e7a768febefd8fa051202ef3f342c7 ChangeLog 1776
MD5 6d5a67f6fae3839c22aa176ffbd96790 files/digest-newt-0.50.35-r2 64
MD5 6d5a67f6fae3839c22aa176ffbd96790 files/digest-newt-0.50.35-r3 64
+MD5 6d5a67f6fae3839c22aa176ffbd96790 files/digest-newt-0.50.35-r4 64
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+Comment: Robbat2 @ Orbis-Terrarum Networks
+
+iD8DBQFBv+faPpIsIjIzwiwRAhP7AJ98dud6KBXYois/GULEpWWo8xe11gCgy5cR
+8vdfFhkCn2W4izJmffVE/60=
+=cri2
+-----END PGP SIGNATURE-----
diff --git a/dev-libs/newt/files/digest-newt-0.50.35-r4 b/dev-libs/newt/files/digest-newt-0.50.35-r4
new file mode 100644
index 000000000000..ac9ded732f82
--- /dev/null
+++ b/dev-libs/newt/files/digest-newt-0.50.35-r4
@@ -0,0 +1 @@
+MD5 87a0555f83473a67a848a11c99dd7755 newt-0.50.35.tar.gz 106345
diff --git a/dev-libs/newt/newt-0.50.35-r4.ebuild b/dev-libs/newt/newt-0.50.35-r4.ebuild
new file mode 100644
index 000000000000..2b83a8f7e352
--- /dev/null
+++ b/dev-libs/newt/newt-0.50.35-r4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.50.35-r4.ebuild,v 1.1 2004/12/15 07:30:28 robbat2 Exp $
+
+inherit python toolchain-funcs
+
+DESCRIPTION="Redhat's Newt windowing toolkit development files"
+SRC_URI="http://koto.mynetix.de/gentoo/${P}.tar.gz"
+HOMEPAGE="http://www.redhat.com"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa ~amd64 ~alpha"
+IUSE="uclibc"
+DEPEND=">=sys-libs/slang-1.4
+ >=dev-libs/popt-1.6
+ dev-lang/python
+ uclibc? ( sys-libs/ncurses )"
+
+src_unpack() {
+ unpack ${A}
+ # bug 73850
+ if use uclibc; then
+ sed -i -e 's:-lslang:-lslang -lncurses:g' ${S}/Makefile.in
+ fi
+
+ # use the correct compiler...
+ sed -i -e 's:gcc:$(CC):g' ${S}/Makefile.in
+
+ # avoid make cleaning up some intermediate files
+ # as it would rebuild them during install :-(
+ echo >>${S}/Makefile.in
+ echo '$(LIBNEWT): $(LIBOBJS)' >>${S}/Makefile.in
+}
+
+src_compile() {
+ python_version
+ econf || die
+ emake PYTHONVERS="python${PYVER}" RPM_OPT_FLAGS="${CFLAGS}" CC="$(tc-getCC)" || die "make failure"
+}
+
+src_install () {
+ python_version
+ # the RPM_OPT_FLAGS="ERROR" is there to catch a build error
+ # if it fails, that means something in src_compile() didn't build properly
+ emake prefix="${D}/usr" PYTHONVERS="python${PYVER}" RPM_OPT_FLAGS="ERROR" install || die "make install failed"
+ dodoc CHANGES COPYING peanuts.py popcorn.py tutorial.sgml
+ dosym libnewt.so.${PV} /usr/lib/libnewt.so.0.50
+}