summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-01 18:46:28 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-01 18:46:28 +0000
commit215ee572a0b55d9751bc29a9642596561ffc98c5 (patch)
tree2f999576a4fbdf35b11d42bf1d19d76466969024 /dev-libs/zthread/zthread-1.5.3.ebuild
parentAdded KEYWORDS, removed old version. (diff)
downloadhistorical-215ee572a0b55d9751bc29a9642596561ffc98c5.tar.gz
historical-215ee572a0b55d9751bc29a9642596561ffc98c5.tar.bz2
historical-215ee572a0b55d9751bc29a9642596561ffc98c5.zip
repoman'd
Diffstat (limited to 'dev-libs/zthread/zthread-1.5.3.ebuild')
-rw-r--r--dev-libs/zthread/zthread-1.5.3.ebuild42
1 files changed, 19 insertions, 23 deletions
diff --git a/dev-libs/zthread/zthread-1.5.3.ebuild b/dev-libs/zthread/zthread-1.5.3.ebuild
index 6b5b7ddab297..1ebd10732c3c 100644
--- a/dev-libs/zthread/zthread-1.5.3.ebuild
+++ b/dev-libs/zthread/zthread-1.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $ Header: $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zthread/zthread-1.5.3.ebuild,v 1.5 2002/08/01 18:46:28 seemant Exp $
S=${WORKDIR}/ZThread-${PV}
@@ -8,31 +8,27 @@ DESCRIPTION="A Platform-Independent Object-Oriented Threading Architecture"
SRC_URI="mirror://sourceforge/zthread/ZThread-${PV}.tar.gz"
HOMEPAGE="http://www.cs.buffalo.edu/~crahen/projects/zthread/"
-DEPEND=">=sys-libs/glibc-2.2.4"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc"
src_compile() {
- local myconf
- if [ "${DEBUG}" ]
- then
- myconf="--enable-debug=yes"
- else
- myconf="--enable-debug=no"
- fi
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || \
- ${myconf} || die "./configure failed"
-
- emake || die
-}
+ local myconf
+ if [ "${DEBUG}" ]
+ then
+ myconf="--enable-debug=yes"
+ else
+ myconf="--enable-debug=no"
+ fi
-src_install () {
+ econf ${myconf} || die "./configure failed"
- make prefix=${D}/usr install || die
- dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS TODO THANK.YOU
-
+ emake || die
}
+src_install () {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS TODO THANK.YOU
+}