summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-31 23:32:48 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-31 23:32:48 +0000
commit445fa6a37bfd7ee0fe000439ba697c30aa05d235 (patch)
treeac06b76934241cfc71d4a1d763f4a69e7e7ca485 /dev-libs
parentuse DESTDIR= (diff)
downloadhistorical-445fa6a37bfd7ee0fe000439ba697c30aa05d235.tar.gz
historical-445fa6a37bfd7ee0fe000439ba697c30aa05d235.tar.bz2
historical-445fa6a37bfd7ee0fe000439ba697c30aa05d235.zip
cleaned up, use DESTDIR=, fixed some RDEPEND/DEPEND issues
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libole2/libole2-0.2.3.ebuild13
-rw-r--r--dev-libs/libxml2/libxml2-2.3.11.ebuild24
-rw-r--r--dev-libs/libxml2/libxml2-2.3.14.ebuild24
-rw-r--r--dev-libs/libxml2/libxml2-2.3.9.ebuild24
-rw-r--r--dev-libs/libxml2/libxml2-2.4.0.ebuild24
-rw-r--r--dev-libs/libxml2/libxml2-2.4.1.ebuild24
-rw-r--r--dev-libs/libxslt/libxslt-1.0.1.ebuild17
7 files changed, 64 insertions, 86 deletions
diff --git a/dev-libs/libole2/libole2-0.2.3.ebuild b/dev-libs/libole2/libole2-0.2.3.ebuild
index ab690cf36abe..39c7c70440e6 100644
--- a/dev-libs/libole2/libole2-0.2.3.ebuild
+++ b/dev-libs/libole2/libole2-0.2.3.ebuild
@@ -11,17 +11,14 @@ HOMEPAGE="http://www.gnome.org/"
DEPEND=">=dev-libs/glib-1.2.8"
-
src_compile() {
- try ./configure --host=${CHOST} --prefix=/opt/gnome
- try pmake
+ ./configure --host=${CHOST} --prefix=/opt/gnome || die
+
+ emake || die
}
src_install() {
- try make prefix=${D}/opt/gnome install
+ make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
}
-
-
-
diff --git a/dev-libs/libxml2/libxml2-2.3.11.ebuild b/dev-libs/libxml2/libxml2-2.3.11.ebuild
index f79237ab2cb6..abc31d777726 100644
--- a/dev-libs/libxml2/libxml2-2.3.11.ebuild
+++ b/dev-libs/libxml2/libxml2-2.3.11.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.3.11.ebuild,v 1.2 2001/08/23 10:20:31 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.3.11.ebuild,v 1.3 2001/08/31 23:32:48 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -15,20 +15,16 @@ DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3"
src_compile() {
- local myconf
- try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc --with-zlib
- try make
-}
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-zlib || die
-src_install() {
- try make install prefix=${D}/usr sysconfdir=${D}/etc \
- mandir=${D}/usr/share/man
- dodoc AUTHORS COPYING* ChangeLog NEWS README
+ emake || die
}
+src_install() {
+ make DESTDIR=${D} install || die
-
-
-
-
-
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
diff --git a/dev-libs/libxml2/libxml2-2.3.14.ebuild b/dev-libs/libxml2/libxml2-2.3.14.ebuild
index 5167597fa004..dec4f070120e 100644
--- a/dev-libs/libxml2/libxml2-2.3.14.ebuild
+++ b/dev-libs/libxml2/libxml2-2.3.14.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.3.14.ebuild,v 1.1 2001/07/10 08:15:27 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.3.14.ebuild,v 1.2 2001/08/31 23:32:48 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -15,20 +15,16 @@ DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3"
src_compile() {
- local myconf
- try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc --with-zlib
- try make
-}
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-zlib || die
-src_install() {
- try make install prefix=${D}/usr sysconfdir=${D}/etc \
- mandir=${D}/usr/share/man
- dodoc AUTHORS COPYING* ChangeLog NEWS README
+ emake || die
}
+src_install() {
+ make DESTDIR=${D} install || die
-
-
-
-
-
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
diff --git a/dev-libs/libxml2/libxml2-2.3.9.ebuild b/dev-libs/libxml2/libxml2-2.3.9.ebuild
index f0b8dca8307c..31c21fea71a8 100644
--- a/dev-libs/libxml2/libxml2-2.3.9.ebuild
+++ b/dev-libs/libxml2/libxml2-2.3.9.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.3.9.ebuild,v 1.3 2001/08/23 10:20:31 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.3.9.ebuild,v 1.4 2001/08/31 23:32:48 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -15,20 +15,16 @@ DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3"
src_compile() {
- local myconf
- try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc --with-zlib
- try pmake
-}
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-zlib || die
-src_install() {
- try make install prefix=${D}/usr sysconfdir=${D}/etc \
- mandir=${D}/usr/share/man
- dodoc AUTHORS COPYING* ChangeLog NEWS README
+ emake || die
}
+src_install() {
+ make DESTDIR=${D} install
-
-
-
-
-
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
diff --git a/dev-libs/libxml2/libxml2-2.4.0.ebuild b/dev-libs/libxml2/libxml2-2.4.0.ebuild
index f8bbe6a8519b..1e55ff53087d 100644
--- a/dev-libs/libxml2/libxml2-2.4.0.ebuild
+++ b/dev-libs/libxml2/libxml2-2.4.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.4.0.ebuild,v 1.2 2001/08/23 10:20:31 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.4.0.ebuild,v 1.3 2001/08/31 23:32:48 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -15,20 +15,16 @@ DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3"
src_compile() {
- local myconf
- try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc --with-zlib
- try pmake
-}
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-zlib || die
-src_install() {
- try make install prefix=${D}/usr sysconfdir=${D}/etc \
- mandir=${D}/usr/share/man
- dodoc AUTHORS COPYING* ChangeLog NEWS README
+ emake || die
}
+src_install() {
+ make DESTDIR=${D} install
-
-
-
-
-
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
diff --git a/dev-libs/libxml2/libxml2-2.4.1.ebuild b/dev-libs/libxml2/libxml2-2.4.1.ebuild
index 3f0fdbb0c5a0..481c2902af53 100644
--- a/dev-libs/libxml2/libxml2-2.4.1.ebuild
+++ b/dev-libs/libxml2/libxml2-2.4.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.4.1.ebuild,v 1.2 2001/08/23 10:20:31 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.4.1.ebuild,v 1.3 2001/08/31 23:32:48 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -15,20 +15,16 @@ DEPEND="virtual/glibc
>=sys-libs/zlib-1.1.3"
src_compile() {
- local myconf
- try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc --with-zlib
- try pmake
-}
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-zlib || die
-src_install() {
- try make install prefix=${D}/usr sysconfdir=${D}/etc \
- mandir=${D}/usr/share/man
- dodoc AUTHORS COPYING* ChangeLog NEWS README
+ emake || die
}
+src_install() {
+ make DESTDIR=${D} install || die
-
-
-
-
-
+ dodoc AUTHORS COPYING* ChangeLog NEWS README
+}
diff --git a/dev-libs/libxslt/libxslt-1.0.1.ebuild b/dev-libs/libxslt/libxslt-1.0.1.ebuild
index 2698d5ce0625..74dc9aa25fe3 100644
--- a/dev-libs/libxslt/libxslt-1.0.1.ebuild
+++ b/dev-libs/libxslt/libxslt-1.0.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.0.1.ebuild,v 1.2 2001/08/23 10:20:31 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.0.1.ebuild,v 1.3 2001/08/31 23:32:48 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,21 +9,22 @@ DESCRIPTION="libxslt"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/"
-DEPEND="virtual/glibc sys-devel/perl
- >=gnome-libs/libxml2-2.4.1"
-
RDEPEND="virtual/glibc
>=gnome-libs/libxml2-2.4.1"
+DEPEND="${RDEPEND}
+ sys-devel/perl"
+
src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man || die
- try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
- try make
+ make || die
}
src_install() {
+ make DESTDIR=${D} install || die
- try make prefix=${D}/usr mandir=${D}/usr/share/man install
dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
}
-