summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-08-29 15:48:20 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-08-29 15:48:20 +0000
commit733fffe6328fcf1de0f676378240595ac89bf652 (patch)
tree725d90683c1d0d26daa4360b744ec17fbf0fd012 /dev-libs
parentBumped to new revision to fix a sandbox violation. (diff)
downloadhistorical-733fffe6328fcf1de0f676378240595ac89bf652.tar.gz
historical-733fffe6328fcf1de0f676378240595ac89bf652.tar.bz2
historical-733fffe6328fcf1de0f676378240595ac89bf652.zip
Version bump, closes #6920.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/ChangeLog7
-rw-r--r--dev-libs/openssl/files/digest-openssl-0.9.6g1
-rw-r--r--dev-libs/openssl/openssl-0.9.6g.ebuild44
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index 1ac297f90c4a..a49dc9ffde19 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/openssl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.9 2002/08/03 16:11:06 cselkirk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.10 2002/08/29 15:48:20 aliz Exp $
+
+*opessl-0.9.6g (29 Aug 2002)
+
+ 29 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> openssl-0.9.6g.ebuild :
+ Version bump, closes #6290. Ebuild contributed by hannes@mehnert.org.
*openssl-0.9.6e (30 Jul 2002)
diff --git a/dev-libs/openssl/files/digest-openssl-0.9.6g b/dev-libs/openssl/files/digest-openssl-0.9.6g
new file mode 100644
index 000000000000..1df7dfe2913b
--- /dev/null
+++ b/dev-libs/openssl/files/digest-openssl-0.9.6g
@@ -0,0 +1 @@
+MD5 515ed54165a55df83f4eb4e4e9078d3f openssl-0.9.6g.tar.gz 2170570
diff --git a/dev-libs/openssl/openssl-0.9.6g.ebuild b/dev-libs/openssl/openssl-0.9.6g.ebuild
new file mode 100644
index 000000000000..f824482ec199
--- /dev/null
+++ b/dev-libs/openssl/openssl-0.9.6g.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
+SRC_URI="http://www.openssl.org/source/${P}.tar.gz"
+HOMEPAGE="http://www.openssl.org/"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND} >=sys-devel/perl-5"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ cp Configure Configure.orig
+ sed -e "s/-O3/$CFLAGS/" -e "s/-m486//" Configure.orig > Configure
+}
+
+src_compile() {
+ ./config --prefix=/usr --openssldir=/usr/lib/ssl shared threads || die
+ # i think parallel make has problems
+ make all || die
+}
+
+src_install() {
+ make INSTALL_PREFIX=${D} MANDIR=/usr/share/man install || die
+ dodoc CHANGES* FAQ LICENSE NEWS README
+ dodoc doc/*.txt
+ dohtml doc/*
+ insinto /usr/share/emacs/site-lisp
+ doins doc/c-indentation.el
+
+ # The man pages rand.3 and passwd.1 conflict with other packages
+ # Rename them to ssl-* and also make a symlink from openssl-* to ssl-*
+ cd ${D}/usr/share/man/man1
+ mv passwd.1 ssl-passwd.1
+ ln -sf ssl-passwd.1 openssl-passwd.1
+ cd ${D}/usr/share/man/man3
+ mv rand.3 ssl-rand.3
+ ln -sf ssl-rand.3 openssl-rand.3
+}
+