summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-12-14 04:32:06 +0000
committerDaniel Goller <morfic@gentoo.org>2004-12-14 04:32:06 +0000
commit7b664b7e7c8b3323046284c5417a9680c1716683 (patch)
tree69191ef65c39ac668941d2d0024978dad9389bc5 /dev-libs
parentStable on sparc. (diff)
downloadhistorical-7b664b7e7c8b3323046284c5417a9680c1716683.tar.gz
historical-7b664b7e7c8b3323046284c5417a9680c1716683.tar.bz2
historical-7b664b7e7c8b3323046284c5417a9680c1716683.zip
Readding icc support, restoring -toolset- libnames, using python.eclass to avoid using sed
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog6
-rw-r--r--dev-libs/boost/Manifest10
-rw-r--r--dev-libs/boost/boost-1.32.0.ebuild21
3 files changed, 23 insertions, 14 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 737a2c8fa68c..51725fc8009a 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.30 2004/12/12 23:40:59 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.31 2004/12/14 04:32:06 morfic Exp $
+
+ 13 Dec 2004; Daniel Goller <morfic@gentoo.org> boost-1.32.0.ebuild:
+ Readding icc support, restoring -toolset- libnames, using python.eclass to
+ avoid using sed
12 Dec 2004; Daniel Goller <morfic@gentoo.org> boost-1.32.0.ebuild:
Fix bjam path
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 80c17a717fad..f3e8b00eadb7 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -2,10 +2,10 @@
Hash: SHA1
MD5 c0e0b430578e177a32295ce8f365302d boost-1.31.0.ebuild 3967
-MD5 21cb10d71e4bc367f50a3acbb94fbd44 boost-1.32.0.ebuild 2042
+MD5 caa9c880eaaa012043f9248339681885 boost-1.32.0.ebuild 2023
MD5 7a5736de479368e026895776885a1f4c boost-1.29.0.ebuild 1428
MD5 c38336b27cb2a10759ade6f16799d051 boost-1.30.0.ebuild 2977
-MD5 161d66557b53fcf20d2be00d087e7028 ChangeLog 4593
+MD5 b7d924cc62ac4691ec2b3f5d0e64d9c1 ChangeLog 4759
MD5 19f97285acdda370e331ee909e26df4c metadata.xml 340
MD5 6fd34399d93efc1de1221666ed6d37d1 boost-1.30.2.ebuild 2964
MD5 ed187a2b2048776a7e5b27060d96938c files/digest-boost-1.29.0 65
@@ -16,7 +16,7 @@ MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0 67
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBvNcNUpKYMelfdYERAqX3AJsEOCx5eRNzmetjCWy1EipRwaGbOACff4DJ
-eT5fxlTFYCOGofWl2JM8UzQ=
-=YYBe
+iD8DBQFBvnjTUpKYMelfdYERAqDwAJ9+77f5hOwKe2NnFgaCGWwrJGvDPACcCWee
+ejfwctXZMPaqnJrxa1psnCg=
+=CK74
-----END PGP SIGNATURE-----
diff --git a/dev-libs/boost/boost-1.32.0.ebuild b/dev-libs/boost/boost-1.32.0.ebuild
index abbb9e0ab2b0..4f0e4f252b80 100644
--- a/dev-libs/boost/boost-1.32.0.ebuild
+++ b/dev-libs/boost/boost-1.32.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0.ebuild,v 1.7 2004/12/12 23:37:18 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0.ebuild,v 1.8 2004/12/14 04:32:06 morfic Exp $
# This ebuild was generated by Ebuilder v0.4.
+inherit python
BOOST_PV1=${PV/./_}
BOOST_PV=${BOOST_PV1/./_}
@@ -17,7 +18,6 @@ IUSE="icc"
DEPEND="sys-devel/gcc
dev-lang/python"
KEYWORDS="~x86 ~ppc ~amd64 ~sparc ~ppc64"
-PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
if [ "${ARCH}" == "amd64" ]; then
arch=
@@ -25,9 +25,16 @@ else
arch=${ARCH}
fi
+if use icc ; then
+ BOOST_TOOLSET="intel-linux"
+else
+ BOOST_TOOLSET="gcc"
+fi
+
BOOSTJAM=./tools/build/jam_src/bin.linux${arch}/bjam
src_compile() {
+ python_version
cd ${S}/tools/build/jam_src
./build.sh || die "Failed to build bjam"
cd ${S}
@@ -36,10 +43,9 @@ src_compile() {
${BOOSTJAM} \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
- -sPYTHON_VERSION=${PYTHON_VERSION} \
- -sTOOLS=gcc \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
--prefix=${D}/usr \
- --layout=system \
stage
}
@@ -48,10 +54,9 @@ src_install () {
${BOOSTJAM} ${MAKEOPTS} \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
- -sPYTHON_VERSION=${PYTHON_VERSION} \
- -sTOOLS=gcc \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
--prefix=${D}/usr \
- --layout=system \
install
# Install documentation; seems to be mostly under ${S}/lib