summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-06-05 23:41:18 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-06-05 23:41:18 +0000
commit98dbc6bece900e607267b008fefa3484b2f2dd26 (patch)
treea8e05d5dc76fc15046dd8b447e510de071c5274d /dev-lisp/cl-html-encode/cl-html-encode-1.2.ebuild
parentStable on SPARC wrt security bug #134010. (diff)
downloadhistorical-98dbc6bece900e607267b008fefa3484b2f2dd26.tar.gz
historical-98dbc6bece900e607267b008fefa3484b2f2dd26.tar.bz2
historical-98dbc6bece900e607267b008fefa3484b2f2dd26.zip
New upstream version.
Package-Manager: portage-2.1_rc4-r1
Diffstat (limited to 'dev-lisp/cl-html-encode/cl-html-encode-1.2.ebuild')
-rw-r--r--dev-lisp/cl-html-encode/cl-html-encode-1.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-lisp/cl-html-encode/cl-html-encode-1.2.ebuild b/dev-lisp/cl-html-encode/cl-html-encode-1.2.ebuild
new file mode 100644
index 000000000000..6308d3ee8aeb
--- /dev/null
+++ b/dev-lisp/cl-html-encode/cl-html-encode-1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-html-encode/cl-html-encode-1.2.ebuild,v 1.1 2006/06/05 23:41:18 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="Common Lisp library for encoding text in various web-savvy formats."
+HOMEPAGE="http://www.cliki.net/html-encode"
+SRC_URI="http://www.unmutual.info/software/html-encode-${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/commonlisp
+ dev-lisp/common-lisp-controller"
+
+CLPACKAGE=html-encode
+
+S=${WORKDIR}/html-encode-${PV}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc LICENSE
+}