summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-08-26 15:56:52 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-08-26 15:56:52 +0000
commitbbf0e33813c70a835b2642e3383974a91fc6ee4a (patch)
treeca6b8c44ebd99e88c3aacb334ce64d1eb86cece1 /dev-lisp/cl-html-template
parentinitial import (diff)
downloadhistorical-bbf0e33813c70a835b2642e3383974a91fc6ee4a.tar.gz
historical-bbf0e33813c70a835b2642e3383974a91fc6ee4a.tar.bz2
historical-bbf0e33813c70a835b2642e3383974a91fc6ee4a.zip
initial import
Diffstat (limited to 'dev-lisp/cl-html-template')
-rw-r--r--dev-lisp/cl-html-template/Manifest4
-rw-r--r--dev-lisp/cl-html-template/cl-html-template-0.1.2.ebuild27
-rw-r--r--dev-lisp/cl-html-template/files/digest-cl-html-template-0.1.21
3 files changed, 30 insertions, 2 deletions
diff --git a/dev-lisp/cl-html-template/Manifest b/dev-lisp/cl-html-template/Manifest
index aca9299505f7..f7b9ffb6f343 100644
--- a/dev-lisp/cl-html-template/Manifest
+++ b/dev-lisp/cl-html-template/Manifest
@@ -1,3 +1,3 @@
-MD5 34bae9fe1155822889cb7cde99c33ed4 cl-html-template-0.1.2.ebuild 1188
-MD5 858972c54bb0eac04e9baac01788f48d cl-html-template-0.1.2.ebuild~ 761
+MD5 39d14e110445cd04977dff560b296011 cl-html-template-0.1.2.ebuild 1194
+MD5 3a976aa37b57188c2f2f929a70162bd6 ChangeLog 345
MD5 73454c494abcf80a74cbda0937b17070 files/digest-cl-html-template-0.1.2 70
diff --git a/dev-lisp/cl-html-template/cl-html-template-0.1.2.ebuild b/dev-lisp/cl-html-template/cl-html-template-0.1.2.ebuild
new file mode 100644
index 000000000000..4ba3b499fa71
--- /dev/null
+++ b/dev-lisp/cl-html-template/cl-html-template-0.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-html-template/cl-html-template-0.1.2.ebuild,v 1.1 2003/08/26 15:56:50 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="HTML-TEMPLATE is a portable library for Common Lisp which can be used to fill templates with arbitrary (string) values at runtime. (Actually, it doesn't matter whether the result is HTML. It's just very likely that this will be what the library is mostly used for.) It is loosely modeled after the Perl module HTML::Template and compatible with a subset of its syntax, i.e. it should be possible to use your HTML-TEMPLATE templates with HTML::Template as well (but usually not the other way around)."
+HOMEPAGE="http://weitz.de/html-template/
+ http://www.cliki.net/html-template"
+SRC_URI="mirror://gentoo/${P/cl-/}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=html-template
+
+S=${WORKDIR}/${P/cl-/}
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc CHANGELOG INSTALLATION
+ dohtml doc/*.html
+}
diff --git a/dev-lisp/cl-html-template/files/digest-cl-html-template-0.1.2 b/dev-lisp/cl-html-template/files/digest-cl-html-template-0.1.2
new file mode 100644
index 000000000000..0c1cf0e4adca
--- /dev/null
+++ b/dev-lisp/cl-html-template/files/digest-cl-html-template-0.1.2
@@ -0,0 +1 @@
+MD5 8cc5c7190900e7caadf3d122f8614869 html-template-0.1.2.tar.gz 24444