summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:53:04 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-06-10 04:53:04 +0000
commit617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f (patch)
treebcfe11291f5c920da39dfc65ba00f51356086a04 /dev-lisp/cl-statistics
parentDEPEND on sed >= 4 (diff)
downloadhistorical-617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f.tar.gz
historical-617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f.tar.bz2
historical-617b5ce9977eeb5a7a7977ef4c6974bf0aecf19f.zip
initial common lisp import
Diffstat (limited to 'dev-lisp/cl-statistics')
-rw-r--r--dev-lisp/cl-statistics/ChangeLog8
-rw-r--r--dev-lisp/cl-statistics/Manifest5
-rw-r--r--dev-lisp/cl-statistics/cl-statistics-1.0.0.1.ebuild26
-rw-r--r--dev-lisp/cl-statistics/files/cl-statistics.asd30
-rw-r--r--dev-lisp/cl-statistics/files/digest-cl-statistics-1.0.0.11
5 files changed, 70 insertions, 0 deletions
diff --git a/dev-lisp/cl-statistics/ChangeLog b/dev-lisp/cl-statistics/ChangeLog
new file mode 100644
index 000000000000..4d760befaab8
--- /dev/null
+++ b/dev-lisp/cl-statistics/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-lisp/cl-statistics
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-statistics/ChangeLog,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+*cl-statistics-1.0.0.1 (07 Jul 2003)
+
+ 07 Jul 2003; Matthew Kennedy <mkennedy@gentoo.org> :
+ initial import
diff --git a/dev-lisp/cl-statistics/Manifest b/dev-lisp/cl-statistics/Manifest
new file mode 100644
index 000000000000..362ac4f6eca5
--- /dev/null
+++ b/dev-lisp/cl-statistics/Manifest
@@ -0,0 +1,5 @@
+MD5 ca86239b39a85182a79b14a679aa6c8a ChangeLog 332
+MD5 eaab8126ea2f543e27bab9636450f24f cl-statistics-1.0.0.1.ebuild 645
+MD5 7a2412a7997a16db85890d4bdd0876a7 cl-statistics-1.0.0.1.ebuild~ 585
+MD5 18de310292b70deeb144e5b3328f858b files/cl-statistics.asd 1089
+MD5 a9cba10a5762d6f7da111f3ec126c9ac files/digest-cl-statistics-1.0.0.1 77
diff --git a/dev-lisp/cl-statistics/cl-statistics-1.0.0.1.ebuild b/dev-lisp/cl-statistics/cl-statistics-1.0.0.1.ebuild
new file mode 100644
index 000000000000..f43b24bac7f5
--- /dev/null
+++ b/dev-lisp/cl-statistics/cl-statistics-1.0.0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-statistics/cl-statistics-1.0.0.1.ebuild,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp Statistics Package"
+HOMEPAGE="http://www.biolisp.org
+ http://packages.debian.org/unstable/devel/cl-statistics.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-statistics/${PN}_${PV}.orig.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=cl-statistics
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ common-lisp-install *.lisp ${FILESDIR}/${PN}.asd
+ common-lisp-system-symlink
+ dodoc *.txt
+}
diff --git a/dev-lisp/cl-statistics/files/cl-statistics.asd b/dev-lisp/cl-statistics/files/cl-statistics.asd
new file mode 100644
index 000000000000..c3b66e429e50
--- /dev/null
+++ b/dev-lisp/cl-statistics/files/cl-statistics.asd
@@ -0,0 +1,30 @@
+;;;; -*- Mode: Lisp; Syntax: ANSI-Common-Lisp; Base: 10 -*-
+;;;; *************************************************************************
+;;;; FILE IDENTIFICATION
+;;;;
+;;;; Name: cl-statistics.system
+;;;; Purpose: ASDF definition for cl-statistics package
+;;;; Programmer: Kevin M. Rosenberg
+;;;; Date Started: 06 Sep 2002
+;;;;
+;;;; Users are granted the rights to distribute and use this software
+;;;; as governed by the terms of the GNU Public License
+;;;; *************************************************************************
+
+(in-package :asdf)
+
+(defsystem :cl-statistics
+ :name "cl-statistics"
+ :author "Larry Hunter <larry.hunter@uchsc.edu>"
+ :version "1.0.0"
+ :maintainer "Kevin M. Rosenberg <kmr@debian.org>"
+ :licence "GNU General Public License"
+ :description "Statistics package for Common Lisp"
+ :long-description "cl-statistics provides numerous statistical functions for use in Common Lisp programs."
+
+ :perform (load-op :after (op cl-statistics)
+ (pushnew :cl-statistics cl:*features*))
+ :components
+ ((:file "cl-statistics"))
+ )
+
diff --git a/dev-lisp/cl-statistics/files/digest-cl-statistics-1.0.0.1 b/dev-lisp/cl-statistics/files/digest-cl-statistics-1.0.0.1
new file mode 100644
index 000000000000..aa95a569a14e
--- /dev/null
+++ b/dev-lisp/cl-statistics/files/digest-cl-statistics-1.0.0.1
@@ -0,0 +1 @@
+MD5 c0410b3eca5da846fdb3574651cf1418 cl-statistics_1.0.0.1.orig.tar.gz 31443