summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-09-07 14:32:46 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-09-07 14:32:46 +0000
commit1553852942f47dc2d52bddd83ae1bdd200c20a10 (patch)
tree947772ce301bd030cb74356c278cdf16cfff490b /dev-lisp
parentStable on amd64 (diff)
downloadhistorical-1553852942f47dc2d52bddd83ae1bdd200c20a10.tar.gz
historical-1553852942f47dc2d52bddd83ae1bdd200c20a10.tar.bz2
historical-1553852942f47dc2d52bddd83ae1bdd200c20a10.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-common-idioms/ChangeLog10
-rw-r--r--dev-lisp/cl-common-idioms/Manifest14
-rw-r--r--dev-lisp/cl-common-idioms/cl-common-idioms-3.ebuild30
-rw-r--r--dev-lisp/cl-common-idioms/files/digest-cl-common-idioms-31
-rw-r--r--dev-lisp/cl-common-idioms/metadata.xml5
5 files changed, 60 insertions, 0 deletions
diff --git a/dev-lisp/cl-common-idioms/ChangeLog b/dev-lisp/cl-common-idioms/ChangeLog
new file mode 100644
index 000000000000..a1bc2de5d3e1
--- /dev/null
+++ b/dev-lisp/cl-common-idioms/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-common-idioms
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-common-idioms/ChangeLog,v 1.1 2005/09/07 14:32:46 mkennedy Exp $
+
+*cl-common-idioms-3 (07 Sep 2005)
+
+ 07 Sep 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +cl-common-idioms-3.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
+
diff --git a/dev-lisp/cl-common-idioms/Manifest b/dev-lisp/cl-common-idioms/Manifest
new file mode 100644
index 000000000000..1bbf5d3f89c1
--- /dev/null
+++ b/dev-lisp/cl-common-idioms/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 28ef92a0cbd5ac2ce47d8d5340e4274c cl-common-idioms-3.ebuild 778
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 7d49d57f2268c1cd2afe0ab16f93999b ChangeLog 437
+MD5 48cc7c24542420a5efc1684128555023 files/digest-cl-common-idioms-3 66
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDHvqdyiNZaEAZA+ARAhwQAJkBAid6wWJWv6wvZSF0khGrELapDQCfX7nI
+9zevdyYKzJTAuAnCqBk6L0s=
+=88yh
+-----END PGP SIGNATURE-----
diff --git a/dev-lisp/cl-common-idioms/cl-common-idioms-3.ebuild b/dev-lisp/cl-common-idioms/cl-common-idioms-3.ebuild
new file mode 100644
index 000000000000..b365b025fe51
--- /dev/null
+++ b/dev-lisp/cl-common-idioms/cl-common-idioms-3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-common-idioms/cl-common-idioms-3.ebuild,v 1.1 2005/09/07 14:32:46 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="A small Common Lisp library implementing various Common Lisp idioms."
+HOMEPAGE="http://www.unmutual.info/software/common-idioms/"
+SRC_URI="mirror://gentoo/common-idioms-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+CLPACKAGE=common-idioms
+
+S=${WORKDIR}/common-idioms-${PV}
+
+src_unpack() {
+ unpack ${A}
+ rm ${S}/Makefile
+}
+
+src_install() {
+ common-lisp-install *.{asd,lisp}
+ common-lisp-system-symlink
+ dodoc LICENSE README
+ dohtml docs/*.{html,css}
+ dohtml -r docs/icons
+}
diff --git a/dev-lisp/cl-common-idioms/files/digest-cl-common-idioms-3 b/dev-lisp/cl-common-idioms/files/digest-cl-common-idioms-3
new file mode 100644
index 000000000000..8d648969fb4d
--- /dev/null
+++ b/dev-lisp/cl-common-idioms/files/digest-cl-common-idioms-3
@@ -0,0 +1 @@
+MD5 292c806ac3781ed164f8bdb7805b4d7a common-idioms-3.tar.gz 19283
diff --git a/dev-lisp/cl-common-idioms/metadata.xml b/dev-lisp/cl-common-idioms/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-common-idioms/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>