summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-12-17 12:16:41 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-12-17 12:16:41 +0000
commitb89f5e18efe80ce2eba471d0ac8a9b170ea4c72c (patch)
treef5682b5211e91ee61593180cb72553fb069c7f40 /dev-lisp
parentVersion bump (to improve maxima support), ebuild from the lisp overlay (diff)
downloadhistorical-b89f5e18efe80ce2eba471d0ac8a9b170ea4c72c.tar.gz
historical-b89f5e18efe80ce2eba471d0ac8a9b170ea4c72c.tar.bz2
historical-b89f5e18efe80ce2eba471d0ac8a9b170ea4c72c.zip
Initial import (from the lisp overlay)
Package-Manager: portage-2.2_rc60/cvs/Linux i686
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clozurecl/ChangeLog10
-rw-r--r--dev-lisp/clozurecl/Manifest5
-rw-r--r--dev-lisp/clozurecl/clozurecl-1.4.ebuild87
-rw-r--r--dev-lisp/clozurecl/files/fix_user-homedir-pathname.patch13
-rw-r--r--dev-lisp/clozurecl/metadata.xml8
5 files changed, 123 insertions, 0 deletions
diff --git a/dev-lisp/clozurecl/ChangeLog b/dev-lisp/clozurecl/ChangeLog
new file mode 100644
index 000000000000..824227b0c350
--- /dev/null
+++ b/dev-lisp/clozurecl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/clozurecl
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v 1.1 2009/12/17 12:16:40 grozin Exp $
+
+*clozurecl-1.4 (17 Dec 2009)
+
+ 17 Dec 2009; Andrey Grozin <grozin@gentoo.org> +clozurecl-1.4.ebuild,
+ +files/fix_user-homedir-pathname.patch, +metadata.xml:
+ Initial import (from the lisp overlay)
+
diff --git a/dev-lisp/clozurecl/Manifest b/dev-lisp/clozurecl/Manifest
new file mode 100644
index 000000000000..2112470f7e9e
--- /dev/null
+++ b/dev-lisp/clozurecl/Manifest
@@ -0,0 +1,5 @@
+AUX fix_user-homedir-pathname.patch 587 RMD160 26371c30e58c1b474a4b85a5cffa4bdc0a8cc82f SHA1 4547a35910124959e0372ac608f53e81ee3b4eed SHA256 733959b1e415d1fcf7dde5bb73a023b449951468f6c98ad69648a478b220ea2b
+DIST ccl-1.4-linuxx86.tar.gz 41535223 RMD160 78ade2a0af9b672bfac240144745bf0deb3d9064 SHA1 08c1ac7037d6e95c7458fc8f891954c9c2d6e3ca SHA256 e879b704400a229668e92af0b7579fed01c1b9aca567b7c57a910a29fb249dfc
+EBUILD clozurecl-1.4.ebuild 2551 RMD160 31120251ee40c199832937e0a523a38ae09f87a0 SHA1 6d03cd6530bff6a4247b671fd5ea4bbfe7f79758 SHA256 d5812ee87052c51bdbab3c8d41da47cbfdd87c75a0de31e5f23a8aa59aadd53f
+MISC ChangeLog 410 RMD160 0a04462414219fd5de5606a5adb30a408c7fb85c SHA1 bda6ae8fa59cab5f15d68eddfee14b692f2d16c0 SHA256 7490aa6b0117ad839f7165a3bd792d1fb78f0546dfe231c991c03e3433f649a1
+MISC metadata.xml 273 RMD160 224a4502b91467dc7687eb1751d85ec06fa7c98e SHA1 f6ce304d6ca6ccb6544c80fdbaba73b52d3be02b SHA256 caf1d458d943a906650d49af8fb83557d23284967f26ba6cec96da260c68ec3d
diff --git a/dev-lisp/clozurecl/clozurecl-1.4.ebuild b/dev-lisp/clozurecl/clozurecl-1.4.ebuild
new file mode 100644
index 000000000000..6214a73ef7d6
--- /dev/null
+++ b/dev-lisp/clozurecl/clozurecl-1.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.4.ebuild,v 1.1 2009/12/17 12:16:40 grozin Exp $
+
+EAPI=2
+
+inherit common-lisp-common-3 eutils
+
+MY_PN=ccl
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="ClozureCL is a Common Lisp implementation, derived from Digitool's MCL product"
+HOMEPAGE="http://ccl.clozure.com/"
+SRC_URI="x86? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )
+ amd64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxx86.tar.gz )"
+ # ppc? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )
+ # ppc64? ( ftp://ftp.clozure.com/pub/release/${PV}/${MY_P}-linuxppc.tar.gz )"
+
+LICENSE="LLGPL-2.1"
+SLOT="0"
+# KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="!dev-lisp/openmcl"
+
+PROVIDE="virtual/commonlisp"
+
+S="${WORKDIR}"/${MY_PN}
+
+ENVD="${T}"/50ccl
+
+src_prepare() {
+ find "${S}" -type d -name .svn -exec rm -rf {} ';' &>/dev/null
+ find "${S}" -type f -name .cvsignore -delete &>/dev/null
+ epatch "${FILESDIR}"/fix_user-homedir-pathname.patch
+}
+
+src_configure() {
+ if use x86; then
+ CCL_RUNTIME=lx86cl; CCL_HEADERS=x86-headers
+ elif use amd64; then
+ CCL_RUNTIME=lx86cl64; CCL_HEADERS=x86-headers64
+ elif use ppc; then
+ CCL_RUNTIME=ppccl; CCL_HEADERS=headers
+ elif use ppc64; then
+ CCL_RUNTIME=ppccl64; CCL_HEADERS=headers64
+ fi
+}
+
+src_compile() {
+ unset CCL_DEFAULT_DIRECTORY
+ ./${CCL_RUNTIME} -n -b -Q -e '(ccl:rebuild-ccl :full t)' -e '(ccl:quit)' || die "Compilation failed"
+
+ # remove non-owner write permissions on the full-image
+ chmod go-w ${CCL_RUNTIME}{,.image}
+}
+
+src_install() {
+ local install_dir=/usr/$(get_libdir)/${PN}
+
+ exeinto ${install_dir}
+ # install executable
+ doexe ${CCL_RUNTIME}
+ # install core image
+ cp ${CCL_RUNTIME}.image "${D}"/${install_dir} || die
+ # install optional libraries
+ dodir ${install_dir}/tools
+ cp tools/*fsl "${D}"/${install_dir}/tools || die
+
+ # until we figure out which source files are necessary for runtime
+ # optional features and which aren't, we install all sources
+ find . -type f -name '*fsl' -delete
+ cp -a compiler level-0 level-1 lib library \
+ lisp-kernel scripts tools xdump \
+ "${D}"/${install_dir} || die
+ cp -a ${CCL_HEADERS} "${D}"/${install_dir} || die
+
+ make_wrapper ccl "${install_dir}/${CCL_RUNTIME}"
+
+ echo "CCL_DEFAULT_DIRECTORY=${install_dir}" > "${ENVD}"
+ doenvd "${ENVD}"
+
+ dodoc doc/release-notes.txt
+ dohtml doc/ccl-documentation.html
+ use doc && dohtml -r examples
+}
diff --git a/dev-lisp/clozurecl/files/fix_user-homedir-pathname.patch b/dev-lisp/clozurecl/files/fix_user-homedir-pathname.patch
new file mode 100644
index 000000000000..d69a58f6b4e1
--- /dev/null
+++ b/dev-lisp/clozurecl/files/fix_user-homedir-pathname.patch
@@ -0,0 +1,13 @@
+Index: level-1/l1-pathnames.lisp
+===================================================================
+--- level-1/l1-pathnames.lisp (revision 11951)
++++ level-1/l1-pathnames.lisp (working copy)
+@@ -624,7 +624,7 @@
+ (let* ((native
+ (ignore-errors
+ (truename
+- (native-to-directory-pathname (or #+ccl-0711 (getenv "HOME")
++ (native-to-directory-pathname (or (getenv "HOME")
+ (get-user-home-dir (getuid))))))))
+ (if (and native (eq :absolute (car (pathname-directory native))))
+ native
diff --git a/dev-lisp/clozurecl/metadata.xml b/dev-lisp/clozurecl/metadata.xml
new file mode 100644
index 000000000000..7fb197497d83
--- /dev/null
+++ b/dev-lisp/clozurecl/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+Clozure Common Lisp (formerly OpenMCL) is a Common Lisp implementation.
+</longdescription>
+</pkgmetadata>