summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-19 15:28:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-19 15:28:23 +0000
commite79237c99c3cc03ad48b75fa747b5f596456a9ab (patch)
tree10241ce0f086aa04f5f0b78a1ab4375557882d02 /dev-ml/core/core-109.38.00.ebuild
parentFix build without a previous version installed, bug #481334. Fix by Yuta SATOH (diff)
downloadhistorical-e79237c99c3cc03ad48b75fa747b5f596456a9ab.tar.gz
historical-e79237c99c3cc03ad48b75fa747b5f596456a9ab.tar.bz2
historical-e79237c99c3cc03ad48b75fa747b5f596456a9ab.zip
version bump and fix build with ocaml 4.01
Package-Manager: portage-2.2.0/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'dev-ml/core/core-109.38.00.ebuild')
-rw-r--r--dev-ml/core/core-109.38.00.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/core/core-109.38.00.ebuild b/dev-ml/core/core-109.38.00.ebuild
new file mode 100644
index 000000000000..6c23b6497546
--- /dev/null
+++ b/dev-ml/core/core-109.38.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-109.38.00.ebuild,v 1.1 2013/08/19 15:28:17 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit eutils oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-ml/res:=
+ >=dev-ml/core_kernel-109.35.00:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/pa_ounit-109.27.00:=
+ >=dev-ml/variantslib-109.15.00:=
+ >=dev-ml/comparelib-109.27.00:=
+ >=dev-ml/herelib-109.35.00:=
+ >=dev-ml/pipebang-109.15.00:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.2 )"
+DOCS=( "README.md" )
+
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.01.0_beta' && epatch "${FILESDIR}/${PN}-ocaml-4.01.patch"
+}