summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-27 21:33:16 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-27 21:33:16 +0000
commit1d69ff2bc9bd623b9bd2e5cbd9a1903533b77039 (patch)
tree03928a8de60c2b839ef4776a25939f5bb22fe2e9 /dev-ml/core
parentuse OASIS_BUILD_TESTS (diff)
downloadhistorical-1d69ff2bc9bd623b9bd2e5cbd9a1903533b77039.tar.gz
historical-1d69ff2bc9bd623b9bd2e5cbd9a1903533b77039.tar.bz2
historical-1d69ff2bc9bd623b9bd2e5cbd9a1903533b77039.zip
convert to oasis.eclass
Package-Manager: portage-2.2.0_alpha95/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/core')
-rw-r--r--dev-ml/core/ChangeLog5
-rw-r--r--dev-ml/core/core-107.01.ebuild35
2 files changed, 10 insertions, 30 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
index 655bf2967375..54f68b0ef3ef 100644
--- a/dev-ml/core/ChangeLog
+++ b/dev-ml/core/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/core
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.7 2012/02/23 20:29:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.8 2012/03/27 21:33:16 aballier Exp $
+
+ 27 Mar 2012; Alexis Ballier <aballier@gentoo.org> core-107.01.ebuild:
+ convert to oasis.eclass
23 Feb 2012; Alexis Ballier <aballier@gentoo.org> -core-0.7.0.ebuild:
remove old
diff --git a/dev-ml/core/core-107.01.ebuild b/dev-ml/core/core-107.01.ebuild
index 71f279f4ff2f..c13ab3b076a4 100644
--- a/dev-ml/core/core-107.01.ebuild
+++ b/dev-ml/core/core-107.01.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-107.01.ebuild,v 1.1 2011/10/06 20:45:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-107.01.ebuild,v 1.2 2012/03/27 21:33:16 aballier Exp $
-EAPI="2"
-inherit findlib eutils multilib
+EAPI="3"
+inherit oasis
MY_P=${P/_/\~}
DESCRIPTION="Jane Street's alternative to the standard library"
@@ -13,34 +13,11 @@ SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
LICENSE="LGPL-2.1-linking-exception"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="debug +ocamlopt test"
+IUSE="test"
-RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
- dev-ml/res
+RDEPEND="dev-ml/res
>=dev-ml/sexplib-5.2.1
>=dev-ml/bin-prot-1.3.1
>=dev-ml/fieldslib-0.1.2"
DEPEND="${RDEPEND}
test? ( >=dev-ml/ounit-1.0.2 )"
-
-oasis_use_enable() {
- echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
-}
-
-src_configure() {
- ./configure --prefix usr \
- --libdir /usr/$(get_libdir) \
- --docdir /usr/share/doc/${PF}/html \
- --destdir "${D}" \
- $(oasis_use_enable debug debug) \
- $(oasis_use_enable ocamlopt is_native) \
- || die
-}
-
-src_test() {
- LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
-}
-
-src_install() {
- findlib_src_install
-}