summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-07-08 21:36:45 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-07-08 21:36:45 +0000
commit0888cff7cf901d98931d1944abcc12d83217ce78 (patch)
tree069d01404ff447b3689774f20c64198dacde4341 /dev-ml
parentVersion bumped. Closes #24701. (diff)
downloadhistorical-0888cff7cf901d98931d1944abcc12d83217ce78.tar.gz
historical-0888cff7cf901d98931d1944abcc12d83217ce78.tar.bz2
historical-0888cff7cf901d98931d1944abcc12d83217ce78.zip
Version bumped. Closes #24701.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lablgl/Manifest4
-rw-r--r--dev-ml/lablgl/files/digest-lablgl-0.993
-rw-r--r--dev-ml/lablgl/lablgl-0.99.ebuild64
3 files changed, 69 insertions, 2 deletions
diff --git a/dev-ml/lablgl/Manifest b/dev-ml/lablgl/Manifest
index b9c4ed52788b..126fc63ad87b 100644
--- a/dev-ml/lablgl/Manifest
+++ b/dev-ml/lablgl/Manifest
@@ -1,7 +1,7 @@
-MD5 a943c6c84dafa2919dbe24492c2fad07 ChangeLog 1851
+MD5 4d51b5e28b5d470dc919062c363f7801 ChangeLog 1984
MD5 e8e3f44b50db5ebd8461c746e688b6de lablgl-0.97.ebuild 1100
MD5 e8135976bdabfdc7a206402ad9c3f460 lablgl-0.98.ebuild 1756
-MD5 18439b4f09a1e27e60f24bec6381d0f4 lablgl-0.99.ebuild 1852
+MD5 6ec5733b6f31ffcad81b1218c5fe88a4 lablgl-0.99.ebuild 1853
MD5 b5f4f06ceeac8ce19b70d33f538b885a files/LablGL-0.97-Makefile-destdir.patch 1350
MD5 7b95aa62137ce4a457a8603803892bcd files/LablGL-0.97-Makefile.config 1422
MD5 007f6ebc610ac1d9f52d6396f5b430e1 files/LablGL-0.98-Makefile-destdir.patch 1540
diff --git a/dev-ml/lablgl/files/digest-lablgl-0.99 b/dev-ml/lablgl/files/digest-lablgl-0.99
new file mode 100644
index 000000000000..028acb4ea1a9
--- /dev/null
+++ b/dev-ml/lablgl/files/digest-lablgl-0.99
@@ -0,0 +1,3 @@
+MD5 5b5ea7889536246c58a5e747d61d6d14 lablgl-0.99.tar.gz 263510
+MD5 ee11755055492e0a9e60cb51fae657bf LablGL-0.99-Makefile-destdir.patch 1450
+MD5 7b95aa62137ce4a457a8603803892bcd LablGL-0.99-Makefile.config 1422
diff --git a/dev-ml/lablgl/lablgl-0.99.ebuild b/dev-ml/lablgl/lablgl-0.99.ebuild
new file mode 100644
index 000000000000..4ffd955138e6
--- /dev/null
+++ b/dev-ml/lablgl/lablgl-0.99.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-0.99.ebuild,v 1.1 2003/07/08 21:36:33 mholzer Exp $
+
+IUSE="opengl"
+
+DESCRIPTION="Objective CAML interface for OpenGL"
+HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgl.html"
+LICENSE="as-is"
+
+DEPEND=">=dev-lang/ocaml-3.05
+ opengl? ( virtual/opengl )"
+
+SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/${P}.tar.gz
+ mirror://gentoo/LablGL-0.99-Makefile-destdir.patch
+ mirror://gentoo/LablGL-0.99-Makefile.config"
+S=${WORKDIR}/lablGL-${PV}
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+#need to do some mangling to keep ebuild name lowercase
+#(anyway package uses mixture of upper and lower case letters)
+Name="LablGL"
+
+pkg_setup() {
+ #lablgl requires ocaml compiled with tk support while ocaml has it as an optional dependency
+ #need to do some checks and correct situation as if necessary
+
+ if ( ! which labltk && which ocaml ) || ! ( which labltk && which ocaml || use tcltk ); then
+ eerror "It seems you don't have ocaml compiled with tk support"
+ eerror "or you don't have ocaml installed and tcltk USE flag is"
+ eerror "not defined."
+ eerror ""
+ eerror "lablgl requires ocaml be built with tk support."
+ eerror ""
+ eerror "Please make sure that ocaml is installed with tk support."
+
+ false;
+ else
+ echo "found tcltk USE flag, proceeding normally!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # patch the makefile to include DESTDIR support
+ cd ${S} || die
+ patch -p0 < ${DISTDIR}/${Name}-${PV}-Makefile-destdir.patch || die
+}
+
+src_compile() {
+ # make configuration file
+ cp ${DISTDIR}/${Name}-${PV}-Makefile.config ${S}/Makefile.config || die
+
+ # build
+ make all opt || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc README CHANGES COPYRIGHT
+}