summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-06-12 12:42:34 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-06-12 12:42:34 +0000
commit941de308ce8ccef394fa83489ccad9b3f841de3d (patch)
tree157c4c98a53815d2961ba5ba9a992cfe3124ce6b /dev-ml
parentvcs-snapshot.eclass, remove old. (diff)
downloadhistorical-941de308ce8ccef394fa83489ccad9b3f841de3d.tar.gz
historical-941de308ce8ccef394fa83489ccad9b3f841de3d.tar.bz2
historical-941de308ce8ccef394fa83489ccad9b3f841de3d.zip
version bump
Package-Manager: portage-2.2.0_alpha110/cvs/Linux x86_64
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ounit/ChangeLog7
-rw-r--r--dev-ml/ounit/ounit-1.1.2.ebuild21
-rw-r--r--dev-ml/pxp/ChangeLog7
-rw-r--r--dev-ml/pxp/pxp-1.2.3.ebuild50
4 files changed, 83 insertions, 2 deletions
diff --git a/dev-ml/ounit/ChangeLog b/dev-ml/ounit/ChangeLog
index 7f4b91f315f4..a9a871d7fff0 100644
--- a/dev-ml/ounit/ChangeLog
+++ b/dev-ml/ounit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ounit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.29 2012/05/29 19:37:39 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.30 2012/06/12 12:42:34 aballier Exp $
+
+*ounit-1.1.2 (12 Jun 2012)
+
+ 12 Jun 2012; Alexis Ballier <aballier@gentoo.org> +ounit-1.1.2.ebuild:
+ version bump
29 May 2012; Brent Baude <ranger@gentoo.org> ounit-1.1.1.ebuild:
Marking ounit-1.1.1 ppc for bug 416531
diff --git a/dev-ml/ounit/ounit-1.1.2.ebuild b/dev-ml/ounit/ounit-1.1.2.ebuild
new file mode 100644
index 000000000000..ad056d2440bc
--- /dev/null
+++ b/dev-ml/ounit/ounit-1.1.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.1.2.ebuild,v 1.1 2012/06/12 12:42:34 aballier Exp $
+
+EAPI="3"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="http://ounit.forge.ocamlcore.org/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/886/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+DEPEND=""
+RDEPEND="${DEPEND}"
+IUSE=""
+
+DOCS=( "README.txt" "AUTHORS.txt" "changelog" )
diff --git a/dev-ml/pxp/ChangeLog b/dev-ml/pxp/ChangeLog
index 6fbfc2eeff25..26b93ecbc2e2 100644
--- a/dev-ml/pxp/ChangeLog
+++ b/dev-ml/pxp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pxp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.26 2012/02/23 20:27:59 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.27 2012/06/12 12:41:42 aballier Exp $
+
+*pxp-1.2.3 (12 Jun 2012)
+
+ 12 Jun 2012; Alexis Ballier <aballier@gentoo.org> +pxp-1.2.3.ebuild:
+ version bump
23 Feb 2012; Alexis Ballier <aballier@gentoo.org> -pxp-1.2.1.ebuild:
remove old
diff --git a/dev-ml/pxp/pxp-1.2.3.ebuild b/dev-ml/pxp/pxp-1.2.3.ebuild
new file mode 100644
index 000000000000..3d983e2032ff
--- /dev/null
+++ b/dev-ml/pxp/pxp-1.2.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/pxp-1.2.3.ebuild,v 1.1 2012/06/12 12:41:42 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+MY_P=${P/_beta/test}
+
+DESCRIPTION="validating XML parser library for O'Caml"
+HOMEPAGE="http://projects.camlcity.org/projects/pxp.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SLOT="0"
+DEPEND=">=dev-ml/pcre-ocaml-4.31
+>=dev-ml/ulex-0.5
+>=dev-ml/ocamlnet-0.98
+>=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+IUSE="examples +ocamlopt"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ #the included configure does not support many standard switches and is quite picky
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all || die "make all failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ cd doc
+ dodoc ABOUT-FINDLIB DEV README SPEC design.txt
+}