summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuval Yaari <yuval@gentoo.org>2008-04-29 06:19:06 +0000
committerYuval Yaari <yuval@gentoo.org>2008-04-29 06:19:06 +0000
commit6e2e803cb5f82e813cca8ffb3cb9c007ce269f3f (patch)
tree108039da3ceeb1800f6296186ec4617febfb55ac /dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild
parentTook maintainace. amd64 stable. (diff)
downloadhistorical-6e2e803cb5f82e813cca8ffb3cb9c007ce269f3f.tar.gz
historical-6e2e803cb5f82e813cca8ffb3cb9c007ce269f3f.tar.bz2
historical-6e2e803cb5f82e813cca8ffb3cb9c007ce269f3f.zip
Version bump
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild')
-rw-r--r--dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild b/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild
new file mode 100644
index 000000000000..43ba67e8bb42
--- /dev/null
+++ b/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Crypt-Cracklib/Crypt-Cracklib-1.2.ebuild,v 1.1 2008/04/29 05:58:06 yuval Exp $
+
+inherit perl-module
+
+AUTHOR="DANIEL"
+DESCRIPTION="Perl interface to Alec Muffett's Cracklib"
+HOMEPAGE="http://search.cpan.org/~daniel/${P}/"
+SRC_URI_BASE="mirror://cpan/authors/id/${AUTHOR:0:1}/${AUTHOR:0:2}/${AUTHOR}/"
+SRC_URI="${SRC_URI_BASE}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/cracklib
+ dev-lang/perl"
+
+src_compile() {
+ # this ebuild is very non-standard it seems
+ echo -en "/usr/include\n/usr/lib\n"| perl Makefile.PL
+ emake
+}
+
+src_install() {
+ myinst="DESTDIR=${D}"
+ perl-module_src_install
+}