summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-07-03 00:48:12 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-07-03 00:48:12 +0000
commitb4dd31702265eed5d124a9218cd80c7ec4916836 (patch)
tree8e4225481209bfff4e01d5d0b5c70a92c4bd7992 /dev-perl/Inline
parentAddresses bug 17223, patch submitted by Kfir Ozer <ufk2k@yahoo.com> (diff)
downloadhistorical-b4dd31702265eed5d124a9218cd80c7ec4916836.tar.gz
historical-b4dd31702265eed5d124a9218cd80c7ec4916836.tar.bz2
historical-b4dd31702265eed5d124a9218cd80c7ec4916836.zip
Addresses bug 17223, patch submitted by Kfir Ozer <ufk2k@yahoo.com>
Diffstat (limited to 'dev-perl/Inline')
-rw-r--r--dev-perl/Inline/Manifest4
-rw-r--r--dev-perl/Inline/files/digest-Inline-0.44-r11
-rw-r--r--dev-perl/Inline/files/gtk2-patch.diff32
3 files changed, 35 insertions, 2 deletions
diff --git a/dev-perl/Inline/Manifest b/dev-perl/Inline/Manifest
index b8e492622294..dc6ebf9aaa0c 100644
--- a/dev-perl/Inline/Manifest
+++ b/dev-perl/Inline/Manifest
@@ -1,7 +1,7 @@
-MD5 b946a137b2b13fe3e1f9e893050dbe99 ChangeLog 934
+MD5 bd530b49cf0fc6be88835b5a1335c1ad ChangeLog 1140
MD5 d7641c0ff9ed5b01213d01e4e1ba5751 Inline-0.43-r1.ebuild 698
MD5 2cc0bb525fdf75f5d6ba9387726007d0 Inline-0.43.ebuild 696
-MD5 1efc6496fffc33ec01e852c8401dd4b5 Inline-0.44-r1.ebuild 924
+MD5 0983b2707d656c14bb16693262edd88f Inline-0.44-r1.ebuild 928
MD5 f3ba519214d153d8004e85d8c11b03c9 Inline-0.44.ebuild 796
MD5 10cb079ed55ec2e6b331b3b4d2a108a1 files/digest-Inline-0.43 62
MD5 10cb079ed55ec2e6b331b3b4d2a108a1 files/digest-Inline-0.43-r1 62
diff --git a/dev-perl/Inline/files/digest-Inline-0.44-r1 b/dev-perl/Inline/files/digest-Inline-0.44-r1
new file mode 100644
index 000000000000..6de2ec935f2b
--- /dev/null
+++ b/dev-perl/Inline/files/digest-Inline-0.44-r1
@@ -0,0 +1 @@
+MD5 840f47d9b6cef39e68370faf9dceab2c Inline-0.44.tar.gz 91450
diff --git a/dev-perl/Inline/files/gtk2-patch.diff b/dev-perl/Inline/files/gtk2-patch.diff
new file mode 100644
index 000000000000..bf28ec596f7b
--- /dev/null
+++ b/dev-perl/Inline/files/gtk2-patch.diff
@@ -0,0 +1,32 @@
+*** Inline-0.44/lib/Inline/denter.pm-orig 2001-06-13 06:30:50.000000000 +0200
+--- Inline-0.44/lib/Inline/denter.pm 2002-11-13 15:43:41.000000000 +0100
+***************
+*** 177,182 ****
+--- 177,183 ----
+ }
+
+ sub _next_line {
++ local ($_);
+ my $o = shift;
+ $o->{done}++, $o->{level} = -1, return unless @{$o->{lines}};
+ $_ = shift @{$o->{lines}};
+***************
+*** 188,193 ****
+--- 189,195 ----
+ $o->{done}++, $o->{level} = -1, return unless @{$o->{lines}};
+ my ($width, $tabwidth) = @{$o}{qw(width tabwidth)};
+ while (1) {
++ local ($_);
+ $_ = $o->{lines}[0];
+ # expand tabs in leading whitespace;
+ $o->next_line, next if /^(\s*$|\#)/; # skip comments and blank lines
+***************
+*** 221,226 ****
+--- 223,229 ----
+
+ sub indent_data {
+ my $o = shift;
++ local ($_);
+ $_ = shift;
+ return $o->indent_undef($_)
+ if not defined;