summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-06-16 19:59:01 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-06-16 19:59:01 +0000
commit8d41b6c74daa9f3c398460b46907795d3bd2bb32 (patch)
tree7a71b9821d7295b49e564102054b43923dc2a704 /dev-perl/OpenGL/OpenGL-0.660.0.ebuild
parentInitial import of Hash-MoreUtils required (indirectly) by the new google-api-... (diff)
downloadhistorical-8d41b6c74daa9f3c398460b46907795d3bd2bb32.tar.gz
historical-8d41b6c74daa9f3c398460b46907795d3bd2bb32.tar.bz2
historical-8d41b6c74daa9f3c398460b46907795d3bd2bb32.zip
Initial import
Package-Manager: portage-2.1.10.63/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/OpenGL/OpenGL-0.660.0.ebuild')
-rw-r--r--dev-perl/OpenGL/OpenGL-0.660.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/OpenGL/OpenGL-0.660.0.ebuild b/dev-perl/OpenGL/OpenGL-0.660.0.ebuild
new file mode 100644
index 000000000000..178b41414f21
--- /dev/null
+++ b/dev-perl/OpenGL/OpenGL-0.660.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/OpenGL/OpenGL-0.660.0.ebuild,v 1.1 2012/06/16 19:59:01 bicatali Exp $
+
+EAPI=4
+
+MODULE_AUTHOR="CHM"
+MODULE_VERSION=0.66
+
+inherit perl-module eutils
+
+DESCRIPTION="Perl interface providing graphics display using OpenGL"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/freeglut
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+mydoc="Release_Notes"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-display.patch
+}
+
+src_compile() {
+ sed -i -e 's/PERL_DL_NONLAZY=1//' Makefile || die
+ perl-module_src_compile
+}