summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2006-01-13 16:12:09 +0000
committerMichael Cummings <mcummings@gentoo.org>2006-01-13 16:12:09 +0000
commit571d6a1cc86f5bb03443cb9a7351c00786583d2c (patch)
treec6cb22cd219cc942ad9d4d45880420bc2cf2cf65 /dev-perl/SOAP-Lite
parentVersion bump upstream (diff)
downloadhistorical-571d6a1cc86f5bb03443cb9a7351c00786583d2c.tar.gz
historical-571d6a1cc86f5bb03443cb9a7351c00786583d2c.tar.bz2
historical-571d6a1cc86f5bb03443cb9a7351c00786583d2c.zip
Version bump
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'dev-perl/SOAP-Lite')
-rw-r--r--dev-perl/SOAP-Lite/ChangeLog10
-rw-r--r--dev-perl/SOAP-Lite/Manifest12
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-0.66.ebuild50
-rw-r--r--dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.661
4 files changed, 61 insertions, 12 deletions
diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
index b95162f04670..a5e8a6572bb7 100644
--- a/dev-perl/SOAP-Lite/ChangeLog
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/SOAP-Lite
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.22 2005/12/30 11:57:04 mcummings Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.23 2006/01/13 16:10:08 mcummings Exp $
+
+*SOAP-Lite-0.66 (13 Jan 2006)
+
+ 13 Jan 2006; Michael Cummings <mcummings@gentoo.org>
+ +SOAP-Lite-0.66.ebuild:
+ Version bump
30 Dec 2005; <mcumming@gentoo.org> SOAP-Lite-0.60a-r1.ebuild,
-SOAP-Lite-0.60a.ebuild:
diff --git a/dev-perl/SOAP-Lite/Manifest b/dev-perl/SOAP-Lite/Manifest
index 77a90d2c1c48..27d10acbb28b 100644
--- a/dev-perl/SOAP-Lite/Manifest
+++ b/dev-perl/SOAP-Lite/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 3f23d6a6d142cd800aac8292a030b82b ChangeLog 3268
MD5 03e1610150a202705650e6a938eb8024 SOAP-Lite-0.55.ebuild 813
MD5 bccf98001439cc65a9f1173b8c52620d SOAP-Lite-0.60a-r1.ebuild 1550
+MD5 9670c3aee94122196d0c85ac76e2853b SOAP-Lite-0.66.ebuild 1446
MD5 0c6fe7b828190ad115d346daf86d4c67 files/SOAP-Lite-0.60.a.patch 652
MD5 a28ac4a4bb16719e4bd3ce3c6ab5e08b files/digest-SOAP-Lite-0.55 66
MD5 6d49bd1e5b967a5a203500df88e8c738 files/digest-SOAP-Lite-0.60a-r1 67
+MD5 d366a295adee3b17a6b73e544f3146a7 files/digest-SOAP-Lite-0.66 66
MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD4DBQFDtSCZtG5z4I8BtQoRAkwmAJdZyfOQ1DkK0blpGFIZCgCdKNnVAJ9G8e+b
-jCOfrPWoWBtFBX7S8uPlIA==
-=DlBr
------END PGP SIGNATURE-----
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.66.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.66.ebuild
new file mode 100644
index 000000000000..b0e8c8713c16
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.66.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.66.ebuild,v 1.1 2006/01/13 16:10:08 mcummings Exp $
+
+IUSE="jabber ssl"
+
+inherit perl-module eutils
+
+MY_PV=${PV/a//}
+MY_P=SOAP-Lite-${MY_PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Provides a simple and lightweight interface to the SOAP protocol (sic) both on client and server side."
+
+SRC_URI="mirror://cpan/authors/id/B/BY/BYRNE/SOAP/${P}.tar.gz"
+HOMEPAGE="http://search.cpan.org/~byrne/${P}"
+
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+myconf="${myconf} --noprompt"
+
+# TESTS ARE DISABLED ON PURPOSE
+# This module attempts to access an external website for validation
+# of the MIME::Parser - not only is that bad practice in general,
+# but in this particular case the external site isn't even valid anymore# -mpc
+# 24/10/04
+#SRC_TEST="do"
+
+DEPEND="${DEPEND}
+ dev-perl/XML-Parser
+ dev-perl/libwww-perl
+ perl-core/libnet
+ dev-perl/MIME-Lite
+ perl-core/MIME-Base64
+ ssl? ( dev-perl/Crypt-SSLeay )
+ jabber? ( dev-perl/Net-Jabber )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ dev-perl/Compress-Zlib
+ >=dev-perl/MIME-tools-5.413"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # The author of this module put a dep for MIME::Parser 6.X - but the6.X
+ # release of MIME::Parser was a mistake during a change in maintainers on
+ # cpan. This patch alters the dependancy to the "real" stable version of
+ # MIME::Parser.
+ epatch ${FILESDIR}/SOAP-Lite-0.60.a.patch
+}
diff --git a/dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.66 b/dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.66
new file mode 100644
index 000000000000..9f211b5cfb24
--- /dev/null
+++ b/dev-perl/SOAP-Lite/files/digest-SOAP-Lite-0.66
@@ -0,0 +1 @@
+MD5 2342b450775fb0a8ca579fd1dee0d9b2 SOAP-Lite-0.66.tar.gz 236804