summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-05-06 23:42:43 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-05-06 23:42:43 +0000
commit4624b2c5a46116a8b1903a24e470ffcc6526f7b5 (patch)
treee76a73fc5a072f11f99b5bf99c7c405ccc3816d3 /dev-perl/gtk-perl-glade/gtk-perl-glade-0.7004-r2.ebuild
parentadded missing author in header (diff)
downloadhistorical-4624b2c5a46116a8b1903a24e470ffcc6526f7b5.tar.gz
historical-4624b2c5a46116a8b1903a24e470ffcc6526f7b5.tar.bz2
historical-4624b2c5a46116a8b1903a24e470ffcc6526f7b5.zip
eclassed
Diffstat (limited to 'dev-perl/gtk-perl-glade/gtk-perl-glade-0.7004-r2.ebuild')
-rw-r--r--dev-perl/gtk-perl-glade/gtk-perl-glade-0.7004-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/gtk-perl-glade/gtk-perl-glade-0.7004-r2.ebuild b/dev-perl/gtk-perl-glade/gtk-perl-glade-0.7004-r2.ebuild
new file mode 100644
index 000000000000..ee6480d3b991
--- /dev/null
+++ b/dev-perl/gtk-perl-glade/gtk-perl-glade-0.7004-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Tools Team <tools@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk-perl-glade/gtk-perl-glade-0.7004-r2.ebuild,v 1.1 2002/05/06 23:42:43 seemant Exp $
+
+. /usr/portage/eclass/inherit.eclass || die
+inherit perl-module
+
+S=${WORKDIR}/Gtk-Perl-${PV}
+DESCRIPTION="Perl bindings for GTK"
+SRC_URI="ftp://ftp.rz.ruhr-uni-bochum.de/pub/CPAN/authors/id/L/LU/LUPUS/Gtk-Perl-${PV}.tar.gz"
+HOEMPAGE="http://www.perl.org/"
+
+DEPEND="${DEPEND}
+ >=dev-perl/gtk-perl-${PV}
+ dev-util/glade"
+
+src_compile() {
+ perl Makefile.PL
+ emake || die
+ cd Glade
+ perl Makefile.PL
+ emake || die
+}
+
+src_install() {
+ cd Glade
+ make PREFIX=${D}/usr INSTALLMAN3DIR=${D}/usr/share/man/man3 install || die
+}