summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2003-06-25 00:54:27 +0000
committerRobert Coie <rac@gentoo.org>2003-06-25 00:54:27 +0000
commit0b80a6b07bd81a2b98b8a0118014b5743a003a7f (patch)
tree09ab535a0e6c9ef8ca9f1f33f7799b93ac5c9a5f /dev-perl/mod_perl
parentchanging configuration process around (diff)
downloadhistorical-0b80a6b07bd81a2b98b8a0118014b5743a003a7f.tar.gz
historical-0b80a6b07bd81a2b98b8a0118014b5743a003a7f.tar.bz2
historical-0b80a6b07bd81a2b98b8a0118014b5743a003a7f.zip
changing configuration process around
Diffstat (limited to 'dev-perl/mod_perl')
-rw-r--r--dev-perl/mod_perl/Manifest4
-rw-r--r--dev-perl/mod_perl/files/digest-mod_perl-1.27-r31
-rw-r--r--dev-perl/mod_perl/mod_perl-1.27-r3.ebuild79
3 files changed, 82 insertions, 2 deletions
diff --git a/dev-perl/mod_perl/Manifest b/dev-perl/mod_perl/Manifest
index ed584114ee58..219ddc114981 100644
--- a/dev-perl/mod_perl/Manifest
+++ b/dev-perl/mod_perl/Manifest
@@ -3,8 +3,8 @@ MD5 b04e594ce1aa3379787924322454aba5 mod_perl-1.27.ebuild 1416
MD5 a248818699df0c2bede5761b7b67cd4c mod_perl-1.27-r2.ebuild 1797
MD5 026fbb84b447f735b4c86b46860f2afb mod_perl-1.99.08.ebuild 1244
MD5 58ceed38b57307fa4190170a23408524 mod_perl-1.27-r1.ebuild 1421
-MD5 16dd03050f2cc0c430f9388cad41fefe ChangeLog 3027
-MD5 94925d26f01b6603a7b6116f9d739079 mod_perl-1.27-r3.ebuild 2009
+MD5 7aecbe36dd285e1a1becaf941c760130 ChangeLog 3027
+MD5 60e7a045de6820eeb93486d0a7747405 mod_perl-1.27-r3.ebuild 2004
MD5 05455750ba5b64e18dbcfd113193e7cd files/digest-mod_perl-1.27-r1 65
MD5 05455750ba5b64e18dbcfd113193e7cd files/digest-mod_perl-1.27-r2 65
MD5 05455750ba5b64e18dbcfd113193e7cd files/digest-mod_perl-1.27-r3 65
diff --git a/dev-perl/mod_perl/files/digest-mod_perl-1.27-r3 b/dev-perl/mod_perl/files/digest-mod_perl-1.27-r3
new file mode 100644
index 000000000000..100b74cf1c13
--- /dev/null
+++ b/dev-perl/mod_perl/files/digest-mod_perl-1.27-r3
@@ -0,0 +1 @@
+MD5 bd07f4f1065eb0d0a8d8004219357d8c mod_perl-1.27.tar.gz 372525
diff --git a/dev-perl/mod_perl/mod_perl-1.27-r3.ebuild b/dev-perl/mod_perl/mod_perl-1.27-r3.ebuild
new file mode 100644
index 000000000000..874d3026b9b4
--- /dev/null
+++ b/dev-perl/mod_perl/mod_perl-1.27-r3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/mod_perl/mod_perl-1.27-r3.ebuild,v 1.1 2003/06/25 00:54:25 rac Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Perl Module for Apache"
+SRC_URI="http://perl.apache.org/dist/${P}.tar.gz"
+HOMEPAGE="http://perl.apache.org"
+
+SLOT="0"
+LICENSE="Apache-1.1 as-is"
+KEYWORDS="x86 amd64 ~ppc ~sparc ~alpha"
+
+DEPEND="dev-lang/perl dev-perl/libwww-perl =net-www/apache-1*"
+
+IUSE="ipv6"
+
+inherit eutils
+
+src_unpack() {
+ unpack ${A}
+
+ if [ "`use ipv6`" ]
+ then
+ # This patch originally came from
+ # http://pasky.ji.cz/~pasky/dev/apache/mod_perl-1.27+ipv6.patch.
+ # It allows mod_perl to correctly build with an IPv6-enabled
+ # Apache (bug #6986).
+ # Robert Coie <rac@gentoo.org> 2002.02.19
+
+ cd ${S}; epatch ${FILESDIR}/${P}-ipv6.patch
+ fi
+}
+
+src_compile() {
+ perl Makefile.PL USE_APXS=1 \
+ INSTALLDIRS=vendor \
+ WITH_APXS=/usr/sbin/apxs EVERYTHING=1
+
+ cp Makefile Makefile.orig
+ sed -e "s:apxs_install doc_install:doc_install:" Makefile.orig > Makefile
+ emake || die
+}
+
+src_install () {
+ eval `perl '-V:installvendorarch'`
+ eval `perl '-V:installvendorlib'`
+
+ make \
+ PREFIX=${D}/usr \
+ INSTALLVENDORARCH=${D}/${installvendorarch} \
+ INSTALLVENDORLIB=${D}/${installvendorlib} \
+ INSTALLVENDORMAN1DIR=${D}/usr/share/man/man1 \
+ INSTALLVENDORMAN3DIR=${D}/usr/share/man/man3 \
+ pure_vendor_install || die
+
+ dodoc Changes CREDITS MANIFEST README SUPPORT ToDo
+ dohtml -r ./
+
+ cd apaci
+ exeinto /usr/lib/apache-extramodules
+ doexe libperl.so
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Execute \"ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config\""
+ einfo "to have your apache.conf auto-updated for use with this module."
+ einfo "You should then edit your /etc/conf.d/apache file to suit."
+ einfo
+}
+
+pkg_config() {
+ ${ROOT}/usr/sbin/apacheaddmod \
+ ${ROOT}/etc/apache/conf/apache.conf \
+ extramodules/libperl.so mod_perl.c perl_module \
+ define=PERL
+ :;
+}